Jump to content

Recommended Posts

Hello guys, i hope this is the right section. I'm having a strange issue with this pin2dmd i have built up. When connected to the PC the display works but when connected to the pinball it remains black. 

I have tried setting voltage on the stepdown to 4.9 and 5.1 and also to move the little jumper both on E5V and U5V, but nothing changes. I have tried to compare it with another working DMD and it seems that different LEDs are flashing:


Working DMD

Power led on nucleo board is ON

On ST Board:

LD4 COM Flashing

LD6 on

blue LD2 on


Nonworking DMD

Power led on nucleo board is ON

On ST Board:

LD4 COM Flashing

LD6 on

LD7 is on


The pinball i have tested them with is a Bally TZ and both where linked to J116 on the Power drive board.

Although the voltage is present on the nucleo board, I have tried to use the stepdown of the working one on the other but the problem is still there...

Any advice for a solution? What about those different LEDs ?

Some pics attached!


Thank you in advance 








Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...