Jump to content

Bug in ST-Link firmware V2.J36.M26?


Recommended Posts

Hey folks,

Just built my first PIN2DMD using a V4 shield and Nucleo-F439 (for a real pin, Data East, 128x32) and was getting very strange startup issues (see video). The only way I could get it to start was to press the reset button on the Nucleo board (I press it at about 15 seconds).

This is my first PIN2DMD, so I thought it must be my soldering, a faulty component or the power supply, but everything checked out. I even re-flashed the ST Link and PIN2DMD firmware with the same result.

Finally, I decided to load an earlier version of the ST-Link firmware and it worked. Im now using V2.J35.M26

I cant tell if this affects other configs, but it may help someone!



Link to comment
Share on other sites

  • 1 year later...

I'm having the exact same problem more and more often. Currently, I have 3 new nucleos doing the same thing. I have already tried to downgrade the st-link but without success. I tried with firmware 3.5 and 4.0...same problem. An idea ?

Link to comment
Share on other sites

  • Content Provider
8 hours ago, aganyte said:



This thread gave me the solution 





I had tried to downgrade ST-Link but with a not old enough firmware.  I found an older ST-link utility on my NAS (V2.J34.M26). Now everything is working fine.




I added the recommended HSE startup timout change to the HAL config. Funny thing is that STM32H7 already is set to 5000 and the old F4 StandardPeripheral Lib had 0x500 set as hex value which is 1280 instead of the 300 in the latest HAL ???!!!

As it does not do any harm I set it to 5000 for all CPU types in the bootloader and the pin2dmd firmware for release V4.41 which is now on github.


Link to comment
Share on other sites

  • 2 months later...
  • Content Provider
3 hours ago, h4fl4 said:

Unfortunately, got the same problem. Spent hours checking my shields etc.  Got v4.43  installed and still need to press reset to turn it on? Any ideas?



This has NOTHING to do with my firmware. You need to update/downgrade your ST-LINK firmware as described above and on pin2dmd.com

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...