Jump to content

Recommended Posts

I ordered six shield boards using the information on the Pin2DMD site. Ordered all the parts from the parts list and built a board. All worked great for about 5 minutes and then the screen froze. I restarted and then it just stayed on the splash screen with Bally/Williams on it. Could not get it to work. I shut everything off and came back later and it worked for 30 seconds or so and froze again and stopped working. I tried a different nucleo board and same result. Tried without the color files and when it did work it would display the 4 color palette and then freeze and stop working. Put  a known working shield board in and it worked fine. So basically I narrowed it down to the new shield board. Decided to just build another one. The new one does the same exact thing. I've swapped ribbon cables. I even put the new setup in my Data East Star Wars and it freezes just line in the Bally. I'm running out of ides. 

 

It appears to be a communication issue and seems to get worse the longer the board is on. When it fails it stays failed. Any one have an idea of where to look on the board for this? I do a lot of my own board work but this has me stumped. 

 

Thanks in advance

 

Lonny

 

Link to comment
Share on other sites

  • Content Provider

Did you doublecheck the components you soldered to the new shield ?

If you used sockets for the ICs try swapping the LS123.

Link to comment
Share on other sites

I swapped both chips with the ones on my older shield and no help and the older shield works fine with the chips that were on the new board. 

 

It reads the color palate and runs normally for 30 seconds to a minute and then freezes. It will not work again until you turn it off and let it sit for 10 minutes or so and then it will do it again. When its not working and just displaying the splash screen, it does load the palate and change the colors but just sits at the splash screen. 

Link to comment
Share on other sites

  • 2 months later...

 

hi, I'm having this same problem with nucleo shield v4 displays that don't work with a realpin.  everything works correctly with a virtual one but the realpin is frozen in the initial screen of the PIN2DMD logo.  Is there anything I need to do for this to work?  The color palette is recognized and so is activation.  everything seems ok to me, it just freezes in a real pinball.  this v4 model is there something related to a jumper like the previous models or is there no need?

IMG_20220727_110400.jpg

Edited by kbueno
Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
  • Create New...