Jump to content

Recommended Posts

Hey guys,

 

I recently bit the bullets and upgraded to 1.10.1 to get the 64 color on my PinDMD3. Everything works terrific with VPX and PinballFX3, but the mirror I set up for P-Roc has stopped working.

 

The original .bat file i had load was:

- - - -

@echo off
START /min "" "C:\Pinball Emulators\Visual Pinball\VPinMAME\dmdext.exe" mirror --source screen --position 0 0 128 32 --no-virtual -p COM5 -d pindmdv3

- - - -

 

This no longer mirrors the P-Roc DMD from the screen anymore.

 

Did a paramater or syntax change that I need to update the param with for it to work?

 

I read through all the dmdext threads and things and I can't seem to find any answer.

 

Any help would be greatly appreciated.

 

Thanks.

Link to comment
Share on other sites

Link to comment
Share on other sites

  • Content Provider

Good News,

 

I inadvertently found a fix that worked with the new dmdext.exe

 

My previous param for my .bat file was this:

 

- - - -

@echo off
START /min "" "C:\Pinball Emulators\Visual Pinball\VPinMAME\dmdext.exe" mirror --source screen --position 7040 0 128 32 --no-virtual -p COM5 -d pindmdv3

- - - -

and in the CCC user_settings.yml I set the DMD position to 7040 0 and set the pixel shape to SQAURE

 

7040 was based on: 3840 playfield with + 1920 backglass width + 1280 topper width - and then having P-Roc make the DMD 128 x 32 for the cleanest (non-scaled) DMD to be mirrored.

 

This put the the DMD onto my 4th screen which is a DUMMY display port plug that simulates having a 4th screen - this all worked previously.

 

THE NEW DMDEXT.EXE didn't recognize this - but when I changed the numbers in the param to 7040 0 7068 32 (basically adding the first position number to the width of the DMD) - suddenly worked perfectly.

 

This was a total accident because when I edited the param I put the numbers in the wrong order and I noticed I caught the corner end of the mirrored DMD on my real PinDMD3 - so when I fine tuned the numbers - it worked.

 

I don't know if this was a bug in dmdext or the param requirements changed - but regardless it worked with the new 1.10.1 dmdext and CCC was the only game I was having an issue with.

 

Hope this info helps.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
  • Create New...