Jump to content

Recommended Posts

Greetings all - Tonight I installed my first Pin2DMD and have hit a wall with a problem.  I have a Star Wars Data East and can't get the game out of 4 color mode.  I've got the board activated and confirmed I have the correct real pin files from CB3.  

 

I think I've done the process right to get this working; but, if anyone has any suggestions or can confirm if I'm right or wrong, I would greatly appreciate it.  

 

- Activated board (thanks Lucky1)

- Placed the license on the SD card

- Updated the firmware to the latest

- Went in and set the game to Data East mode in the Device Mode and saved the config.  I can see it boot back to Data East on a power off/on.  

- Placed the .fsq and .pal files into the root of the flash along with the key and also see the config file that gets made after the settings change.  

 

The game is stuck in 4 color mode and I can't get it out of it.   I looked through the SWDE colorization thread and I didn't see a clear cut answer; but, I wonder if the issue is my game rom is 1.04 and if that is what needs updating.  The sad thing is I know I've got the latest code somewhere around here; but, I've just moved the games into a new room and can't find it.  

 

Beyond the game rom being the issue, is there anything else I'm missing?

 

I've got one more EVO board that I can try swapping into the game; but, since it's actually "working" minus the color - I think it's not the board.  

 

Many thanks in advance!

Link to comment
Share on other sites

  • Content Provider

Confirm your Pin2dmd is actually activated.

 

Go into the config and select display UID. It should show your UID and nothing will change. If it says "Not activated" then there is an issue with activation and the colour file will never load. See the SD card info below.

 

If it is activated, boot the Pin2dmd without the data cable connected. The DATA EAST/SEGA text and the colours at the top of the screen will change. I believe it should have some orange in there, but you will clearly see the colour palette change. If this does not change, it means the PAL is not being loaded. 

 

From here I would double check your SD card and maybe try another one. Confirm your firmware is 4.30 after the update which will also show at the boot screen.

 

Finally, if you've checked all that, I would do a reset on the pin2dmd WHILE the SD card is inserted. If it has it's own config it may not overwrite the settings.

 

Let us know how you go.

Link to comment
Share on other sites

Thanks for the assistance.  Below are the updates:

 

Terranigma - I did confirm the device is active.  

Without the data cable attached, the device does boot to Data East/Sega.  The text changes color to orange/red; but, the palette above the logo doesn't change.  

The firmware is 4.30 and I used the same SD card to activate and update it.   

I did try 4 different SD cards from 2 different vendors with the same results.

I have reset the device with the SD card in and confirmed it requires setup again back to Data East/Sega.  

 

Chesco - I'll attach a screenshot below of the SD config.

 

In addition to the above, I also pulled the other Pin2DMD I purchased from another real pin user (last used in Addams Family) and tried it in SWDE and it's doing the same thing - not playing the colorization file and just 4 colors.  

 

My game rom is v1.04, so I'm wondering if that is the issue and it needs updated to pick up the sync since the first thing displayed by the game is a screen with the version info?

 

 

swde_sd_pin2dmd.JPG

Link to comment
Share on other sites

Thank you!

 

I actually figured it out while I was moving my ColorDMD out of IJPA and swapping the PIn2DMD in there.   The colorization files were noted to change the name.   

 

All good now on SWDE after what seemed like a million times pulling the DMD out of SWDE since you can't control or eject the card while it's in the game as the driver board and frame block it. 

Link to comment
Share on other sites

  • Content Provider
9 hours ago, jedimastermatt said:

All good now on SWDE after what seemed like a million times pulling the DMD out of SWDE since you can't control or eject the card while it's in the game as the driver board and frame block it. 

 

Yes, working on a solution for this. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
  • Create New...