Jump to content

Some Tables hanging at "Starting Game Scripts".. B2S???


Recommended Posts

  • Content Provider

I've been recently noticing some odd loading behavior and am hoping someone may have seen this or would know how to address.

Some of my tables are taking a looong time to load and if I Alt-Tab I can see that VPX has a dialog sitting at "Starting Game Scripts".  The tables eventually will load.  I've tried this with Popper and directly from VPX.  The tables happen to have PUP pacacks as well...

Master of the Universe - This table was taking long (1.5mins+) to load.  I found that if I had the table outside of my Tables folder it loaded really fast.  Through many iterations I removed things from my tables dir until I figured out what it was.  In this case it was was my B2STableSettings.xml.  What's odd is that this table did not even have an entry in there.  I found it was the defualt <DefaultStartMode> was set to 2 and if I changed to 1 it loaded fast again..In the end I added a block to the file for <motu> and had <StartAsEXE> set to 1 and changed the <DefaultStartMode> back to 1…and it seemed to work. 

I'm not sure what DefaultStartMode does for tables not running a B2S, but I can try setting it to 2..but I'm shooting in the dark here!  I can't find a schema or explanation for the fields in the B2STableSettings.xml file...

I tried to launch The Munsters this morning and I'm seeing similar behavior where it takes long to load sitting on "Starting Game Scripts".   I haven't had a chance to see if I launch the table outside of the Tables folder if it will launch differently.

Neither table runs a B2S.  I suspect B2S runs due to DOF or something... I'm not even certain the problem is with B2S for Munsters, its just what I noticed helped MOTU...It is odd that I'm suddenly having this issue with multiple tables however...not all though.

The only other thing I can think of is that recently install P-ROC and I'm trying to see if that registered something or messed with B2S in some way...

Any ideas would be appreciated!!


Link to comment
Share on other sites

  • 4 months later...
  • Content Provider

@danpowi changed the way I was using B2S in that I had B2S generate a new xml file.  In my B2S settings I set X Offset equal to 1 which magically removes the grill and dmd from all tables and alleviated the need for so many entries in the xml files.


I suspect my file had become too large for B2S and it would choke on it (just my theory).


Since I made the change, and have a clean file, I have not seen the issue since.


if you were to try it, I’d recommend you backup your existing xml just in case..


I hope it helps!!

Link to comment
Share on other sites

@scampa123thanks for the info - i've done some more testing and my problems completely stop when I 'disable B2S' in VPX prefs. I wish, like you, I could find more hard info on the xml schema...

I did some reading and spotted that B2SBackglassServerRegisterApp.exe is supposed to be run as admin. It wasn't on my system. I only changed that today, and haven't had any problems yet, but it's early days...


if the problems reappear i'll look at implementing your xml changes and report back.

@Thalamus my xml file only held entries for a dozen or so games, and is 16KB on disk, so i'm not sure the file size would be an issue in my circumstamce.


Link to comment
Share on other sites

  • 1 month later...
  • Content Provider

This started happening again.  Many of my tables will hang for a while before starting due to my B2STableSettings.xml....How do I know it is that?  Because if I remove the file from my tables directory my table will start fast....


I think something must have happened to it while updating the backglass for PROC Knight Rider...


I tried removing the games block (I attached the bad one and there are only two as you will see) but the file still causes the issue.. I tried loading AC/DC and TAF (both with PUPs too if it matters)..


I have found that if I remove the xml...launch a B2S table and right click to reenable my plugins it will generate a new xml which works for me...I've even copied over the Knight Rider block and saved and it works fine...


So I'm running fine again (thankfully) and am documenting here for other...


So my question is, what is writing the block to the file?  Could the Knight Rider table have somehow done something to my xml file?  Or does B2SServer have a scenario where it fails writing the file completely.  The file itself appears normal (see attached), but something is wrong with it.  Maybe encoding? Not sure…


thanks gang



Link to comment
Share on other sites

  • 1 year later...
  • 2 months later...

I too am having this issue. I tried renaming the B2STableSettings.xml to a different name and it did in fact load the tables much faster. However, I ran into a problem where pup packs are either not loading or are loading to a position where I can't see them. Not sure if this is related to the change or if it was a system update that caused this as my screen numbers in VPX also got rearranged. I would say the slow load definitely has to do with the table settings file in some way.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...