Jump to content

teensy stops working sometimes


Recommended Posts

I've got a teensy for addressable LED's and on occasion I'll boot up the virtual pinball machine to find that the addressable LED's are not working. 

I can usually get it working with some combination of:

1) pressing the reset button the teensy

2) Unplugging the RJ45 cables from the OctoWS2811 

3) unplugging and plugging the USB cable from the teensy

4) powering down the PC

5) unplugging the PC and waiting for 10 or 20 seconds for my power supplies to discharge


Those 5 steps are involved in getting it working, but I don't which one or the magic that's making it work.  I don't think any one step by itself was helping.  I do always get it to come back up and work but I'm at a loss as to why it would do this. 


What trouble shooting steps should I take next time this happens?


Link to comment
Share on other sites

  • 1 month later...

Okay... so the way that this gets fixed for me 100% of the time.

1) I unplug the USB cable from the teensy.  (PC makes USB disconnect sound)

2) I disconnect the 5V from the Octo2811 board...  

3) I plug in the USB cable back into the teensy. (PC makes USB reconnect sound)

4) I reapply the 5v lead to the Octo2811 board.


Everything works at this point.


Do I even need the 5V line connected to the WS2811 board?  Maybe I need to tie the grounds together from the 5V power supply to the PC power supply?

I bought a replacement Teensy to try that, but I'm really thinking it has something to do with either separate power supplies, or the teensy getting power before it has USB connection.


Anyone else have any ideas?






Link to comment
Share on other sites

  • 1 month later...
  • 1 year later...

Wondering if a fix was found for this, as I am having similar issues:


Addressable lights work anywhere from 30s to 3 minutes.   At that point, the LEDs either freeze with what ever trigger was hit, or if none the LEDs remain black.  I have to stop DOF.exe, reset the USB connection, and restart DOF.exe.


I know DOF is working and continues to work, because all the other toys continue to work, after LEDs stop working.  DOF indicates 0 errors, as it is working fine.


I have tried different, USB ports, USB cables, purchased new USB PCI board to try different ports, as well as checked the USB not to suspend - all yield in same issue.


I am wondering if it is the Actual Teensy board having an issue.    


Anyone else experience something similar or currently experiencing the same?

Edited by seesitee
Link to comment
Share on other sites

  • 2 years later...

Hello, I have exactly the same problem. Teensy 4.0 on OctoWS2811 Freeze after 30 seconds to 10 minutes. Has the problem been solved? Does somebody has any idea.

Thank you for your help.

Many greetings


Link to comment
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...