Jump to content

Warning about cheap chinese STM32F4 discovery board clones


Recommended Posts

Recently some cheap chinese clones of the STM32F4 discovery board have surfaced on ebay and aliexpress.These boards DON´T work with pin2dmd because of missing or wrong parts mounted on the pcb. They can be identified by the green audio socket and the missing STM32 logo on the pcb. Please make sure you order a genuine STM32 board for your pin2dmd project or better use the NUCLEO STM32F429ZI based pin2dmd which has e.g faster SD card access and supports more pinball machines (128x16 DataEast) Here is a picture of the original (top) and the clone (bottom)


Link to comment
Share on other sites

  • lucky1 pinned this topic
  • 1 month later...

Unfortunatly i have buy one i have tried it but with no result led panel are totally off. How i can test if Led panel are ok or hoe i can test STM32F4 without panel? Firmware is flashed correctly i belive and windown recognize the board using zadig.

Please help me thanks i 'll buy an original one but i want to test led panel if it is possible.

Just to test i have made a direct connection but now with st utility i cannot connect to st link anymore while before i can connect i need to change driver with zadig before try to reflash firmware.





2019-01-16 (1).png

2019-01-16 (2).png

2019-01-16 (3).png

Edited by bmiki75
add photo
Link to comment
Share on other sites

I have already wasted too much time on these cheap STM32 clones and always only buying a original one solved the problems in the end.

So please understand that I can´t help you more than saying double check your wiring against here https://github.com/lucky01/PIN2DMD/blob/master/hardware/V3 STM32F4 DISCOVERY/Wiring.md 

and buy a original one.

The zadig is not for replacing the ST-Link drivers (Mini USB). Only for the user USB (micro USB).
Reinstall your ST-Link Drivers for the MiniUSB

Link to comment
Share on other sites

Thanks a lot lucky1 i'll triple check connection even i am quite sure that they are correct and i'll buy an original STM32F4 board asap. Let me ask tree question just to help me to point out if i have made some mistake:

1)i have powered stm32F4 board from mini usb connector it is enouth or i have to power it with my 5V 20 AMP power that is connected only to led panel?

2)for virtual pinball i have to use micro or mini usb or both for data connection?

3)if something is wrong or cheap chinese board are not working is there a way to test led panel because the are completely black i do non t see anaything, they seems completely powered off


Thanks for your help and beautiful work.


Link to comment
Share on other sites

I have bought an original stm board but i am able only to obtain the same result of the chinese one wrong graphic on panel i have checked connection more than 10 times stanrting every time from zero.

Please help me , i have a LED chinese panal pheraps i use the wrong pinout?

Pin 1 of hub75 is the one with red ribbon and an arrow over it is this correct?

4 status led Led on STM are off only th red one is on all other led are red,  and i see an usb device on windows? Pheraps it is in the wrong devide mode?

I have no sd no schield and latest 2.60 firmware with direct connection and only want to test pc connection and panel connection

I have updade ST-Link firmware and declared in instruction than reflashed 2.60 firmware



I have find this on instruction

1) Troubleshoot with the on Board LED´s
 BLUE led = input DATA received (toggling)
 RED led = SD Card error / Device Mode 0 on startup
(use BLUE USER Button to get in to it)
 ORANGE led= smart color change detected (toggling)
 GREEN led = hash color change detected (toggling)

2)Device Modes:
1 - PinMame USB Mode with output to RGB DMD (16Pin HUB75 or HUB08)
2 - PinMame USB Mode with output to Pinball DMD (14Pin PinDMD Header)
3 - WPC Input – input from PinDMD -> output to RGB DMD (HUB75 / HUB08)
4 - STERN Input – input from PinDMD -> output to RGB DMD (HUB75 / HUB08)
3) Switch to Device Mode 0 to have USB access
 Press the “BLUE USER” Button at the boot OR boot with NO SD CARD or with NO
Config file on the SD Card








Link to comment
Share on other sites

  • 1 month later...

bought a few of these cheap Chinese STM32F407's.

To get them to work had to reflow the pins on the micro, usb controller and sever components. 

also reverted the onboard boot loader to an earlier version.  V2j24s5 I think it was.

anyway all 3 boards now work so at least I got lucky.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...