Jump to content

Recommended Posts

Using the current xmen_151 rom from stern, and the v1.2 table, when I load it, the DMD sometimes loads black and only works properly if I drag it back to the 1st screen (3 screen setup ).


It was the only table doing this but i recently added the spiderman table and it did the same... However it may be my only Sam table on my machine. I had the unity pindmd1 1.7 VPm installed... But I don't have a pindmd. Not sure ini had the wrong version... I did however just install the unity 1.2 vpm and the dmd is still loading a solid black (non working) dmd half the time...

Odd thing is. If I drag the "non working dmd" to my 1st monitor (over the table) it suddenly gets picture on it and then goes back to black when moved to the 2nd or 3rd monitor.



the game plays, just a solid black dmd. I have had a couple times where that solid black dmd would start flickering small color blocks instead. Im using two gpu's, both radeon 8400 gtx's not the best cards but they were free. but i dont this they are the problem cuz like i said it works when dragged over the table. which is displayed using one card.


Only seems to be happening on the two SAM tables I have... and intermittently.


Any thoughts?

Link to comment
Share on other sites

  • 4 weeks later...


though I don't recieve many answers on this forum from people willing to help, I figured I'll practice what I preach and at least post my results incase other newbies come along with the same problems.


I originally had another issue along with this that i did not post:


Previous Issue: DMD would jump to my second monitor over my backglass even after relocating it and restarting VP.

Resolution: Though VPinMame was set to "cabinet mode", the specific x-men ROM was not, and resolved by opening setup.exe in VpinMame, opening the specific rom and checking appropriate boxes.


Current Issue: X-men loads working properly as long as DMD is on my 1st screen over the table by default. If I move it to the second or third monitors (third is where my DMD should be) it will continue to work until I reload VP.

Then, upon reopening VP the DMD is solid black, and only works if I drag it back to the 1st monitor. (goes completely black again when moved back to the second or third monitor).

This issue occurs everytime I open VPinball and open this table to play, however doesn't occur everytime when launching from HyperPin.

Current Resolutions: Obviously I can move the DMD back to the 1st mionitor, close VPinball, reopen VPinball, DMD works, Move back to 3rd monitor and play (since the DMD works as long as default DMD loading location was the 1st monitor. This resolution is not reasonable.

My second resolution is to live with it. Since I am running everything from the HyperPin front end anyway, I can just open the table and as stated sometimes it works, sometimes it doesn't. If it doesn't I exit to HyperPin wheel, and return to game continuously until the DMD works. Not fun, not the way I want it, but at least I can play it.


Notes: I just noticed that this second issue also occurs with the Avatar Table.

I do have other SAM games that work properly.

I have no idea which "SAM Unity" version I should be running. I am now using the .dll from the 1.9 SAM download. I do not have a PinDMD, just a 3 monitor setup.


I will update again, if I reach different results.

Link to comment
Share on other sites

Each time I have changed the .dll I have ran the install yes. I haven't tried to clear the registry of the rom though.


I may try that, as well as I ran across a thread stating that the display needs to be set to default in VPinMame. I haven't looked to see if it was set that way, but read about similar symptoms from that.

I would assume it would have caused issues on more than just this one game though.


I've also noticed that since installing the v1.9 VPinMAME.dll, Tron has started laoding out of hyperpin super-laggy, almost frozen seeming. Maybe also a ROM issue, might try replacing it with a resh copy or checking individual ROM settings.


Thanks for the advice!


On a side note... Am I using the correct SAM VPinMAME.dll? there are so many, and I just got the newest one, but was unsure if there was a specific one I needed since I don't have PinDMD...

Link to comment
Share on other sites

Glad I found this thread!  I just updated everything to the latest versions after not touching VP for ages, tried a few tables and had exactly the same problem with the DMD being black (even on old tables)  Setting VPinMAME's Display drop down to Default instead of DISPLAY3 fixed it.  Phew!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...