Jump to content
CarnyPriest

SAMBuild2.9 beta thread

Recommended Posts

@connorsdad Ok, well, I unfortunately didn't buy the Pin2DMD myself, so, I haven't verified this. But, I think you should try to replace you dmddevice.dll from lucky' repo. Just rename dmddevice.dll that you find in your vpinmame folder to dmddevice.dll.off or something - then replace it with this one

https://github.com/lucky01/PIN2DMD/tree/master/integration/pinmame

Doing it this way, it is of course easy to revert the change.

Share this post


Link to post
Share on other sites
@connorsdad Ok, well, I unfortunately didn't buy the Pin2DMD myself, so, I haven't verified this. But, I think you should try to replace you dmddevice.dll from lucky' repo. Just rename dmddevice.dll that you find in your vpinmame folder to dmddevice.dll.off or something - then replace it with this one

https://github.com/lucky01/PIN2DMD/tree/master/integration/pinmame

Doing it this way, it is of course easy to revert the change.



I don't have the pin2dmd either, I'm using it for the coloured roms on an LCD monitor.

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

Ok then. Get this one https://github.com/freezy/dmd-extensions/releases

Inside 2.5.1 of dmd-ext you'll find dmddevice.dll. Get the dmddevice.ini as well, edit it - so that none of the pindmd[1,2,3] or pin2dmd is enabled. You should of course run virtual to on.

I seem to remember though that there are still some issues with focus. But, then again - just do that same as I told you above - easily reversible.

Share this post


Link to post
Share on other sites

There seem to be some issues with the ARM7 jit core in general, as i get crashes for example even with Whitestar games like LOTR and Elvis on the first run. The second time running the table is fine.

I looked into this at some point but had to give up,

So thats where the other crashes can come from, too, especially if its related to other tables having to be loaded (or not) first to make it work, like its the case for @connorsdad

Share this post


Link to post
Share on other sites

Seems someone on another forum had exactly the same problem as me and he fixed it by "Disable at91jit in registry for that rom. Set to 0 instead of 1", I'll be trying this as soon as I get near my cab :D

Share this post


Link to post
Share on other sites

Yeah. I've had a couple of tables where I've had to disable that registry key myself. But, never for this table. But, then again, from what toxie now is saying, it sounds to me it can start kind of randomly. It depends in some cases from what table you ran last. Hmm. Can that explain why ... from ACDC beta ... I had been running with color rom. New 1.0 comes out, I change those tables to use the color rom. Running unmodified rom, sure, no problem. Could not for the life of me get them to start ... even though I played almost the same table and the rom - just minutes ago.. Set it to color again - saved  - rebooted, and never had a problem since.

Pinball - virtual or not, does take time to maintain ;)

Share this post


Link to post
Share on other sites
Seems someone on another forum had exactly the same problem as me and he fixed it by "Disable at91jit in registry for that rom. Set to 0 instead of 1", I'll be trying this as soon as I get near my cab 



It worked :)
Everything plays fine first time even in PinballX

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

Had also an issue with CSI PM5. The ball was invisible, but that seems to have corrected itself. Spider-Man PM5 is still crashing for me. Tried the regedit above as well. Also using an LCD for dmd with pin2dmd..

Share this post


Link to post
Share on other sites

Regarding the 'hammer' in Metallica LE.

When I first put this game in my cab (using 2.8c if my memory serves me right) - the hammer worked absolutely perfectly.

Now it does not with 2.9 as we all know but even when I go back to the old (2.8c) vpinmame.dll file - the hammer still does not work.

Really hope someone is looking into this weird issue.

Also - do I use this new 2.9 with AC/DC LE?  Or the one that came with the table on monstercab?

Are we any closer to knowing the problem when we use ALTCOLOR files within Pinball X on Sterns (using a Pin2DMD)?

Really wish I was good at software so I could offer assistance on this.

 

 

Share this post


Link to post
Share on other sites


Does it crash if you are just using the VPM display instead of freezy's dmddevice.dll?




Tried without the dmddevice dll...still no go on Spider-Man pm5. I see the b2s a split second then it's like I never ran it.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
14 hours ago, CarnyPriest said:

You can use the one in this thread for AC/DC LE.

Try using the latest dmddevice.dll. Link to lucky1's repository in first post in this thread.


Sent from my iPhone using Tapatalk

It flickers like mad (Pin2DMD).
 

Share this post


Link to post
Share on other sites

I think a lot of questions and answers are being mixed up.  I would suggest Carny and Lucky to tag people in replies.
I do not have flickering on my Pin2DMD.

I can not run any Stern modern table using ALTCOLORS successfully when using PINBALLX.  They work maybe 2nd time I boot running direct from VPX (ie without PinballX).

Spiderman Vault is hard to get working with v2.9 of SAM - and not possible at all with the ALTCOLOR folder (yes I am using a patched ROM and have the palette folder in the correct directory).   Something in Pinball X, VPX, SAM2.9 and PIN2DMD are not 'talking' to each other properly.

Also I used to have the hammer working on my cabinet (in Metallica LE) running V1.64 and V1.70 software - and it now is not correctly working.  Whenever I go back to older VPINMAME.DLL it does not correct this problem.

Share this post


Link to post
Share on other sites
It flickers like mad (Pin2DMD).
 


Does your Pin2Dmd flicker or does it not flicker?

Metallica LE issue is a known issue.

I don't know on Interactions with PinballX. I don't use PinballX built-in VP support. I use my own script that PinballX launches within a Custom system type slot to bypass issues with preset delays. It generally works for me for SAM, but I haven't tested AC/DC LE or Smanve specifically. I don't have those installed.

General troubleshooting steps involve making sure all files updated, properly installed and registered, unblocked, running as admin. Enabling or disabling at91jit key, updating/upgrading to Windows 10


Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites
57 minutes ago, CarnyPriest said:


Does your Pin2Dmd flicker or does it not flicker?

Metallica LE issue is a known issue.

I don't know on Interactions with PinballX. I don't use PinballX built-in VP support. I use my own script that PinballX launches within a Custom system type slot to bypass issues with preset delays. It generally works for me for SAM, but I haven't tested AC/DC LE or Smanve specifically. I don't have those installed.

General troubleshooting steps involve making sure all files updated, properly installed and registered, unblocked, running as admin. Enabling or disabling at91jit key, updating/upgrading to Windows 10


Sent from my iPad using Tapatalk

The flickering was solved a long time ago.  My cab is not flickering.

It works fine until pinballx is introduced with altcolor palettes.

The reason I reformatted my cab last week was I upgraded to Windows 10 and had more issues than before, so I did a fresh install of win7.  None of the files on my computer get 'blocked' as I have bypassed the OS doing this.  Everything is run as admin as well.

To be honest I was going to look into the launcher for VP within Pinball X.

Can you make your launch script public.

It just seems everything can work - but this all changes when PinballX is used to launch VP.

Currently on the VP facebook group several are discussing the same problem as I have. 

 

Share this post


Link to post
Share on other sites
GtG    1
On 5/2/2017 at 0:08 AM, GtG said:

What's the word on sam GI support? I'm only getting GI updates when the game tilts, no other time.

BTW found it buried deep in the chglamp array. Thanks DJRobX  :D

Share this post


Link to post
Share on other sites

so its a dll file making flickering issues so where a link for a updated dll which i got what location on c: drive i got windows 7 64 bit running on my setup

i get flicking on flintstones visal pinball and metallia future pinball

i though this was a hardware. electrinic issue rather then

a panel or controller one

paul

Edited by psmmacker
New info and new pictures

Share this post


Link to post
Share on other sites

@jukedock, there is quite a bit more going on in my launch script than just launching VP which is why I use a custom approach in the first place. My script is published here. 

https://www.gameex.info/forums/topic/16462-update-visual-pinball-mini-dmdb2s-screen-for-apron-now-with-instruction-card-splash-viewer/

My latest script is in the thread.

Share this post


Link to post
Share on other sites

@jukedock To me your problem seems quite similar to what I've experienced with Pindmd3. Why don't you try to do what I've described needs to be done here :

http://vpinball.com/wiki/visual-pinball-knowledge-base/pindmd3-replacing-pindmd-dll-for-dmddevice-dll/

If It isn't working, very easily revert back ... and of course - only try the part where I mention PBX.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×