Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
lucky1

Pin2Dmd Colorprism V2.0 Firmware

Recommended Posts

1 hour ago, ARMYAVIATION said:

question..when I load a rom in vpinspa and try and test it, it says rom igood but when I try and run the rom it says "Failed to load DLL"  What would cause that?

This is not a firmware related problem. Please open a new thread.

Share this post


Link to post
Share on other sites

uploaded new version 2.56 with fix for 128x16 colorization (checkpoint,TMNT) on real pinball machine. Fixes also a issue when opening a fsq file on SD.

Share this post


Link to post
Share on other sites

 

- added support for panels with different RGB color sequence (GRB etc) (use onscreen menu to change)

Is it possible to add the ability to change color sequence via usb cable and PIN2DMD ColorPRISM v2.53.?

It seems all other functions of the onscreen menu are possible via ColorPrism except this option?

Thanks

Share this post


Link to post
Share on other sites

Hi Lucky1,

 

Any chance of uploading bin and dfu files of the v2.57 firmware  for the discovery board. I don't have a spare microsd card to update the firmware

 

Cheers

 

Rob

Share this post


Link to post
Share on other sites

Hi Lucky1,

Thanks for letting me know - having a few issues with the turtles rom colorisation and wasn't sure whether it was due to me not having the latest firmware.

Cheers

Rob

Share this post


Link to post
Share on other sites

Hi Lucky,

can I ask for support on this...

I've been updating everything to the latest...latest pinmame (v3.2 rev 4641), latest VPX (v10.5.3490), latest pindmd (2.57 (although display says 2.55).

 

Now....     a lot of STERN tables do not work anymore: when starting up the BG comes up, table comes up (no lights) and then....few seconds, VPX hard crashes, back to Windows screen.

Of course this could be everything but... 

When I go into the test-function of pinmame itself and I choose game-options, disable external .dll  then the table is fine, starting perfect (although no pin2dmd but when I enable it, I can get a virtual display.

Now...this might be a sign that there is something with the pin2dmd as disabeling it from the f1 menu (or, as I can not get the table running I change it in the Pinmame test menu).

As a test I switched all to non-colorized ROM's.

As a wild gues I reverted the pin2dmd software (both firmware and dll to V2.37  (I know...old one) and that worked!

 Tested 2.45: also ok....2.50..also ok  2.55 does not work for me and also 2.57 does not work anymore.

So, with 2.50: now tables start, real colored rom's won't work (but that might also be a pinmame issue) standard colorized option does work.

Now...any clue?

1 thing I do not know: I am on Win7 64 bit. Do I need  the 64bit dll from the github source?   (I tried it but it did not work as well).

Tested with:

AC/DC  Rom : acd_168 
Avatar Rom : avr_200
Metallica : mtl_170h

color roms for ad/dc and mtl  I can not get to work (anymore) with this 2.50 pin2dmd version

Thank you! 

Share this post


Link to post
Share on other sites
12 hours ago, Joppnl said:

pin2dmd but when I enable it, I can get a virtual display.

Virtual DMD ? Do you use freezy´s DLL ? If yes did you try mine ?

The OS version (64bit) is not relevant for the DLL version. Only the 64bit version of pinmame needs the 64bit DLL.

 

Share this post


Link to post
Share on other sites

Only the pin2dmd .dll, did not install freezy's (would it be any better for pin2dmd?)

 

But also with your .dll it's possible to uncheck 'use external dll' and then when enabeling it on the BGoptions it shows a virtual dmd and the table does start instead of crash.

Now,  to summerize:  for me 2.50 is fine and it works ok but no real color rom's anymore. 

What I can do is...test it again and see when I change some hardware options (like cables) if it comes back (I wonder), I could try Freezy's .dll to see if that makes any difference and if not I could  'USBcapture'  the data when a color rom is set and when VPX crashes.

Or if you have an idea pls let me know,  thank you!
 

Share this post


Link to post
Share on other sites

I just tested the latest sambuild from here  

 

and started mtl_170hc in pinmame setup.exe without a problem (at91jit disabled).

- pin2dmd firmware version 2.57
- latest dmddevice.dll from my github
- colorize and external dmddevice enabled with pal file in altcolor.

Could you please verify wether that works on your side too.

Share this post


Link to post
Share on other sites

THANK YUO, THANK YOU!!!!

It's 'alive' again...!!
 

Did a lot of testing and came down to this one problem:

- in the pinmame test/run rom everything was fine. Perfect colors on pin2dmd.   When running Metall. in VPX table and BG showed up but then it -hard- crashes to Windows.

When using the same rom but just disabeling the colorize function the table does start.

Using a non-colorized ROM but enabeling the colorize option did work to but not the nice colors of the real colorized ROM.

 

Now, then I did the updates you suggested (pin2dmd firmware 2.57 shows 2.55 in display and 2.53 in colorprism but ok).  Latest pinmame tried it...nothing, same problem. I did not download the seperate .dll from github as I think the .dll in the latest total package is te latest dll (??)

But...then I had a look at this at91jitt $#%@$%!thing!!   There was a '1' as value. Changed it to 0 and....it takes time before the table starts up but it worked! Put it back to 1 and crash again, rebooted the PC, put it back to 0 and it works again!

Now...the only strange thing and question is.... How the h*ck can this value be changed all of a sudden?

I defenitely know it was a 0 before (although all my tables worked fine I just did a check, long ago).

Only thing I lately changed is that I removed my Geforce card and installed a 1070 NVidea card + drivers.... could that change it?

 

Anyway...it DOES seems that this has been the problem, I did not un-91jit all the entries in the register, but it seems to be a reproduceble error and solution so I guess this it it, 

thank you again for your help!

 

Share this post


Link to post
Share on other sites

Hi Lucky,

can I ask for your support on this please:

 

Since the latest updates on Pinmame  it will crash when using the rom's or trying to play a machine.

So, going into pinmame itself, press test, choose a rom, enable use external dll (for the pin2dmd) and press run: I see the pin2dmd light go very dim and then pinmame exits without warning.

Checking the ROM-set itself says that the rom is ok and pinmame is able to use it but running it will crash pinmame.

Now... up to Pinmame Version r3.2 v4621 there was no problem but upgrading from there with either r4635 or the latest r4637  does not work, giving the behaviour as said.

Disabeling the 'use external display' will make it possible to run the same rom with a virtual dmd on screen.

Tested with afm113b and tz94hc, ij_l7 but up to now can not make it work, random other roms do not work as well.

After having this issue I did a complete new install of my total harddisk (to clean up everything as well) and also installed Win10 (coming from Win7)

Installed the all-in-1 VPX ,installed the latest sam ,  checked it, problem as described. (not even starting VPX itself, first checking SAM)

Then I downloaded the latest pin2dmd drivers from grithub, copied dmddevice.dll to pinmame, copied the xdmd files and installed the latest firmware to the pin2dmd (2.58) but no succes, same problem.

Also checked at91jit (as my previous problem) but that value is 0.
 

any clue? Thanks for the support,

Share this post


Link to post
Share on other sites
8 hours ago, Joppnl said:

Hi Lucky,

can I ask for your support on this please:

 

Since the latest updates on Pinmame  it will crash when using the rom's or trying to play a machine.

So, going into pinmame itself, press test, choose a rom, enable use external dll (for the pin2dmd) and press run: I see the pin2dmd light go very dim and then pinmame exits without warning.

Checking the ROM-set itself says that the rom is ok and pinmame is able to use it but running it will crash pinmame.

Now... up to Pinmame Version r3.2 v4621 there was no problem but upgrading from there with either r4635 or the latest r4637  does not work, giving the behaviour as said.

Disabeling the 'use external display' will make it possible to run the same rom with a virtual dmd on screen.

Tested with afm113b and tz94hc, ij_l7 but up to now can not make it work, random other roms do not work as well.

After having this issue I did a complete new install of my total harddisk (to clean up everything as well) and also installed Win10 (coming from Win7)

Installed the all-in-1 VPX ,installed the latest sam ,  checked it, problem as described. (not even starting VPX itself, first checking SAM)

Then I downloaded the latest pin2dmd drivers from grithub, copied dmddevice.dll to pinmame, copied the xdmd files and installed the latest firmware to the pin2dmd (2.58) but no succes, same problem.

Also checked at91jit (as my previous problem) but that value is 0.
 

any clue? Thanks for the support,

Sorry no idea.

I think this is not related to the firmware which is the topic of this thread.

Please open a new thread for your problem or maybe this is the right thread 

 

Share this post


Link to post
Share on other sites

No problem, thanks for the link.

I was thinking about the pin2dmd firmware as when disabeling it in pinmame the table does start but it is a total of a chain and if one thing in the chain doesn't work...the whole chain won't...so...will go check it out.

Share this post


Link to post
Share on other sites
 new version 2.60

- unified codebase and version number for 192x64 and 128x32
- reworked output code to improve speed and save memory (50%)
- increased color depth for 192x64
- fixed colorization and init code for Capcom
- improved speed and fixes for DataEast 128x16 code
- fixed minor bugs in bootloader (update through USB to update bootloader code)
- fast palette load in dmddevice.dll
- fixed dump for CapCom in pin2dmd.exe
- added raw dump support for WPC, Gottlieb, Capcom and AlvinG
- added 128x16 as device mode (with dump functionality)
- reviewed / refactored almost 90% of the code for better portability to other platforms
  (tested with DMDMK66 / Teensy 3.6)

 

Share this post


Link to post
Share on other sites

Hi @lucky1 I've succeswsfully upgraded my firmware to 2.60 for my PIN2DMD and also upgraded my dmddevice.dll (in my vpinmame directory v1.42) and pin2dmd.exe (in my pin2dmd directory). I can run vpinmam and run test DMDs but when I load a table through visual pinballX My DMD remains black and lifeless. any ideas?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

I had a look in my PinballX directory, there was no dmddevice.dll but I copied the latest dmddevice.dll from the master Pin2DMD download into my PinballX directory anyway. 

 

Interestingly when I loaded pinballx at boot the PinballX logo video appeared on the DMD but then it went black again and not loading DMDs for any tables. This is still the same when loading tables directly in VPX after exiting PinballX.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×