Jump to content

Recommended Posts

I wanted to test to add some new features to the B2S Server.

Does anyone have a hint what is needed to compile it?    I am new to VBA and C#, but wanted to give it a try.

 

Is Visual Studio 2015 needed? Any hints are very appreciated!

Link to comment
Share on other sites

On 3/6/2022 at 9:08 AM, jarr3 said:

I wanted to test to add some new features to the B2S Server.

Does anyone have a hint what is needed to compile it?    I am new to VBA and C#, but wanted to give it a try.

 

Is Visual Studio 2015 needed? Any hints are very appreciated!

 

I got an answer elsewhere:   VS 2022 should work, and VS 2019 and earlier is already being tested to compile the B2S Server.

Link to comment
Share on other sites

  • jarr3 changed the title to Compiling B2S Server? *Solution* It is easy!

I can confirm that VS 2022 works as well, but it wants to upgrade the project files to use .NET 4.8 instead of 4.0.

 

Microsoft even has a Windows 11 VM's (Hyper-V, Parallels, VirtualBox and VMWare) prepared with VS2022 incl. WSL + Ubuntu and everything needed to test it out.

 

The link is to the german page, could not find the english one, search for WinDev2202Eval.HyperVGen1.zip 

Link to comment
Share on other sites

  • 3 months later...

Now the move to github is finalized:  https://github.com/vpinball/b2s-backglass

 

So now it should be easier for everyone to send in patches!

 

/Jarr3

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
  • Create New...