Jump to content

Recommended Posts

I have a two-screen set-up with the virtual DMD on the same screen as the backglass.

 

I recently updated the B2S Backglass Server as I was installing PinUp Player. The new version of the B2S Backglass server has added a new checkbox called “Bring BF Form to Top” When you initially set this it does it globally for all Backglasses.

 

The issue is that since this update larger backglass (i.e. larger file size) that take slightly longer to load are opening after the DMD and are hiding the DMD behind them.

 

This is happening for some Freezy DMD’s and nearly all Ultra DMD’s games

 

The usual settings i.e. “DMD to visible” on the B2S Backglass Server setting make no difference.

 

Unchecking “Bring BF Form to Top” on the B2S Backglass Server setting solves the problem when opening a table directly from Visual Pinball, but…… The BIG PROBLEM is that Unchecking “Bring BF Form to Top” now hides the DirectB2S Backglass behind the static backglass image used by my frontend Hyperpin.

 

I only realised this when I noticed the Backglass were now static with no animations. I pressed alt-Tab and realised that setting was actually causing the backglass to open behind the frontend image.

 

This was never an issue with the older version of the B2S Backglass Server, but PinUP Player requires the newer version.

 

I have no intention of moving away from Hyperpin as I have it all set-up for well over 700 tables.

 

I would actually like to solve the problem of the Backglass opening after the DMD when the Backglass is larger and takes longer to load.

 

Is possible to add a 1 Second delay / pause in the table script just before the “DMD_Init” to allow the Backglass to load before the DMD?

That way I could leave “Bring BF Form to Top” checked for all tables.  

 

Alternatively, is there a way to stop the backglass from opening behind the Hyperpin backglass image when “Bring BF Form to Top” is unchecked?

 

Any help would be appreciated as this only happens on about 15-20 tables such as Diablo and Stranger Things and is driving me nuts!

Edited by Andypc
Link to comment
Share on other sites

  • Andypc changed the title to [Solved] Issues with DMD hidden Behind Backglass since B2S update
Posted (edited)

The problem appears to be caused by version 1.3.1.1. Reverting to version 1.3.1.0 solved the problem with the DMD's being hidden behind the backglass.

 

I am therefore able to leave "Bring BF Form to Top” checked which prevents the backglass being hidden by Hyperpin.

 

A huge Thanks to Jarr3 for his help with this. I wasn't aware where the problem had been introduced as I upgraded from a much older version, but it appears to be between 1.3.1.0 and 1.3.1.1

 

 

Edited by Andypc
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
  • Create New...