Jump to content

Recommended Posts

hello boy's, i have the problem in my pin2dmd...

Bally/wms perfect work

Data/east no work!

I tried either the data / east or starn settings, but it gets stuck on pin2dmd ..
i try the display on a bally / wms and it works perfectly ..



my hadware is Nucleo v4 429zi fw 3.05

shield v4

Link to comment
Share on other sites

  • Content Provider

You can run the input test as described here https://pin2dmd.com/#3

Also set all settings to default in the onscreen menu.

Then try devicemode Data/East and Whitestar.

Where do you get the power for the pin2dmd ? If you power it from the pinball machine your data/East pinball machine power supply 
may be too weak causing a constant reset of the dmd controller board.

Link to comment
Share on other sites

 tried as the video says and everything is ok ... 1 3 5 7 11 13,

i reset the board, setting standard

setting data/east or whitestar

I also tried to power the pin2dmd with a foreign power supply set at 5.05v, but there is no way, it does not start

in williams bally no problem boot!



Link to comment
Share on other sites

  • 3 weeks later...

Hi All - Really struggling to get my setup working. I have a pin2dmd evo board version 1.1 (sold to me by another pin enthusiast you had an order of 10 pcbs made up) and a Data East 128 x 16 dot matrix driver board (as supplied by german gaming supplies) connected up to a checkpoint pin. The display doesn't seem to be getting a signal from the pin through the driver board. I have run the input test as described on the pin2dmd site and get that pin 9 is closed all the time but that the others close in turn as expected when you add the jumper (so i think this is correct?).

When I power on both the display (through a separate power supply) and the pin the display just stays on the pin2dmd screen and doesn't go any further. When the pin is powered on you get a red LED on the evo board but it doesn't flash or anything. (worth noting that everything was working fine with the original dmd)

Can anyone advise on how to troubleshoot either the evo board or the driver? Any help greatly appreciated.

Link to comment
Share on other sites

Yeah the enhancer is definitely set to off. I did notice something else though completely by accident whilst repositioning the boards. When the top left pin (when looking from the bottom of the driver board, as per the pic) of the ribbon connector that runs from the driver board to the display is bridged to the pin below it (like you do for the input tests) the display suddenly works although a little jumbled (some animations display better than others). Does this tell you anything? Picture attached showing the pins I am talking about. Does this point to an error on the driver board?

Again any help is greatly appreciated.

highlighted pins.jpg


Link to comment
Share on other sites

See the video attached. This is what it looks like with the two pins bridged. Some of the animations appear to display with elements out of order (bits that should be on the right being on the left for example) with most having bits that overlap when they shouldn't. Don't think I got it on the video but there is also one animation that shows correctly.

Any ideas??

Link to comment
Share on other sites

Not sure on the display ROM version. This would normally be shown on startup right? unfortunately I can't read that with this display connected. Is there another way to find this?

It's been a while since I had the original DMD in but I could fish that out and have a look. I am a little worried about damaging the fragile legs though on changing the chip over (I remember it being difficult).

Nothing obvious wrong with the solder joints but I am now going through and checking for continuity with the multimeter just in case.

Do you think it's worth getting a fresh chip set? I suppose I could have potentially damaged it on switch over?

Link to comment
Share on other sites

  • Content Provider

Yes, that means that data is sent without error, which also means that the error is generated by the DE DMD Controller.
It is impossible to find this error remote, but you can try a different RAM IC and or a new ROM EEPROM.

Link to comment
Share on other sites

Ok thank you for the help lucky. Very frustrating if it's an issue with the DE DMD controller since it was bought direct from German gaming supplies (which after some reading I can see many people have had a problem with). 

I will order a new ROM EEPROM just in case it is that. Is it recommended to change the CPU and display ones at the same time?

Another silly question - which IC is the RAM?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...