• 0
cyclemat

Lwclone On Arduino Mega 2560

Question

Here comes the LWClone on Arduino MEGA 2560

 

How to Compile

Windows Prerequisites

On Windows, you will need a copy of the latest Atmel Toolchain, either downloaded 
and installed as a standalone package, or installed as part of Atmel Studio. 
You will need to ensure that the "bin" directory of the toolchain is available 
in your system's PATH environment variable.

In addition, you will need to install a ported version of the ZSH or BASH *nix shells, 
and a standard set of *nix utilities such as cut, find and sed. 
These can be found in the "basic" system package of the of the MinGW installer (http://www.mingw.org). 
Once installed, add the "msys\1.0\bin" of the MinGW installation folder is added 
to your system's PATH environment variable.

The bootloaders currently also require the "bc" application, 
which can be installed from http://gnuwin32.sourceforge.net/downlinks/bc.php. 
Once installed add the "GnuWin32\bin" path of the GnuWin32 installation folder 
to your system's PATH environment variable.

Linux Prerequisites

On Linux systems you will need to install the latest Linux distribution 
of the standalone Atmel Toolchain from the Atmel website for general development, 
or use the latest avr-libc and avr-gcc packages for your chosen distribution's package 
manager. For full device support, the Atmel standalone package is recommended.

How 2 Flash

Connect your Arduino to USB and look witch comport it has
Start Flash Main Chip Arduino Mega to LW.bat
enter your Comport e.g com2 or com32 what ever
Remove USB
Connect your USBASP to the ISP header behind the USB port
Start Flash 8u2 - 16u2 Arduino Mega - with USBASP Dongle to LW.bat
Connect The USB port wait for reorgination the Device 
Start Change ArduLW ID.bat
Enter your LEDWIZ ID e.g. 1 or 2 up to 16
That is it test it with Visualpinball an Pinmame/DOF

 have make New packages 23.01.2016

 

https://mega.nz/#F!bdZHVaxK!3WmePgTED-3xQp8oj-ZfOA

 

one package with inverted LED ports so that High ist normal and low is on ( for the Relaisboards from ebay)

 

 

For Boards that say it gives problems with The STK500 Timeout Error Here ist a Short way to fix it !?!?

 

 

1. Connect the USBASP to the ISP connector behind the USB Port.

2.Start the  "0. Flash 8u2 - 16u2 Arduino Mega - with USBASP Dongle to Arduino.bat"

 

3. Connect the USBASP to the Second ISP port

4. Start the "Flash m2560 Unlock fuses, erase, verify - with USBASP Dongle.bat"

5. Start the "Flash m2560 Write the bootloader, set the lock fuse, verify  - with USBASP Dongle.bat"

 

 

Now you can flash it normaly

 

when the flash with the USB ASP didnt work test to bridge the GND point on the 10->6 Pole Converter

 

FOR HELP PLEASE POST YOUR PINMAP.H AS CODE AND WHEN YOU HAVE COMPILING PROBLEMS POST YOUR OUTPUT AS CODE SO I CAN BETTER

HELP

 

So have make a little Video tutorial don`t say anything about my english have do my best.

 

 

 

 

 

Share this post


Link to post
Share on other sites

163 answers to this question

  • 0

Hi..i am a new user here. I downloaded the first Version from earlier today and managed to get it on my ardu and it seems to work fine.So now i downloaded the new Version and try it later or is there no diff between the hex files and only an install bat + arduino soft added ?Another question is are you planning to release the source so that we can create the hex ourself´s and have the possibility to change the ID and the Portmapping ?

surface mount pcb assembly

Share this post


Link to post
Share on other sites
  • 0

You can change the ID anyways.

I have an source code... and nice add on breakout boards with driver... check it out

Share this post


Link to post
Share on other sites
  • 0

To enable or disable any functions you must edit the folow files

in Devconfig.h

#ifndef DEVCONFIG_H__INCLUDED
#define DEVCONFIG_H__INCLUDED


/****************************************
 USB device config
****************************************/

#define ENABLE_LED_DEVICE       <- Enable the LED LEDWIZ Outputs
#define ENABLE_ANALOG_INPUT     <- Enable Normal Joystick Analog inputs
#define USE_ACCELGYRO 1         <- Esnable Gyro Controller ( Sixaxis Device )
#define ENABLE_PANEL_DEVICE     
#define NUM_JOYSTICKS 0         <- Number of Normal Joys 2Axis and 12 Buttons
#define USE_MOUSE 1             <- Enable Mouse Controlls
#define USE_CONSUMER 1          <- Enable Multimedia Keys
#define USE_KEYBOARD 1          <- Enable Normal Keyboard device



#endif

 

Share this post


Link to post
Share on other sites
  • 0

I'm trying to follow your YouTube tutorial and I have a doubt.

At time 15; 20 on your video, you open 'simple LED test' application, but i do not find that application. Where do i find it?

On the other hand, i have flashed LedWiz Clone to my arduino in my laptod, But I want to install vpinball in other PC.

Do I need to change ID in the second PC or can I change it in my laptop?

Share this post


Link to post
Share on other sites
  • 0
On 6/12/2016 at 11:46 AM, jacaba said:

I'm trying to follow your YouTube tutorial and I have a doubt.

At time 15; 20 on your video, you open 'simple LED test' application, but i do not find that application. Where do i find it?

On the other hand, i have flashed LedWiz Clone to my arduino in my laptod, But I want to install vpinball in other PC.

Do I need to change ID in the second PC or can I change it in my laptop?

I can find "Simple LED Test" and i work my ledwiz clone.

all digital outputs work just fine, but i want to use  Analog support and the analog Acelometers. 

how my english is very bad I have trouble following and I don´t know if It has managed to make both things work.

 

My idea is use this potenciometer for plungler. 

https://es.aliexpress.com/store/product/Free-shipping-Electronic-building-blocks-slide-potentiometer-module/433698_2029224818.html?detailNewVersion=&categoryId=400199

 

and this acelometer for tilt.

https://es.aliexpress.com/item/GY-61-ADXL335-Module-3-axis-Analog-Output-Accelerometer-angular-transducer-3v-5v-Wholesale-Electronic/32463825736.html?spm=2114.13010608.0.0.ZSOUUK

 

Could you say me if can both work? 

i need help for get this. 

thx for help 

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
  • 0

i look into pinscape, but I prefer to use ledwiz clone, because I  have got  all items for arduino.

Share this post


Link to post
Share on other sites
  • 0

I have a problem with my clone and I think it should be very easy to solve .. apart from the Ledwizclon I have a Pinscape plate that works great as a joystick and for the nudges but when I install the ledwiz clone this appears as joystick 1 and the pinscape Like joystick 2 and there is my problem.

My query is .. how do I disable the clone joystick? This is my Devconfig.h file maybe I'm getting something wrong here.

 

 

 

/*
 * LWCloneU2
 * Copyright (C) 2013 Andreas Dittrich <lwcloneu2@cithraidt.de>
 *
 * This program is free software; you can redistribute it and/or modify it under the terms of the
 * GNU General Public License as published by the Free Software Foundation;
 * either version 2 of the License, or (at your option) any later version.
 *
 * This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY;
 * without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
 * See the GNU General Public License for more details.
 *
 * You should have received a copy of the GNU General Public License along with this program;
 * if not, write to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
 */

#ifndef DEVCONFIG_H__INCLUDED
#define DEVCONFIG_H__INCLUDED


/****************************************
 USB device config
****************************************/

#define ENABLE_LED_DEVICE

#define ENABLE_PANEL_DEVICE
#define NUM_JOYSTICKS 0
#define USE_MOUSE 0
#define USE_CONSUMER 0
#define USE_KEYBOARD 0

#endif

Share this post


Link to post
Share on other sites
  • 0

kill this out must work 

 

#define NUM_JOYSTICKS 0
#define USE_MOUSE 0
#define USE_CONSUMER 0

Share this post


Link to post
Share on other sites
  • 0

Hi Cyclemat,

First of all,  Thx for your "How To" and all the works  you've done to simplify the flash of the Arduino.

I want to inform you that I translated and adaptated your tutorial in french and I posted it in the forum Pincabpassion.net : http://www.pincabpassion.net/t5411-tuto-transformer-un-clone-d-arduino-mega-2560-en-clone-de-ledwiz#113812,

 Could you give me your blessing for this share ? (lol)

If you don't, i will erase my topic.

 

Best Regards

Share this post


Link to post
Share on other sites
  • 0

Hi cyclemat,

first of all many thanks for that awesome work. you've done !

I am using an arduino Mega2560 R3 board and flashing just works fine with avrdude and the atmels switch application .. no need for USBasp ...

Currently I am only using the board to connect accelerometer ADXL335 and plunger poti, which works fine up to now ... more to come ... 

I have build lwclone from this git repo https://github.com/cithraidt/lwcloneu2

I just wonder whether the sources are the latest version as the last commit in the repo is form 2014 and I have seen that you have distributed the last binary package here 2 years later.

Best Regards

step

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now