Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Joppnl

(solved) PIN2DMD & Freezy's not working here...

Recommended Posts

Hello,

as I'm installing PUPplayer I need to install the Freezy drivers for PIN2DMD and I really can't get it to work (just standard use, directly run from VPX,  not talking about pinup pack or so at this moment)

Some more info:

I am on firmware 2.60 and with the normal pin2dmd .dll everything works fine, also full color etc.  PC Win10.

When using Freezy's 1.71 (x86) I do copy all that files into the pinmame dir (make sure they are all unblocked).

Change the ini file to enable pup packs. now:

I do get a virtual dmd on my table screen (makes sense, it is enabled in the .ini file) but the pin2dmd does not work.
Pin2dmd is enabled in the ini as are some others (this is default).

When I disable the virtual dmd and the other real-dmd's (except pin2dmd) then it also does not work at all.

Pup is working fine with Freezy's .dll but it is not working fine with the original pin2dmd.dll (although with that dll I do have pin2dmd working.

Any suggestions to get it work?  Is it possible to get it to work with Freezy .dll? (and yes: 'use external dll is active (otherwise with the normal .dll pin2dmd wouldn't work as well)

Thanks in advance!

DmdDevice.ini

Share this post


Link to post
Share on other sites
I use frenzy for my pin2DMD all the versions have worked this is the one I'm currently using

http://vpuniverse.com/forums/topic/3370-attack-from-mars-colorization/page/3/?tab=comments#comment-42753

I'm not sure what the pin2DMD.dll is but I've never had it
All the Freezy files go in the VPinMame folder

Also try the latest firmware for Pin2DMD V2.67

http://vpuniverse.com/forums/topic/2436-pin2dmd-colorprism-v20-firmware/

This is a  copy of my DmdDevice.ini

And this is when I use for my  UltraDMD or XDMD

https://vpinball.com/forums/topic/masters-of-the-universe-vpx-pup-pack-royal-boob-edition/page/3/#post-104546

 

dmddevice.ini

Share this post


Link to post
Share on other sites

Thank you outhere....lot of new options, will give these a try, will report later. 

Share this post


Link to post
Share on other sites

Well....

tried everything I can think of but...no luck.

Did:

-  use your .ini file

-  reïnstalled .net 4.5.2 as suggested by Freezy: PC says I have newer version, abort

-  reïnstalled C++ by Freezy's link

-  updated pin2dmd to 2.67

 

I guess ultradmd is working as that-table-not-to-be-mentioned works fine.....

Out of options now.....

Share this post


Link to post
Share on other sites

OK...found it:

with help from Jens Leiensetter who gave the solution:  with the Zadig tool you need to install the  libusb-win32 driver,  I did use an other one which worked great but not in conjunction with Freezy's .dll

Thanks for your help,

Share this post


Link to post
Share on other sites
Glad you have it figured out...
  • Like 1

Share this post


Link to post
Share on other sites

Update:

changing the driver to libusb-win32  does work for normal dmd images and also the pinUP packs work but you will loose xDMD functionality.

The better solution is to  change the version of the used WIN driver.

When connecting a pin2dmd to a fresh Win10 system it installs a driver version V10.x which does NOT work with Freezy's .dll

With the Zadig tool you can downgrade it to V6.x which works fine and you don't loose xDMD functionality.

When changing the driver be sure that after you pressed some buttons in the left and right box are the same (V6.x) (in this image I didn't press the button but after I pressed the big button it didn't change either, had to go into that option menu of the big right box by pressing the small arrow on the right and choose the downgrade/install option)


zadigdriverdowngrade.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...