Jump to content

Recommended Posts

Hi all!  I'm new! I have an Oculus Quest VR headset with Virtual Desktop. I downloaded the latest version of Visual Pinball X from Github and the VR version of Pin Bot from here. When I open it, it shows me the table but doesn't go into VR. Am I missing something? Do I need a VR plugin or something? I'm a complete noob when it comes to this stuff. 

Link to comment
Share on other sites

18 hours ago, LugofilmLtd said:

Hi all!  I'm new! I have an Oculus Quest VR headset with Virtual Desktop. I downloaded the latest version of Visual Pinball X from Github and the VR version of Pin Bot from here. When I open it, it shows me the table but doesn't go into VR. Am I missing something? Do I need a VR plugin or something? I'm a complete noob when it comes to this stuff. 

Hi LugofilmLtd, 

 

First you need a working version of VPX (must be able to play a table in non-VR) I suggest installing Nailbuster's "Baller Installer" it takes care of everything for you. Then you need to install VPVR on top of your VPX install. You can find Baller on Facebook or in the Virtual Pinball Chat Discord and the VPVR file is here https://sourceforge.net/projects/vpvr/files/ grab the "VPVR.zip"  Then you could follow this guide to get it going, just disregard the old links and follow the settings https://docs.google.com/document/d/e/2PACX-1vSjel9VopmDcLaDbVx5xAEYP3R_i7gY-StYYcWIh0Nxu5JOH3wfZ9AHQK5lqHggh3mMb4MHdvGQUq7a/pub#h.766pdekwexux  Here is a Youtube video for reference https://www.youtube.com/watch?v=V0BVrNQ_U-U&list=PLUAE7P28D0EYcnsJsb1ufvXvXwhs5i_mZ&index=4&t=218s  Good luck

 

Link to comment
Share on other sites

3 hours ago, studlygoorite said:

Hi LugofilmLtd, 

 

First you need a working version of VPX (must be able to play a table in non-VR) I suggest installing Nailbuster's "Baller Installer" it takes care of everything for you. Then you need to install VPVR on top of your VPX install. You can find Baller on Facebook or in the Virtual Pinball Chat Discord and the VPVR file is here https://sourceforge.net/projects/vpvr/files/ grab the "VPVR.zip"  Then you could follow this guide to get it going, just disregard the old links and follow the settings https://docs.google.com/document/d/e/2PACX-1vSjel9VopmDcLaDbVx5xAEYP3R_i7gY-StYYcWIh0Nxu5JOH3wfZ9AHQK5lqHggh3mMb4MHdvGQUq7a/pub#h.766pdekwexux  Here is a Youtube video for reference https://www.youtube.com/watch?v=V0BVrNQ_U-U&list=PLUAE7P28D0EYcnsJsb1ufvXvXwhs5i_mZ&index=4&t=218s  Good luck

 

 

Okay! We're making progress! I got everything set up with baller installer, the non VR program works and I set up open composite following the instructions exactly. Now, when I attempt to load VPVR, it starts to load a table, I hear sound but don't see any video, then it boots me back to the desktop after a few seconds. Now what should I do? I feel like I'm close to getting it to work.

Link to comment
Share on other sites

1 hour ago, LugofilmLtd said:

 

Okay! We're making progress! I got everything set up with baller installer, the non VR program works and I set up open composite following the instructions exactly. Now, when I attempt to load VPVR, it starts to load a table, I hear sound but don't see any video, then it boots me back to the desktop after a few seconds. Now what should I do? I feel like I'm close to getting it to work.

How are you attempting to load VPVR, by double clicking the VPinballX_GL.exe, any errors? Make sure your Oculus is connected (put on the headset to see the menu) before starting VPVR, are you still running through Virtual Desktop (wireless?) and are you using Steam VR? Open Composite does not work with Steam VR

Link to comment
Share on other sites

1 hour ago, studlygoorite said:

How are you attempting to load VPVR, by double clicking the VPinballX_GL.exe, any errors? Make sure your Oculus is connected (put on the headset to see the menu) before starting VPVR, are you still running through Virtual Desktop (wireless?) and are you using Steam VR? Open Composite does not work with Steam VR

 

I am double clicking GL.exe and at the moment I have my headset connected to my laptop directly because it occurred to me I might need to do that. I ran the open composite setup and told it to switch to open composite so it wouldn't use Steam VR anymore.

 

I feel like I'm missing something and I don't know what.

Link to comment
Share on other sites

17 hours ago, LugofilmLtd said:

 

I am double clicking GL.exe and at the moment I have my headset connected to my laptop directly because it occurred to me I might need to do that. I ran the open composite setup and told it to switch to open composite so it wouldn't use Steam VR anymore.

 

I feel like I'm missing something and I don't know what.

So you are not running wireless, are you using Oculus Link? If you are then make sure you select "Oculus Link" in the Oculus Headset before starting VPVR, also open the Oculus software and choose your Quest 2 (if using a Quest 2) then run a USB test to make sure all is good . If you have done this and still have issues you can try clicking "disable b2s" in VPX/Preferences/Configure Keys, Nudge and DOF, make sure VR is "Enabled" not set to auto in VPX/Preferences/VR Settings... and try unchecking "Disable VR Preview". If these suggestions don't fix it make sure you replaced the openvr_api.dll file with the 32Bit version and have created a new file called “opencomposite.ini” and added the one line "enableAudio=false" 

Link to comment
Share on other sites

1 hour ago, studlygoorite said:

So you are not running wireless, are you using Oculus Link? If you are then make sure you select "Oculus Link" in the Oculus Headset before starting VPVR, also open the Oculus software and choose your Quest 2 (if using a Quest 2) then run a USB test to make sure all is good . If you have done this and still have issues you can try clicking "disable b2s" in VPX/Preferences/Configure Keys, Nudge and DOF, make sure VR is "Enabled" not set to auto in VPX/Preferences/VR Settings... and try unchecking "Disable VR Preview". If these suggestions don't fix it make sure you replaced the openvr_api.dll file with the 32Bit version and have created a new file called “opencomposite.ini” and added the one line "enableAudio=false" 

 

I did all that and it's not working. I try and load a table and it acts like it's starting to, then boots me back to the desktop after a few seconds to a minute. When I try to run VPX VR Launcher 4 instead of the normal VPVR, I get an error message and the Openovr Log shows me this: 

 

DX11Compositor::CheckCreateSwapChain    - Generating new swap chain
oovr_abort_raw    - Abort!
ITrackedDevice::GetStringTrackedDeviceProperty    - unknown string property - dev: 0, prop: 7000
DX11Compositor::CheckCreateSwapChain    - Generating new swap chain

 

I'm stumped. I'm usually pretty good at figuring stuff out but I have no idea what I'm missing here.

Edited by LugofilmLtd
Link to comment
Share on other sites

8 minutes ago, LugofilmLtd said:

 

I did all that and it's not working. I try and load a table and it acts like it's starting to, then boots me back to the desktop after a few seconds to a minute. When I try to run VPX VR Launcher 4 instead of the normal VPVR, I get an error message and the Openovr Log shows me this: 

 

DX11Compositor::CheckCreateSwapChain    - Generating new swap chain
oovr_abort_raw    - Abort!
ITrackedDevice::GetStringTrackedDeviceProperty    - unknown string property - dev: 0, prop: 7000
DX11Compositor::CheckCreateSwapChain    - Generating new swap chain

 

I'm stumped. I'm usually pretty good at figuring stuff out but I have no idea what I'm missing here.

Maybe post your log over in the VR Launcher thread, Ba Sti might be able to determine what it means. 

Link to comment
Share on other sites

12 minutes ago, studlygoorite said:

Maybe post your log over in the VR Launcher thread, Ba Sti might be able to determine what it means. 

 

I got VPX VR Launcher 4 running in VR by switching the device in the config file from "openvr" to "oculus". That seems to be the key. Is there any way to tell VPVR to run through oculus rather than openvr? Because I think that might do it.

Link to comment
Share on other sites

3 hours ago, LugofilmLtd said:

 

I got VPX VR Launcher 4 running in VR by switching the device in the config file from "openvr" to "oculus". That seems to be the key. Is there any way to tell VPVR to run through oculus rather than openvr? Because I think that might do it.

Go into your Oculus Software on your PC, then go to settings and then general, there it will tell you what is set as your OpenXR runtime, if it's not Oculus then you can switch it there. Also, make sure Steam is not starting when you launch VPVR

Link to comment
Share on other sites

31 minutes ago, studlygoorite said:

Go into your Oculus Software on your PC, then go to settings and then general, there it will tell you what is set as your OpenXR runtime, if it's not Oculus then you can switch it there. Also, make sure Steam is not starting when you launch VPVR

 

Yeah, I checked that and the XR runtime IS set to Oculus and Steam DOESN'T start when I launch VPVR. It doesn't work. On a hunch, I tried running it through Steam VR again and it gave me an error message that said "wrong video card". I checked my Nvidia drivers and they were all up to date. I let Windows install an update that it hadn't yet in case there was something there but it still doesn't work. When I try to open the Nvidia control panel it opens to a page that says "manage 3D settings" but immediately  closes. the problem might have something to do with that but I don't know what. Rolling back to earlier Nvidia drivers if the present ones are incompatible doesn't appear to be an option.

 

UPDATE: I fixed the problem with the control panel crashing, added VPVR to the list of programs and tweaked a couple of settings to tell it to specifically use the Nvidia graphics card. No effect. It still doesn't load.

Edited by LugofilmLtd
Link to comment
Share on other sites

15 hours ago, studlygoorite said:

Go into your Oculus Software on your PC, then go to settings and then general, there it will tell you what is set as your OpenXR runtime, if it's not Oculus then you can switch it there. Also, make sure Steam is not starting when you launch VPVR

 

Okay, so after getting nowhere with openvr/oculus, I reset it to Steam VR and found that it was giving me the following error message and VPVR is the only thing that does. Everything else I run through Steam VR works perfectly. Any ideas? 

20211013_202746.jpg

Link to comment
Share on other sites

On 10/13/2021 at 4:38 PM, studlygoorite said:

Go into your Oculus Software on your PC, then go to settings and then general, there it will tell you what is set as your OpenXR runtime, if it's not Oculus then you can switch it there. Also, make sure Steam is not starting when you launch VPVR

 

SUCCESS!!! I got VPVR working! After my last post here, someone elsewhere told me I needed older Nvidia drivers and pointed me to the ones he used. That did the trick. Thank you for helping me figure all this stuff out. I really appreciate it.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...