Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
scampa123

Some Tables hanging at "Starting Game Scripts".. B2S???

Recommended Posts

I've been recently noticing some odd loading behavior and am hoping someone may have seen this or would know how to address.

Some of my tables are taking a looong time to load and if I Alt-Tab I can see that VPX has a dialog sitting at "Starting Game Scripts".  The tables eventually will load.  I've tried this with Popper and directly from VPX.  The tables happen to have PUP pacacks as well...

Master of the Universe - This table was taking long (1.5mins+) to load.  I found that if I had the table outside of my Tables folder it loaded really fast.  Through many iterations I removed things from my tables dir until I figured out what it was.  In this case it was was my B2STableSettings.xml.  What's odd is that this table did not even have an entry in there.  I found it was the defualt <DefaultStartMode> was set to 2 and if I changed to 1 it loaded fast again..In the end I added a block to the file for <motu> and had <StartAsEXE> set to 1 and changed the <DefaultStartMode> back to 1…and it seemed to work. 

I'm not sure what DefaultStartMode does for tables not running a B2S, but I can try setting it to 2..but I'm shooting in the dark here!  I can't find a schema or explanation for the fields in the B2STableSettings.xml file...

I tried to launch The Munsters this morning and I'm seeing similar behavior where it takes long to load sitting on "Starting Game Scripts".   I haven't had a chance to see if I launch the table outside of the Tables folder if it will launch differently.

Neither table runs a B2S.  I suspect B2S runs due to DOF or something... I'm not even certain the problem is with B2S for Munsters, its just what I noticed helped MOTU...It is odd that I'm suddenly having this issue with multiple tables however...not all though.

The only other thing I can think of is that recently install P-ROC and I'm trying to see if that registered something or messed with B2S in some way...

Any ideas would be appreciated!!

 

Share this post


Link to post
Share on other sites

I changed DefaultStartMode back to 2 and left the block for MOtu....It all seems to load fast again.  I’m not really sure what it’s doing but it’s working I guess!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...