Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
dzorbas

Problem with PIN2DMD EVO board installed in a Data East WWF

Recommended Posts

Is the install of an EVO board straight forward on a Data East machine? Wiiliams/Bally machines it's just plug in the power and get the ribbon cable the right way and you are good to go. I have someone trying to get one installed on a DE WWF machine and he gets nothing but the logo screen. Works fine with his original display. He has colour files on the SD card.

Any suggestions would be appreciated.

Thanks,

Dino Z.

 

Share this post


Link to post
Share on other sites

Should be straight forward. You can try setting DataEast mode or alternatively Whitestar in the onscreen menu. 
I just recently had the same problem in a Lethal Weapon and it ended up being a "repaired" power connector 
on the DataEast DMD controller board. The connector did not have a proper connection to the PCB on the GND pin.
The GND connector connection is on the topside of the PCB beneath the connector housing which is hard to solder if the via is missing.
It worked with a plasma though, because it got GND connection through the DMD power connector.

Share this post


Link to post
Share on other sites

Thanks for the info. I was able to test on a DE Tommy last night. No issues. I looked at a picture from the guy that is installing it and it looks as though he unplugged the ribbon cable from the DMD controller and plugged that into the pin2dmd board instead of the connector on the other end. Could be a matter of confusion. Hope it's that simple!

Share this post


Link to post
Share on other sites
11 hours ago, dzorbas said:

Thanks for the info. I was able to test on a DE Tommy last night. No issues. I looked at a picture from the guy that is installing it and it looks as though he unplugged the ribbon cable from the DMD controller and plugged that into the pin2dmd board instead of the connector on the other end. Could be a matter of confusion. Hope it's that simple!

So he connected the old plasma panel to the pin2dmd ?🤦‍♂️

Share this post


Link to post
Share on other sites

That's what it looked like in a picture he sent me although he says he plugged it into the DMD controller. We sorted that out but he is still having an issue. He has 2 pin2dmd boards and says they are both doing the same thing, no video from the pin. He's going to try an external power supply in case there isn't enough power to the display. I can't believe that is problem if the display is booting and getting to the pin2dmd logo. He has a couple of other games so he is going to plug one in to see if they are working. 

The investigation continues...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...