Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Recommended Posts

@Terranigma : I've well received the files, thanks, I h'aven't checked the dump files yet, but I watched the video, and I was surprised to see the "skill shot" animation, as it is different from the one I have on my ROM !!!  I'm using 1.12, but it seems, that it is not the lasteste display file... ! 
I did see the Daat east, first not colored, and then blocked... so frustating considering the time I spent on it... ! I will correct that strating tonight... 

data-east.gif.18c97997413a5d866597cc451de16b34.gif

 

Share this post


Link to post
Share on other sites
1 hour ago, dtatane said:

@Terranigma : I've well received the files, thanks, I h'aven't checked the dump files yet, but I watched the video, and I was surprised to see the "skill shot" animation, as it is different from the one I have on my ROM !!!  I'm using 1.12, but it seems, that it is not the lasteste display file... ! 
I did see the Daat east, first not colored, and then blocked... so frustating considering the time I spent on it... ! I will correct that strating tonight... 

data-east.gif.18c97997413a5d866597cc451de16b34.gif

 

That's great you have found the issue. Hopefully it isn't too much to get it working on the latest display rom and also could explain why there is a few frames of just red instead of colour at the end of each scene.
I will be ready to test whenever you have something new. Thanks for the ongoing work!

That Data East coloured animation looks great :D 

Share this post


Link to post
Share on other sites

Thanks again @Terranigma for sharing the dump files.. I can move forward !

Attract mode has been changed to ColorMask Mode, and it should display "Tales from the crypt" with the right colors and continously. 
I've added the missing frames at the end of the skill shot sequence, displaying "skill shot" correctly.

The fact is that my recording is definitely on the right ROM but for any reason, the sync is so different from real pin to vpin that I miss a lot of frames :
- when it happens at the beginning of a sequence -> the color is not loaded correctly (it was the case in your dump with one DATA EAST logo in attract mode)
- when the colors were displayed, there's almost 10% of additional frames on realpin due to sync issues -> the color sequence is not long enough and the last frames displayed are, therefore, not colored

To correct that, I will switch as much sequences as possible to ReplaceSequence Mode, i already did :
- data-east logo
- skillshot
- dynamite feature (general animation when we see the flame going from left to right to lit the TNT)

Could you please give it a try and see if the red frames at the end of these sequences disappeared ?
If so, I'll go on resetting all the hashes of the sequences

Share this post


Link to post
Share on other sites

No problem. I am just on my way out but I will quickly test the new build for you for those changes now. I will report back in a few minutes.

Data East logo animation is still red. The next ones still get stuck.

The finger for the push start animation also is stuck same as before.

Tales from the crypt animation is GOOD! No red at the end now.

This is all I can test right now but I will be back later.

Share this post


Link to post
Share on other sites

To illustrate the differences, heres a slowed GIF of the frames recorded

REALPIN :

data-east-realpin.gif.dd8810e5d8100f58f18917d80c588136.gif

VPIN :

data-real_vpin.gif.9716058360b7d2d910c46ddfc4e89391.gif

Share this post


Link to post
Share on other sites

Due to the difficulty to change the sd card in real pin, I was waiting for an update, I wil try this one by the end of the week

 

great job by the way ;)

Share this post


Link to post
Share on other sites

To get rid of the sync problem it should help to split the scene into single frames and trigger them one by one, or use the layered color mask mode. With the single frame method you should also increase the delay time of each frame to maybe 500 or 1000. 

Share this post


Link to post
Share on other sites
On 10/27/2020 at 3:37 PM, dtatane said:

To illustrate the differences, heres a slowed GIF of the frames recorded

REALPIN :

data-east-realpin.gif.dd8810e5d8100f58f18917d80c588136.gif

VPIN :

data-real_vpin.gif.9716058360b7d2d910c46ddfc4e89391.gif

 

you should try making the same capture from the Setup.exe  found in your PINMAME folder.

I always strip the table down to its basic components (No flashers, minimal lights  ,   no large scale  images or prims (unless they are called by the code)

this ensures that the table is  not putting a  large strain on my PCs resources.

Share this post


Link to post
Share on other sites

New update - see changelog : 

 @Pinballuser ok, I'll try what you suugest to see if the result in different on my vpin

 

  • Like 2

Share this post


Link to post
Share on other sites

Hi all i think to test the last version during the weekend and i would send my comments ;)

Share this post


Link to post
Share on other sites

Do not forget to update pin2dmd firmware to 3.17 

Share this post


Link to post
Share on other sites
On 9/12/2020 at 7:14 AM, dtatane said:

TO DO / CHANGE LOG - EDIT 29/10 :
- crane jackpot : add keyframes
- world premiere countdown : to colorize 61/180 (at least) -> I should switch to LCM mode
- Double jackpot countdown : check mask & trigerring scenes (conflcit with danger bar or crane runaway) + some missing frames while the crane is going backwards to be tested
- LAH sequence : 
-- Hero + Last : to be recorded
-- Hero + Action : to be recorded

- smart missile : scene is not triggered sometimes -> to check and add additional frames
- Ripper blow-out countdown => initial colorization done.. I can't imagine agood solution. I'll keep that scene at the very end to find solution to improve it + added additionnal frames

I thought I recorded the last action hero scenes for you, if I missed them let me know and I can do them. 

Share this post


Link to post
Share on other sites

Yes, I did have all the scenes, I'm just missing a variation where you get action first, then, hero. I will have to record this one missing !
I've reset all keyframes for these sequences and all the variation.
I couldn't find a solution to colorize world premiere using LCM, so I did a basic colorization.

 

Share this post


Link to post
Share on other sites
9 hours ago, dtatane said:

Yes, I did have all the scenes, I'm just missing a variation where you get action first, then, hero. I will have to record this one missing !

Ok, would you like me to record that variation for you?

 

Share this post


Link to post
Share on other sites

Hi @Terranigma

@Yopi has tried to update his realpin with the lastest file, but it seems the pin2dmd is stuck at the very beginning.  Did you have the chance to test the lastest file on yours ?

I've been spending some time converting the animations that were in "replace" Mode to "ReplaceSequence" Mode in order to have a better sync for the scenes, and hopefully get rid of the final frames that remain not colorized. Did you see any improvements ?
Could you please also confirm if the "catch the red eye" countdown and "find benedict" countdown scenes are colored ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...