Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
kbueno

PIN2DMD unsigned mini-USB

Recommended Posts

Hi,

After a long journey I decided to acquire some plates of the excellent design of Lucky1 PIN2DMD EVO.

The pcb's have come to me recently and I'm wanting to install and activate the firmware for use.

I followed the step by step installation but my computer does not recognize the PIN2DMD in any USB input.

I noticed that when I connect the mini-USB to the card and connect to the computer I do not get any notifications or alerts when I connect or disconnect the USB and there is also no signal on the PIN2DMD. In the device manager without signal.

I tried the install attempt countless times through the executable DfuseDemo, ST-Link Utility and zadig, but I did not find any device signals connected to the PIN2DMD.

I only get the power light on the PIN2DMD only when I connect a 5V source, but I realize that there is no light or data signal through the mini-USB.

What can I be doing wrong or can I risk the plates being damaged?

Here are some pictures of the board and the display I'm using.

Any help is welcome.

Thanks for your help in advance!

DFuse.jpg

ST-LINK.jpg

PIN2DMD EVO 2.jpg

PIN2DMD EVO 3.jpg

PIN2DMD part1.jpg

PIN2DMD part2.jpg

PIN2DMD part3.jpg

PIN2DMD part4.jpg

PIN2DMD part5.jpg

display2.jpg

Share this post


Link to post
Share on other sites

To put the STM32 into DFU mode you need to

- hold the DFU button
- press/release the reset button
- release DFU button 


The evo should then register as a device in DFU mode.
Then use the choose/upgrade function of the DFU utility to upload the DFU image from my github. 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...