Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
OverSoftNL

PIN2DMD not getting past logo

Recommended Posts

I've built a PIN2DMD v3.1 shield and connected it to a STM32F4 Discovery board.
I've activated it and it works without flaws on Visual Pinball and VPinMame.
The input test runs without problems (pin 1,3,5,7 and 11 show when they're shorted to ground).
There is a SD card in there which works properly (updated the firmware from it), but i have no custom colorizations on it yet.

Now i'm trying to put it in my STTNG machine, but it doesn't seem to get any input.
It's set to Bally/Williams input, the latest firmware is installed and i've tried both with enhancer and without, but it doesn't show anything other than the logo with "Bally/Williams" underneath it (see photo).

I've tried a different ribbon cable between the machine and the PIN2DMD and i've tried turning it on before and after the machine, but it doesn't show anything other than this. (When i connect to original DMD, the display works fine)

I've also tried it on my Stern (Whitestar) High Roller Casino, but that doesn't go past the logo either.

I have a couple of other machines (a couple of WPC and WPC95's), but haven't tried the others yet.

Does anybody have any ideas on how to get the display up and running?

20181229_154955.jpg

Share this post


Link to post
Share on other sites

That was it!

I didn't populate the pins, because i couldn't find anything about the "enh" pins in the documentation. I've added the pins and a jumper and it works now.

Thanks for the help!

 

I do see a little bit of static on the middle and bottom rows though. Could that be because of the long cable between display driver and PIN2DMD?

20181230_140828.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×