Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
nickbuol

Pin2DMD keeps reverting back to Not Activated until I reboot

Recommended Posts

Working through my cabinet and did the physical build first, and now have been messing with the software so I haven't played a ton of games yet and don't even have a frontend menu system installed yet either.

But, for some reason when I play some tables (most tables) when I exit out of the table, but not out of VPX, the Pin2DMD will pop up that it is Not Activated and then won't work again until I power cycle the whole cabinet.

I am not sure if this is just with colored DMD tables or not, and will keep trying to find a pattern, but it happens A LOT.  

I have a valid license, and it works perfectly right after reboot, but between games it does this.

Please help.

 

Oh, I have an Uncle Sash built Pin2DMD that he made me around Christmas 2017 if that helps to put a "date of birth" on to the one that I have.

Share this post


Link to post
Share on other sites

So I tested it again and in the middle of TRON Legacy it just went to Not Activated. So it is happening mid-game it seems.

Sent from my SM-G965U using Tapatalk

Share this post


Link to post
Share on other sites

Are you running the latest firmware ? If not update. Info on pin2dmd.com

Share this post


Link to post
Share on other sites

Not sure how to check the current firmware version (probably in the update tool or something), but I will grab the latest and update.  

Share this post


Link to post
Share on other sites
When I 1st power mine up it says the firmware on the front of it

Share this post


Link to post
Share on other sites
>>>When I 1st power mine up it says the firmware on the front of it

 

Colorprism V2.51 is what I see. Looks like the latest is 2.58. Unfortunately the ST Link utility keeps saying "No ST-LINK detected" when I select Target>Connect. Might have to upgrade via microSD, which is unfortunate because getting to my Pin2DMD is not a simple task. Makes me almost wish that I put an access panel on the back of my backbox.

 

 

 

 

Share this post


Link to post
Share on other sites

Updated to 2.58 via micro SDcard. Need to try one other thing and then test it.

Sent from my SM-G965U using Tapatalk

Share this post


Link to post
Share on other sites

So far so good.  I played TRON Legacy, which I was getting about 2 minutes into yesterday before it would "fail" and go to not activated, and made it through a full game, then went to 3 more tables and played 2 balls each, all without issue.

Not sure that it all helped, but I updated the firmware to 2.58 as mentioned (via micro SDcard), I left the original PIN2DMD.DAT that was on the micro SDcard, but also added my activation key (renamed to pin2dmd.key).  I doubt that will do any good, but I did it anyway.

 

I made sure that I ran the zadig USB tool (I don't think that I ever did) and changed the Pin2DMD  device to libusb-win32.

I also copied all of the latest files into the Pin2DMD folder on my C: drive and overwrote the old files.

Lastly, I swapped USB ports just for kicks.

So I *think* we are good.  YAY! Finally getting some of the kinks worked out.  

  • Like 2

Share this post


Link to post
Share on other sites

I have firmware version 2.58 and still have the activation issue.  It works fine for about three minutes then it tells me it is not activated. Any ideas?

 

Share this post


Link to post
Share on other sites

Then it is not activated. Do you have a key ? Does the keynumber match the number on the display ? How do you activate ?

Share this post


Link to post
Share on other sites

I followed the directions on the PIN2DMD site.  

1) Connect the your controller to power, if not already connected.
2) Connect the STM board using the microUSB cable to your PC.
3) Copy the keyfile in the same directory where your pin2dmd.exe is located.
4) Start the pin2dmd.exe tool without any option.

 

It worked fine for a long time then the activation issue happened.  I do have a key and it no longer matches my display.  A couple of weeks ago I deleted everything from the controller and started over using the original key.  Now when the activation code comes up, it is different than it was originally.  If I need to purchase another key, that is fine but I want to be sure there isn't anything wrong where I would need to continue to purchase additional ones. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...