Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Joppnl

rev r4638 2nd start problems

Recommended Posts

**note** this thread is a continu from the official beta 3.2 thread as I didn't want to spoil it more with my findings and questions.**

Reason for my postings in the official thread was that pinmame startin with the xx30 rev's and further on are having the problem that pinmame fully crashes when starting a rom. No warning, no sings...crash.

This only happens when the external pin2dmd is active. Disabeling it and having the virtual display will run the rom's fine (so it's not a rom issue).

Now....about this 4638 version (thanks guys for your help and very fast response)

Something weird but I can reproduce the error now.

Ok...here it is: after copying the  new .dll into pinmame dir and running pinmame/test  my test-rom works out very well. (TZ94CH)
Pressing start gives the note in pinmame that it is running and the pin2dmd shows the TZ graphics.

 

But.....running a 2nd time the rom (press stop and directly start)  is impossible:  a direct hard crash of pinmame back to Win10.

Starting pinmame again and running the test won't help: a direct crash.

Now....rebooting the PC (soft reboot is fine) and starting pinmame / test : everything fine the 1st time but 2nd time the same.

 

And now something more interesting: For this TZ94CH rom I enabled the color option in the F3 game menu.

I do not have full color for it but a nice white graphics to a black background . pal file (see attachment).

When I rename the TZ94CH alt color directory (where the pal file is in) to a weird name so that pinmame can not find it and I restart pinmame/test: Everyting is fine!

 The color option in the game menu is still on but, as it can not find the directory it will display some kind of orange colors but stopping and running and stopping and running...everything is fine.

So it seems to be a combination of using a .pal file and running pinmame a second time.

** Edit: tested an other ROM-with-pal-file (term3) : same problem: after reboot first time ok, 2nd time crash, only reboot will help.

Thanks again so far!

 

tz.PNG.1c2715f37fe0aaee3fcc90c044c55f9b.PNG

pin2dmd.pal

Share this post


Link to post
Share on other sites

Thanks for testing.

I did not have freezy's extention as I am told that it has no benefit when you use a pin2dmd-display.

Nevertheless I installed it, but I couldn't get the real pin2dmd to work, only the virtual dmd which was looking 'freezy's '  (other pixel-shape) so that worked.

I did check the freezy's ini file to see if the pin2dmd was enabled but it was enabled by default.

Then I wanted to revert back to the working standard situation and...now nothing works at all anymore.

Time to do a total Windos X and VPX install......

 

Share this post


Link to post
Share on other sites

Could be related to the dmddevice.dll that @lucky1 ships himself.

But the other crash from the SAM thread that you were experiencing is fixed, right?

Did the new crash that you're bringing up here happen with older version, too, or is this now something new with the newest release only?

  • Like 1

Share this post


Link to post
Share on other sites

Mmmm....from memory:

All the xx30 rev's did have the crash error. 

What I experienced with the latest rev 4738 that it runs with the color enabled the first time but not the 2nd time (as described above).

I do not know if that was the case as well with older xx30 rev's but I am sure that the xx20 rev's did not have this problem.

But now...after the Freezy test-install pinmame crashes immediately even the first time (even with the xx20 versions) and I couldn't get it back to work so now I'm totally installing a complete new build including WinX and VPX...... 

What I will do: install a fresh WinX and a fresh VPX first without any additions like DOF or Lucky's dll or whatsoever and build it up from there and test every step and see at what time it is going wrong. (if the new build has the same problem).

Will report back but can take a while as I'm not at my cab for the next 3,5 weeks but will come back to you, thank you for the support!
 

Share this post


Link to post
Share on other sites

Reinstalling is often a good thing to do. Remember to export a few of those registry keys that holds rom settings, dmd location etc.

  • Like 1

Share this post


Link to post
Share on other sites

One more thing: The dmddevice.dll that you have in your PinMAME directory, where does it come from and which date/size has it?

Share this post


Link to post
Share on other sites

It was the file coming from the 2.55 version of the pin2dmd git-hub section (my pin2dmd firmware is 2.55)

Also tried it with the latest 2.58 version (both firmware and .dll) but same effect.

When I do the new install I will use the standard pin2dmd dmddevice.dll which comes with the all-in 1 installer but what I do not know is with what firmware version is corresponds... therefore I did use the dmd file from the corresponding firmware version.

Is there any benefit of using Freezy with a pin2dmd display?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...