Jump to content
Sign in to follow this  
latenite04

Pin2DMD Jumbled on Super Mario Mushroom World

Recommended Posts

I hooked up my display to my Super Mario Mushroom World machine and the image on the display is somewhat scrambled. I hooked up the old dmd and that works fine. I also connected my pin2dmd back up to my Street Fighter and the display is working correctly on that machine. I'm hoping it's a setting issue but I tried using the Gottlieb V1, v2, and v3 modes and they all looked about the same. This is running on a v4 shield with the latest firmware from github. Thanks in advance for any help.

 

 

Share this post


Link to post
Share on other sites

Looks like a power issue. Where do you get the power for the display from ? Make sure you have clean 5V
oder better a little below 5V (4.7 to 5V) to power the pin2dmd hardware.

Share this post


Link to post
Share on other sites

Thanks for the reply @lucky1. I'm getting power from a dedicated 5v 10A power supply. I checked it and it was a little high, 5.15v, so I adjusted it down to 4.9v. Hopefully I have time in the next few days to try it in the machine again.

Share this post


Link to post
Share on other sites

I tried the display in my machine again and it is having the same issue.  I also tried a second display and power supply and swapping the ribbon cable with the one from my street fighter. Both displays work on street fighter and are having the same issue on mario. I looked through scottyc's info from his mario colorization and unfortunately he has the 3.1 shield from german gaming so it's not a direct comparison but i did notice that he had the 2.41 firmware installed. @lucky1 do you have an older version of the firmware for the nucleo-144/shield v4 that I could try? I currently have 2.58 installed.

Share this post


Link to post
Share on other sites

The only files on the sd card are the key file and the pin2dmd.dat file with the config settings so it's running off of the pinball machine's roms. As far as I know there are no colorization files for this machine yet, I was hoping to do the dump and try coloring it. I was under the impression that this would act like a normal dmd even without those files. I did put the pal and fsq files from the other mario machine's project on the sd card once just to see if it would make a difference but I had the same issue.

Share this post


Link to post
Share on other sites
2 hours ago, latenite04 said:

I tried the display in my machine again and it is having the same issue.  I also tried a second display and power supply and swapping the ribbon cable with the one from my street fighter. Both displays work on street fighter and are having the same issue on mario. I looked through scottyc's info from his mario colorization and unfortunately he has the 3.1 shield from german gaming so it's not a direct comparison but i did notice that he had the 2.41 firmware installed. @lucky1 do you have an older version of the firmware for the nucleo-144/shield v4 that I could try? I currently have 2.58 installed.

If they are working both in your streetfighter it is not a firmware issue. Seems like a problem with your Gottlieb DMD controller.
Is there another ROM version available for the Gottlieb display controller you could try ? 

Share this post


Link to post
Share on other sites

Gottlieb V1 should be the right mode for Mario. I don´t think that your controller is defective, but maybe you have installed a ROM version which
I did not analyze / implement so far. There are at least 3 different versions for Mario I know of.

Share this post


Link to post
Share on other sites

O.K. I overread that it is a mushroom world. Gottlieb played a lot with the DMD signals in the early machines.
I think that has never been tested so far and that it works with super marion bros. does not automatically mean that it
works with super mario mushrooms world. If you want we can try to analyze what the problem is but you need to
buy a cheap logic analyzer to make a recording of the signals for me 

https://www.ebay.com/itm/USB-Logic-Analyzer-Device-Set-Compatible-to-Saleae-24MHz-8CH-for-ARM-FPGA-M100/253841718379

But first try swapping the DMD controllers.

Share this post


Link to post
Share on other sites

I tried swapping the controllers and changing the enhancer settings but neither fixed the issue. My logic analyzer arrived today in the mail. Is there a write up on how to create the signal recording?

Share this post


Link to post
Share on other sites

You need this software https://www.saleae.com/de/downloads/

Connect Pin 1,3,5,7,9,11 of your dmd controller to channels 0 to 6 and GND to any of the even pins (e.g. 2,4)

Look at the picture to find where pin1 is located.

With the analyzer connected through USB and the pinball machine turned on start the recording in the software with the button in the upper left.

You should see changing signals on all channels attached. Save the captured data and send me a download link through PM

IDC10WAY-M - Layout03.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×