Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
CarnyPriest

SAMBuild3.2 beta thread

Recommended Posts

All newer SAMBuilds, from May onwards, e.g. 3_2_SAMBuild_r4735.zip and higher, unfortunately disable Altsound Mode 1 on THE GETAWAY: HIGH SPEED II.
With other tables I haven't noticed any malfunction like with HS2.

Only with the older version from March 3_1_SAMBuild_r4723.zip it works again with the altsound 1 method at THE GETAWAY.

If someone doesn't have the HS2 Sounds or the SAMBuild from March:

https://www.dropbox.com/s/mrpp2arn02e0nfq/3_1_SAMBuild_r4723.zip?dl=0
https://www.dropbox.com/s/b6qc966nuelzhg8/gw_l5.zip?dl=0

 

The problem was confirmed by several people.
Can someone please look at it?
Thank you

  • Like 1

Share this post


Link to post
Share on other sites

Again I
The T2 altsound 1 from http://altsound.vpin24.com/ doesn't work with the old SAMBuilds from March. 

With the new SAMBuild it works
Hope you find these bugs quickly, keep your fingers crossed.

Share this post


Link to post
Share on other sites

Relax. All the devs do their work on their own time. If you want it done quickly - do it yourself.

Share this post


Link to post
Share on other sites
Relax. All the devs do their work on their own time. If you want it done quickly - do it yourself.



Soniq2 is a nice guy. I think it got a bit lost in translation as English is not his native language.
  • Like 1

Share this post


Link to post
Share on other sites
On 5/31/2019 at 2:57 PM, soniq2 said:

Again I
The T2 altsound 1 from http://altsound.vpin24.com/ doesn't work with the old SAMBuilds from March. 

With the new SAMBuild it works
Hope you find these bugs quickly, keep your fingers crossed.

Contact @lucky1

 

Share this post


Link to post
Share on other sites

Dear CarnyPriest,

For some reason the slot for mtl_164hc doesn't seem to work. It says the ROM isn't available, while it actually is present.

Thank you very much in advance,

Themer

Share this post


Link to post
Share on other sites

Can't reproduce. Works for me. 

Patched with 

using bspatch

 

patched file must be named mtl164hc.bin. File size must be 100663280 bytes. File must be zipped into a zip archive named mtl_164hc.zip. The table's game settings needs to have Ignore ROM CRC errors enabled. 

If you have trouble with colorization then post a request for support somewhere in the Pin2DMD forum. Someone will help you out with the correct hardware/software to use.

Good luck.

Share this post


Link to post
Share on other sites

Ok, that must have been my mistake. I don't know what went wrong, but i recreated the ZIP-file and now it works.

Thanks again!

Share this post


Link to post
Share on other sites
On 5/31/2019 at 2:32 PM, soniq2 said:

All newer SAMBuilds, from May onwards, e.g. 3_2_SAMBuild_r4735.zip and higher, unfortunately disable Altsound Mode 1 on THE GETAWAY: HIGH SPEED II.
With other tables I haven't noticed any malfunction like with HS2.

Only with the older version from March 3_1_SAMBuild_r4723.zip it works again with the altsound 1 method at THE GETAWAY.

If someone doesn't have the HS2 Sounds or the SAMBuild from March:

https://www.dropbox.com/s/mrpp2arn02e0nfq/3_1_SAMBuild_r4723.zip?dl=0
https://www.dropbox.com/s/b6qc966nuelzhg8/gw_l5.zip?dl=0

 

The problem was confirmed by several people.
Can someone please look at it?
Thank you

The folder structure of the Getaway zip file is scrambled and therefore not supported in mode 1. In scrambeled soundsets the folder names start with a 10 digit number. In unscrambeled soundsets it starts with a 6 digit number. However it could be that the old parsing routine took the command numbers from the filenames, but that is bug and not really reliable and could lead to unpredictable results. Maybe someone has the time to write a small scipt to replace the 10 digit numbers of the foldernames with the 6 digit numbers from the files in these folders or even create a altsound.csv for it. That would fix the problem properly

Share this post


Link to post
Share on other sites

Pretty sure the whole point of encrypting the folder names was to protect Wms/Bally IP. I’m thinking it is not trivial to map to the old address-based folder structure. If your friends are on Facebook, maybe someone in one of those VP groups can hook you up with the old version from prior to PinSound’s license with the Wms/Bally holders. I’ve heard someone on Facebook was maintaining a repo with the old mixes. Don’t ask me. I’m not on Facebook. IMO, for original sounds you are better off just using PinSound Studio/soundmode 2 and using the mixes available at the main PinSound site. I believe as official licensees, The PinSound mixes are straight from the Wms/Bally vault or at least from the DAT masters and are as good in quality as you are going to get. I haven’t put it to the test. I still mostly use good ol’ vPinMAME emulated sound, and there have been recent improvements in sound recently. The community mixes I think use the encrypted folder names so require soundmode 2.

i do appreciate work done to turn soundmode 1 into a more robust open source option for new orchestration/remix projects that are not dependent on PinSound Studio, but I haven’t seen or heard any projects that are taking advantage of it yet.

Share this post


Link to post
Share on other sites

It is not about Wms/Bally IP. It is about making sure that the soundsets are not used with anything else but their commercial product. As always it is all about money. Pinsound even knows that the sounds used in community soundsets infringe copyrights and that is the reason why the pinsound-community.org site has no disclaimer is registered in panama and hosted in romania.They sent letters to members of the vpin community to take sites down which hosted soundsets in the unscrambled format claiming that these soundsets are their IP which is absolutely nonsense because they are made by the community. That is why the new altsound format was intruduced that the community still has the possibility to create soundsets without getting in conflict with pinsound. AFAIK there are some soundsets making use of the new altsound format already, like LOTR (link in a post above), but I didn´t have time to test them.

Find attached the altsound.csv for the getaway soundset. I wrote a little script that generated the altsound.csv from the commands in the filenames. You need to move all .ogg soundfiles from the encrypted subfolders (jingle etc) up to the gw_l5 folder and copy the altsound.csv to it.  You then can remove the empty subfolders and the pinsound config files and it sound work with the latest sambuild.

altsound.csv

Share this post


Link to post
Share on other sites

Gotcha. This is for one of the MrTantrum mixes. Thought we were talking about original mixes. The addresses in the folder names are not encrypted so I don't know why it would not work the same as the old soundmode 1 in the first place. But I haven't put it to the test. I looked at my collection of mixes from pinsound-community and looks like ones from the past several months have encrypted folder names. But there are a handful that slipped through with unencrypted folder names.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...