Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
CarnyPriest

SAMBuild3.2 beta thread

Recommended Posts

I have to double verify everything before I open my mouth when so many say they have a issue. But, I became aware of the color patch just late yesterday and applied it. No issues. FF is working and so is colors. It was late and I only had time to barely test it before heading to bed. I'm on pindmd3, maybe the problem lies somewhere else ?

Share this post


Link to post
Share on other sites

Fixed

Make sure this is the name of the bin before you zip it up

mtl180hc.bin

or this

MTL180hc.BIN

Share this post


Link to post
Share on other sites

Find it a bit weird that you are saying this @outhere - not that I don't believe you. I mentioned it already a few times that I've seen this behaviour before. If the rom inside the zip isn't 100% correctly named it may lead to issues. I remember a few times where I've told people to rename their rom inside the correctly named zip and it has resolved their problems. I've also seen cases where this has not been important. Now, this is a "color enabled" rom. Maybe it is so that in order to get color working, the rom needs to match pinmame 100% ? Food for thought ?

  • Like 1

Share this post


Link to post
Share on other sites
I don't recall seeing or reading anything about it, that doesn't mean I didn't
I guess I assumed since the Rom is working it must be right  
I've already had it were the rom didn't work because I didn't have the bin named right but that was always either it worked or didn't...

 

Share this post


Link to post
Share on other sites

Makes sense that you'd want to use the correct file name in the zip. If you disable CRC check (as you must do with a patched file), how else would VPinMAME identify which file to load unless the file name was spelled correctly?

By the way, I can't confirm the behavior for mtl180h. I haven't tested on my cab, yet. For those not getting color with the patch, have you copied over the pal file to mtl180hc folder within the altcolor folder? Gotta use both the patch file and the palette. 

I was not even aware of the patch until yesterday. Should have known something was up when DJRobX added fastflips.

Wouldn't it be great if we get a patch for st162h?

 

  • Like 1

Share this post


Link to post
Share on other sites

sorry for ignorance,  but how does one tell if fast flips works or does not in Metallica 1.8?

also,  how would one "turn it on" beside downloading the latest sam build here, any other steps?

Share this post


Link to post
Share on other sites

1. Patch rom.

2. Change table script to match new rom name.

3. Make sure that the table script has Fast Flip enabled ( github repo has it pr example ).

4. Test by starting table - press F11 and look at left flipper response. Should not fluctuate and be very close to 0ms at all the tests. If it is not working you see approx 0-20ms fluctuation.

  • Like 1

Share this post


Link to post
Share on other sites

thanks, will do and test,

and as far as the script having fast flips enabled, with this game it should look like this?

Const UseVPMModSol = 1

Share this post


Link to post
Share on other sites

ahh, this maybe?

 

Sub table_Init

' VPMInit Me

InitVpmFFlipsSAM

UpPost.Isdropped=true

With Controller

.GameName = cGameName

If Err Then MsgBox "Can't start Game " & cGameName & vbNewLine & Err.Description:Exit Sub

.SplashInfoLine = "Metallica (Stern 2013)"

.HandleKeyboard = 0

.ShowTitle = 0

.ShowDMDOnly = 1

.ShowFrame = 0

.HandleMechanics = 1

.Hidden = VarHidden

On Error Resume Next

.Run GetPlayerHWnd

If Err Then MsgBox Err.Description

End With

Share this post


Link to post
Share on other sites

3rd line - yes. I think it is already mentioned in this thread a few times.

Share this post


Link to post
Share on other sites

ok, will try it out later,, also.. thanks for the help. i do not do computer stuff for a living, like some of you may, but i dont mind learning new stuff.  I just ask to keep that in mind, that basic stuff for you guys, I may not know. 

Share this post


Link to post
Share on other sites

Okay I can confirm as well renaming the bin file was the issue.  Although I have a question to why naming changes things

If I name the bin file, the zipped bin file, and the color file mtl_180hc then I get the white letters as well as no fastflips

If I change the bin file to mtl180hc and leave everything else the same then i get fast flips and the colored rom as expected.  I guess I always thought .bin and the zip files should match, seems like this is not always true??

 

Share this post


Link to post
Share on other sites

No, not always true. If you want to know the name of the bin file, use Setup.exe and Test feature.

Share this post


Link to post
Share on other sites

it doesn't matter to have a certain name of the bin file, for roms that needs to match the hash of the rom that is foreseen in vpinmame.

this applies to all roms except the stern patched colored roms, for these ones, we have to uncheck the ignore crc option.

Then vpinmame don't do a crc check, then i guess the name of the bin file is what vpinamme uses to match the respective folder inside the altcolor folder

  • Like 3

Share this post


Link to post
Share on other sites

Okay makes sense, thanks for the clarifications. 

Share this post


Link to post
Share on other sites
Will this one be updated as new roms are added or will that be the start of a new Beta cycle?

Share this post


Link to post
Share on other sites

New beta cycle. Until that happens feel free to post any reports to this thread.

Share this post


Link to post
Share on other sites

Fixed date for 3.2 release [volkenborn]

for whatsnew files only

No change to dll or exe. No need to re-download unless you just want to have the release date documented in the whatsnew files

Share this post


Link to post
Share on other sites

I've come across a "Bug?"

Metallica Premium Monsters (Stern 2013) mod 1.5

Comes back with : Variable is undefined: 'InitVpmFFlipsSAM'

Which didn't happen with the previous SAM Build, but this also has the color rom, so dunno if that did something wrong.

Share this post


Link to post
Share on other sites

Hi, found a bit of a problem with the Bally Game Show (gs_La3)

IT seems that the gates for the loops are not working properly. The gates are suppose to allow the ball the go the full loop down the lit loop path for either a letter in one of the prizes or an extra ball. IT seems that the machine doesn't allow that and just have all balls go to the cash lanes, regardless if the loop was lit or not.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...