Jump to content

Recommended Posts

I have the R1 version of DOF running with VPX and my Pinscape controller just fine.  I upgraded to the new version of PinballX 3.05 and cannot get it to work.  I can register the com object just fine.  I go into the PinballX folder.  Put the PinballX dll into the plugins folder.  Run the plugin manager from the PinballX directory, click the PinballX DOF plugin to configure, and it says it cannot find the com manager running.

Any suggestions?  I have tried upgrading to the R3 beta but I can’t get it to work even with VPX.  Not a big deal as I have it working when I launch the table.  Just don’t have button lights in the PinballX.  

Share this post


Link to post
Share on other sites

That was it.  Thanks!

 

Next question is on a couple games that don't light my flippers.

 

In my plugin log I see that the match is good but the ones that don't light all say the same thing...

 

18.07.31 06:35:20.596 Best match for ACDC is ACDC (acd_168hc). Match Value: 1
18.07.31 06:35:20.603 Game selected AC/DC (No update sent)

Where all the ones that light say that an update was sent.  This happens on Spider-man, Shrek, and Tron too.  Any ideas why?  In VPX they light up fine.  The rom names are all correct and have entries for the flippers.

 

What is strange is that it doesn't seem to pull from the DOF config files.  I have AFM setup as Green.  The default was red.  In PBX is shows up red.  Anyone know how PBX pulls table configs?

Share this post


Link to post
Share on other sites
On 8/1/2018 at 6:32 PM, Sch007er said:

Found it...PinballX is a table in the DOF.  That is what I was missing.

 

 

Hi ,  how did you resolve this ? I am having the same issue with ACDC in PinballX not showing UnderCab lights

Share this post


Link to post
Share on other sites
7 hours ago, kiwi said:

 

 

Hi ,  how did you resolve this ? I am having the same issue with ACDC in PinballX not showing UnderCab lights

What I didn’t realize is that PinballX is just listed as another table in your DOF config ini file.  That PinballX listing has a huge Boolean statement in it.  If you used a different Rom name because it is a colored Rom, you need to add that name in the Boolean argument.  Basically it is saying if the game is this, this, or this, set the left flipper to red OR if the name is this, this, or this, set it to green OR ...

 The same I assume holds true for the undercab lighting.  Things get complex when your Rom names don’t match the Rom name in the online config tool.  Then you are editing the ini by hand.

Share this post


Link to post
Share on other sites
2 hours ago, Sch007er said:

What I didn’t realize is that PinballX is just listed as another table in your DOF config ini file.  That PinballX listing has a huge Boolean statement in it.  If you used a different Rom name because it is a colored Rom, you need to add that name in the Boolean argument.  Basically it is saying if the game is this, this, or this, set the left flipper to red OR if the name is this, this, or this, set it to green OR ...

 The same I assume holds true for the undercab lighting.  Things get complex when your Rom names don’t match the Rom name in the online config tool.  Then you are editing the ini by hand.

 thanks -  Will take a look at this tonight.  :)

Share this post


Link to post
Share on other sites

I have had flipper color lights working in VPX but not in PBX in the past. What i found was that PBX was looking for the directoutputconfig file located in the direct output\config folder. when i copied the directoutputconfig file from my tables directory to overwrite the one in the direct output\config  folder all was working.

Share this post


Link to post
Share on other sites
22 hours ago, lizard said:

I have had flipper color lights working in VPX but not in PBX in the past. What i found was that PBX was looking for the directoutputconfig file located in the direct output\config folder. when i copied the directoutputconfig file from my tables directory to overwrite the one in the direct output\config  folder all was working.

 

So, I dont have a directoutputconfig file in my tables directory, only on the directputput\config  folder...  well, I actually have these:

directoutputconfig30.ini
directoutputconfig51.ini

so, I copied directoutputconfig30.ini and renamed it directoutputconfig.ini in the same folder, and now PinballX shows the undercab lighting!! ha! Perhaps the PlugIn is coded to look for a default .ini name ??

thanks for your tip!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×