Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Twistedsistem

PIN2DMD unwanted coloring help!!

Recommended Posts

All,

I am using a PIN2DMD with the v3 shield.  I have flashed the latest firmware as of 3/18/2018.  I have a fresh install of windows, virtual pinball, pinmame 3.0 sam build, dmdext.  When I run tables such as South Park or World Cup Soccer as my testing tables the virtual dmd shows the video exactly as the tables were built and function (I have a neighbor with World Cup Soccer that we are comparing with), but the PIN2DMD is adding a light blue/gray tint to some things like the coin in the insert coin animation and in the high score scroll through on south park.  I have attached the images below to show my settings and to see if anyone can help me stop this from happening.  Any help would be greatly appreciated!!!!

 

 

pin2dmd showing odd color.jpg

virtual dmd view.jpg

pinmame Settings.jpg

Share this post


Link to post
Share on other sites

Choose either you want to use the internal dmd OR external dll. You checked both which might cause problems.

Additionally you might want to remove the altcolor folder if you have some folders and files inside.

Please test and report ;)


Gesendet von iPhone mit Tapatalk

Share this post


Link to post
Share on other sites

Looks pretty original to me... ;)

If you check colorize and set it to different orange shades do you still get the wrong colors?


Gesendet von iPhone mit Tapatalk

Share this post


Link to post
Share on other sites

How are your settings for the 4 different colors in pinmame (0,33,66,100%) ?

Could it be that you use the dmddevice.dll for pindmd2 instead of mine from github ?

Share this post


Link to post
Share on other sites

Lucky1 - the 4 different colors in pinmame are set like the picture in the first post.  I haven't changed them at all.

I just went through and put the dmddevice.dll from github into the pinmame/PIN2DMD folder and in the pinmame folder.

After doing this and unchecking use colorization i still get the same results.

Share this post


Link to post
Share on other sites

OK here is what i did.

 

I did a fresh install of windows.

Installed vpx using the all in one installer

Told it to add support for PIN2DMD

ran everything as admin and used the WCS from monsterbashpin.

Still get the light blue/gray coloring.

Grabbed new dmddevice.dll from lucky's github and put it in the pinmame folder

same light blue/gray coloring

 

I am quite sad at this point and running out of ideas on how to fix this besides using an LCD for my DMD which i don't want to do.

Share this post


Link to post
Share on other sites

It is definitely a problem with your setup and not a general pin2dmd problem.

Please change the 4 colors in pinmame and see if the colors on the dmd change accordingly.

Share this post


Link to post
Share on other sites

i changed the four colors and was getting different results yes.

 

One thing i was trying to do was to use the menu and options button on my shield to see if there was a reset or something on there and it doesn't cycle through a menu or anything for me.  Don't know if that is a problem or not.

Share this post


Link to post
Share on other sites
54 minutes ago, Twistedsistem said:

i changed the four colors and was getting different results yes.

 

One thing i was trying to do was to use the menu and options button on my shield to see if there was a reset or something on there and it doesn't cycle through a menu or anything for me.  Don't know if that is a problem or not.

different results means you are getting the colors you choose ?

Menu is not a problem. Do you have a SD card inserted ?

Share this post


Link to post
Share on other sites
1 minute ago, lucky1 said:

different results means you are getting the colors you choose ?

Menu is not a problem. Do you have a SD card inserted ?

Yes i was able to get it to show only shades of orange if i changed to colorize and put in custom values for all 4.

I do not have an SD card inserted.

Share this post


Link to post
Share on other sites
2 hours ago, lucky1 said:

And if you disable colorize and change the value of 100% to full red (255) ? Do you get a red palette ?

Lucky1 - i first want to say thank you very much for helping me troubleshoot this!!!j

When I disable colorize and put in a full red value for 100% I did get a red palette and it was just different shades of red throughout the gameplay.

Share this post


Link to post
Share on other sites

Then everything seems to be working as expected.  

If colorize is not checked it takes the 100% color and calculates the shades from it.

If colorize is checked and no palette is found for that rom in altcolor it takes the values from pinmame.

If palette is present in altcolor it takes that palette.

Share this post


Link to post
Share on other sites

The color shifting is coming from the ROM and not directly hardware related.

When you change the palette to 4 shades of a single color you won’t have these shifts during transitions.

Or use the full color rom, especially that one for smb is great.

And don’t forget to send the creator a beer ;)


Gesendet von iPhone mit Tapatalk

Share this post


Link to post
Share on other sites

This problem is Gottlieb and WPC emulation specific and has nothing to do with the hardware.
You can compensate it either by using a monochrome palette or a full colorization.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×