Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Ciceronic

DOF not working in VP, but in DOF testing??

Recommended Posts

Hello

I need some help to isolate my problem. I'ven running A LOT of testing, reading, testing, etc but I can't understand what's wrong.

I have Teensy + one strip 156 addressable LED's running right+back+left side.

If I load Medieval Madness in DirectOutputConfigTester.exe, I get solenoid and switches list. While sending pulse or activation all my LED's respond nicely.

BUT when I start the exact same table in VP nothing happens??! No blink, nothing...

Plugins are activated, DOF is running, table is running, no lag, etc etc.
What could cause this behavior?

Share this post


Link to post
Share on other sites

Ok thanks, I tried a couple of more times, same results. I can't find any difference compared to
https://directoutput.github.io/DirectOutput/installation.html

But b2sserversettings.xml ??
I made a search for that and could not find it! Interesting, where is the standard location for that file?

Otherwise, is a full re-install including windows a good option?
Been struggling for weeks, at this moment I hate this Pinball Cab more than my wife does...

Share this post


Link to post
Share on other sites

Post your GlobalConfig_B2SServer.xml,  Cabinet.xml and log File

Share this post


Link to post
Share on other sites

Nope, makes no difference...
Every LED responds in "DirectOutputConfigTester", but at table in VP all LED's dead.

Other idea´s ??

In my opinion: If the LED's are acually working, then it must be related either Teensy or B2S sending and receiving commands.
Teensy is flashing in blue constantly repeating: Two blinks - short pause - two blinks - short pause - two blinks - short pause - etc..
I've tried connecting Teensy to another USB-port. It made no difference..

Share this post


Link to post
Share on other sites

Thanks, I followed the same directions.

This is so strange..
Today I've reprogrammed the teensy, reconfigured and tested COM7 instead of COM3, played with baud, bits in the serial config. Reinstalled B2S (incl clean it out of registry).

Whatever I try I get the same result. Testing config all LED's OK, playing table no LED at all.
I don't have one single error message, everything looks just like pictures/directions.

If I could get some reference from working setups, I might figure it out...
* How is your teensy blinking/responding while playing table in VP?
* What version of B2S are you running?
* Is there any program to monitor the B2S communication?

Share this post


Link to post
Share on other sites

Now I saw it!! Blue color LED at the teensy means it's not original. Very strange, I bought it at a trusty european electronic store.

New teensy board ordered! 

Big thanks for the support, I was totally focused that it was a communication problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...