Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

problem pin2DMD power supply 5 volts board STM32

Recommended Posts

Hello everyone ,
I use a shield V3 + STM32, here is my problem, when I plug the STM32 on the USB port of my computer and that I feed the leds RGB panels with the 5 volts everything works correctly. the three red leds on the board STM32 lights.
view the photo 1.
now I want to install the pin2DMD in my pinball,
I feed the LED panels with the 5 volts and I power the V3 shield in 5 volts, and I have only two red leds that lights up on the STM32 and therefore no pin2DMD that works if I remove the 5 volts of the LED panels, the three LEDs of the STM32 lights up,
I tried to feed the STM32 directly on the map ditto it does not work

view the photo 2.
so I did another test
Power supply 5 volts LED panels + board QSTM32 mini USB on computer + board pinballsur shield V3, it works.
so I tried to cut a mini USB and power the mini usb with the 5 volts, it does not work. two LEDs lit on the STM32
it looks like there is a conflis between the 5volts of the STM32 and the 5 volts of the LED panels.
sorry for my English, I hope you come to understand me.
Thank you for your help



Share this post

Link to post
Share on other sites

yes lucky 1 I flash the STM32 firmware 2.51

activation key installed that you provided me

the pinball works, but I have to put the mini USB of the computer for the STM32 to work,
any other power supply the STM32 the led 5VOLTS is not lit and it turns on again as soon as I remove the 5 volts of the leds panels.
I tested another STM32 and also another shield ditto
remains more than the LED panels.
What I do not understand is that it works when I connect the STM to the computer via the USB port.

Share this post

Link to post
Share on other sites

First of all you should use the screw terminal and make a solid connection to 5V and GND instead of using a jumper wire to the power source pinheader.

Then you should place a jumper on 1-2 (EXT) for the power supply jumper. If that is not working you should ask @UncleSash what could be wrong.

Share this post

Link to post
Share on other sites

I already tried the terminal block and the black power plug,

and the jumper was good on 1-2 EXT position.

I exposed the problem to Uncle Sash and he does not understand why it does not work

I tested two shields and two STM32s and it only works when I plug in the USB power supply of the STM32.

Share this post

Link to post
Share on other sites

I can see on your tutorial 2 different way of installation 

Installation using ST-Link interface
(STM32F407 Discovery Board and Nucleo 144)

And this one
1.2 Installation using boot mode
(custom controller without ST-Link interface)

Which one i need choose for a real pinball machine ? 
At the begining i used the 1.1 process installation not the 1.2
So the STM is already flashed with the 1.1 step of your tutorial.

And now i try the 1.2 installation and i can't do it because i don't understand the step 3 and 6

- 3) Set controller into boot mode (DIP2 off for DMDST32) and powercycle.
- 6) Set controller into run mode and powercycle

*When i lauch Dfuse Demo v3.0.5 i can't select any device (blank)
I don't understand how i can flashed with Dfuse

*When i lauch Zadig 2.1.2 i can't see PIN2DMD device but only 3 others like STM link or STM storage


Share this post

Link to post
Share on other sites

1.2 is only for custom boards. 

1.1 is used for the discovery board you have.

16 hours ago, grandDD said:

yes lucky 1 I flash the STM32 firmware 2.51

That is the version of the pin2dmd firmware.

I still think it is a problem of the ST_link firmware.

The last version I used was V2.J29.M18 STM32 Debug+Mass storage.

Quote from the pin2dmd website !

!! Note : Latest Discovery boards MB997D may need a ST-Link firmware update from here


Share this post

Link to post
Share on other sites

It's working now you right i just installed the upgrade and it work well.

All my problem is solved :)

Thanks ! 

  • Upvote 1

Share this post

Link to post
Share on other sites

Hey GranDD.
Can you take a picture from the bottom side of the shield?

I still do not understand why they just work with the USB.

It makes no sense.

But I try to understand the problem and to fix it.

Share this post

Link to post
Share on other sites

Hey Uncle Sash,
all my problems are solved,
it just had to update the firmware of the STM32, it works great, so no worries with the V3 shield.......................................:)
I will soon test your V4 shield with the Nucleo for pin2DMD XL...................................;)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...