Jump to content
ScottT

Help! Upgraded to VPX4, dmdext 1.6, vpinmame 3.0 SAM, and now colorized DMDs don't work

Recommended Posts

As the title suggests, I recently upgraded VPX to the official 10.4 release, downloaded and installed the vpinmame 3.0 SAM release.  Everything seemed to work great, except any colorized DMD didn't show color anymore.  I believe DMDExt is running properly, because the DMD display looks like it, and has the white triangle resizing tab on the bottom right corner.  I found and installed the dmdext 1.6 update from github, but that doesn't seem to change anything. The pin2dmd.pal files are all in their right folders (named according to the rom names),  in the altcolor folder in vpinmame, etc.  As I said, it all worked great before the updates. 

I've reinstalled vpinmame multiple times, restarted everything (including the PC), and have confirmed the rom setttings.  Any ideas?? 

Share this post


Link to post
Share on other sites

I believe that you've overwritten dmdext with a version that doesn't have the colourization. You say you've downloaded the latest from github which is the correct thing to do, so, I'm not sure why it isn't working for you. Did you maybe put dmddevice.dll and dmddevice.ini into the wrong folder ?

Share this post


Link to post
Share on other sites

dmddevice.dll and dmddevice.ini are both in vpinmame\DMDext\

What gets me is that I can see that everything about DMDExt seems to be running great -- except for the fact that all of the DMDs are the red dots, and the resizing handle is white dots.  It's like it doesn't see or recongnize the pin2dmd.pal files.  

Is there another place I should post this question, or someone I could message directly?

 

 

Share this post


Link to post
Share on other sites

Thanks BambiPlattfuss and lucky1... I made those changes and it is working!  One mistake that I made was installing DMDExt, when all that I really needed to do was move  the dmddevice.dll and dmddevice.ini files to  my vpinmame directory.   As you pointed out, I was editing the  dmddevice.dll and dmddevice.ini files in the wrong place (in an unnecessary DMDext folder).  I  don't know if there is an official install guide (I haven't found one for my configuration, at least), but senseless wrote up a wiki at vpinball that could use some updating.  I'm happy to document my leanings if there is an official thread for this.  I'll update senseless's post, since it is a wiki and designed to be contributed to.  

Share this post


Link to post
Share on other sites

I think I had several unneccesary folders within my vpinmame folder.  I am using a third PC monitor for my DMD display.  I believe through a variety of installers, mishaps, etc. I had the following folders in my vpinmame folder that weren't needed... they are:  DMDExt,  PIN2DMD, PinDMD1, PinDMD2, and PinDMD3.  I deleted those.  I'm not sure what all caused what, but things seem to running much better now.  For example, I had problems with sound stutter that have gone away. 

Share this post


Link to post
Share on other sites

Yes. I expected you did but, since Loserman releases a ton of tables I didn't notice what Toxie said before a long time had passed. Last time I updated from 10.2 to 10.3 I used the all in one on the cab but this time I was a bit hesitant since I knew about some special fixes I've done that isn't release ready. Happy to hear you resolved it though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×