Jump to content
Flexo

Can't get VPX v.3.1 to run from Pinball X

Recommended Posts

I have been running Pinball X frontend with Visual pinball for a couple years.  I have no issues with VPX in my cabinet but I wanted to update to Version 3.1 to run some of the newer tables so I downloaded the new minimal package and copied the files in.  VPX v3.1 will load the table from the desktop but when I try to launch from Pinball X it just hangs.  None of the previous VPX tables will load nor will the newer tables.  When I copy the original VPX executable back over the newer one everything works as it should with the exception of the newer tables that require the new version.  What am I missing?  It should be simple....so whats wrong?

Share this post


Link to post
Share on other sites

Ok. Without really checking what version that is. I advice you to download your VP files from official sources.

That in general means for now. Off VPF for normal VPX releases

http://www.vpforums.org/index.php?app=downloads&showfile=11572

If you need Stern support - from this site.

... ok, there are newer version out there ... VPX 10.4 is still beta.

http://www.vpforums.org/index.php?showtopic=38450

Soon to become official - so it is kind of the right time to test it anyway.

- beware, there might be bugs ... but, well, there are bugs in all previous version of VP anyway.

-  again, beta. ... I expect this to become official really soon - so, that's why we should have more trying it.

In both cases. Running beta, means, read the info provided. Running these versions means you need to know what you're doing. You should at least know how to roll back to different versions. Yes. there exists some tables that doesn't work correctly yet without them. But, that is because authors know what they are doing and they are the driving force behind the development of new stuff.

Share this post


Link to post
Share on other sites

Thanks for the response, but I guess you skipped over the fact that VPX is and will run just not the newest version that I downloaded.  I actually did get it from vpforums but had tried other versions as well.  The link you sent me is for the same version lever I said I had.  If I upgrade to version 2 the table will hang on the loading screen just like version 3.1 (all VPX tables) I must have missed something but it a simple unzip and copy over.  I upgraded to the latest version of pinball X also thinking there could be an issue there.  I was hoping that there would be a response other that stating other that what I already know.  

 

Thanks

Flexo

Share this post


Link to post
Share on other sites

I currently run the latest and greatest of everything in my cab. Upgraded 10 minutes ago to latest VPX 10.4 beta, that one I've been holding back a little. 2 days ago I upgraded to latest PBX, was eager to try the performance improvements that was promised and yes. It is better. Latest SAM been in there since its release. No issues.

I didn't skip any fact ... told you - you need 10.4 beta if you are to run the newest stuff.  Last two sentences. Or maybe I misunderstand what you're saying ?

I don't know really what you are talking about when you say version 2 and version 3.1 ?? That is of one specific table ? Well. Don't tell me just the version of it - tell me what table and a link and maybe I can help you. I'm no mind reader.

Share this post


Link to post
Share on other sites

Really special response.  I am very proud of your ability to run all the latest, If you are not interested in helping simply don't respond.  Not new to this just missed something, sam is not required for all VPX tables so that is not the issue.  BTW did I say I wanted to have the newest?  Been running VPX since it has been official just wanted to get current for the family tomorrow.  No worries I will get it running.

 

Thanks

You're the best!

Share this post


Link to post
Share on other sites

So, what did I do to piss you off I wonder ? I still don't understand what version 2 and version 3.1 is ... so I can't really help out - sorry.

VPX is currently in 10.3.1 ... guess you find that to be 3.1. What is 2 ? - 10.2 ?

And by telling you that I can run the latest without a problem - that means, so should you. Again in fact telling you something useful. There isn't anything wrong with PBX. It is local to your installation.

Share this post


Link to post
Share on other sites

Hey Thalamus you try to be nice and help people, and you get your head bitten off by a jerk,  Sheesh.  For the record I think he meant VP10.31 but not that matters he fixed his own problem so now Flexo can go crawl back under a rock.

So Flexo having made 6 whole posts all in this thread, let me offer you some advise.  What Thalamus was asking for and going out of his way to try and help you, was simple and straightforward questions.  He was trying to help you out with YOUR problem, and advising you to update to VP 10.4  Your answers were vague and did allow anyone to help solve your issues.  I just hope your sniveling and whining has not discouraged Thalamus from helping others, as he tends to do this quite a bit on all sites.

 

Share this post


Link to post
Share on other sites

Thank you Jesper. I should have re-read the whole thread a couple of times because I in the end realised it was VPX versions he was taking about. Its all good. One sour apple isn't going to discourage me from helping out when I can. Not sure if I bother if he comes around again though :)

Share this post


Link to post
Share on other sites

Guys, I didn't mean to be an ahole but it was very frustrating to have that issue.  I knew it was something simple and was looking for the must basic problems since the cab was running for so long so well.  I had lost a bit from when I set it up and upgraded to VPX its been a couple years.  But for the benefit of anyone that may stumble across the same simple issue here is the simple answer.  Hit Alt-Tab and see if there are any errors hiding in the background, in my case I neglected to unblock the file in windows 7 and there was a prompt waiting for permission to run the file.  The cab is running even better than before.

 

Merry Christmas,

Flexo

 

Jesper,  if you had nothing to add you could have passed right by.  who's the troll?

Share this post


Link to post
Share on other sites

Well glad it's all worked out Flexo

Okay so troll is a bad term, how about inconsiderate?  I can see where you can get frustrated, especially when something works for so long then all of a sudden it does not.  My point I was adding is you were being rude to a guy that takes time out of his day to help someone out.  Nobody here gets paid to do this and we all help where we can, so man if you get some bad advice or maybe it's not the correct answer well sorry.  Why do you think I read this post in the first place? I was thinking well I can help this guy out, read your post and thought a permissions issue, or something of the like.  Then by the time you are finished I'm thinking what an ass

All I can say if you have issues in the future, let us help you by giving as much information to versions you are running etc.    Also be patient sometimes it's an easy fix, sometimes it's not

And hey now that you have upgraded to VP10.31 you should take the next step and upgrade to 10.4 as it is out of beta today.  Most of the latest releases need 10.4 to play correctly.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×