Arkadia

PinballX no Teensy Led feedback

7 posts in this topic

How can i get the PBX browsing feedback working with teensy leds?

I have the solenoids working for left and right flipper in PBX but no leds.

It seems to me that the DOF plugin is not running right in PBX, because in the B2S Screen i can not open the DOF plugin Settings. (Inside VP i can select this button.)

The PinballX DOF plugin is activated in PBX.

The Globalconfig_PinballX.xml and DirectOutput PinballX Plugin.dll is inside PinballX plugin directory. My DirectOutput folder is on drive F:\DirectOutput.

Some people reported a non working dof if the controller id or c:\DirectOutput folder is a little bit different. Also when the XML is pointing to the right path.

I have one LedWiz ID 6 and one Teensy No. 30.  (directoutputconfig6.ini + directoutputconfig30.ini but no directoutputconfig.ini because i dont have a LedWiz ID1).

Is this the problem? Teensy is always No. 30 with the Dof Tool.  I have made the 3 RGB addressable Combos like this link: http://vpuniverse.com/forums/topic/2695-configtool-big-update-for-teensy-users/

Maybe a wrong folder or a missing INI / XML for the PBX plugin???

Share this post


Link to post
Share on other sites

Update: I tested some normal RGB Led´s on the Ledwiz with PBX. This is working. The Color is changing with most tables. 

But the Direct Output PinballX Plugin.dll is still not driving the Teensy Leds.

The control led on Teensy is only blinking slow and not fast, like when receiving data. 

 

The PinballX Plugin LOG is showing no Error : 

Plugin config loaded
Initializing plugin
Loading PBX config data
PBX config data loaded
Initializing DOF
DOF initialized

The following +++ RomNames are configured in DOF: PBXWHEELLEFT,PBXWHEELPAGELEFT,PBXMENUDOWN,PBXWHEELRIGHT,PBXWHEELPAGERIGHT,PBXMENUUP
Table/RomName mapping loaded
Sending initial PBX state

Init complete
Event_Input
Action: PBXWheelRight

Action: PBXWheelLeft

 

PinballX Table Settings inside the Dof Configtool.:

Flipper Left: $PBXWheelRight/$PBXWheelPageRight/$PBXMenuUp

Flipper Right: $PBXWheelLeft/$PBXWheelPageLeft/$PBXMenuDown

 

No Teensy Led is working with PinballX.

What can i try? 

 

PS.: Found a bug when starting Champion PubDungeons and Dragons or Indiana Jones (2008) over PinballX. The PBX program will crash.

A normal VP start without PBX will run the same tables without problems. :huh: 

Share this post


Link to post
Share on other sites

double check your installation. I can't think what you could be missing. Worked first time for me. You have a cabinet.xml file?

Share this post


Link to post
Share on other sites

thank you kiwi! good to see this forum a little bit alive

I got the Teensy Leds working now! 😀 yes i had a cabinet.xml

Unchecked the admin rights for pinballx and created a new globalconfig with same setup.

After that i got light on teensy strips in pbx too. 😎 very strange!

i think this win10 admin right is blocking some needed dll or exe without reporting that in any log. And then there is no good connection between some plugins.  Everything is unblocked by the way.

But now i have got next DOF problems with DOFLinx and FX2. Same strange things here.

When i check admin rights for the DOFLinx.exe the log is reporting no tennsy (no Ftdi serial and no ports). There is just a standard solenoid feedback via the pressed Lshift + Rshift button on keyboard. No real FX2 game feedback.

When i unckeck the admin rights for doflinx.exe the log shows a good ftdi device with 8 port (this is the teensy in doflinx). But after that i got no feedback at all and no B2S feature because the doflinx.exe has no admin rights.   Aaaaaarghhh 😣

In both settings i can press button "5" and have red leds with the also connected and found ledwiz.

Doflinx seems to work a bit but not fully because of some crazy admin rights????

Is someone able to help me out of this dilemma ?

Share this post


Link to post
Share on other sites

thanks. yes i know this two helpfull links.

My VP  Status:

VP working

PBX working

PBX plugin working

DOF working

Tennsy Leds working in VP and PBX

B2S Server working in VP and PBX

DOFLinx is not working with FX2

No real B2S DOF feedback in FX2

No Teensy Leds in FX2

Something is blocking the connection between DOFLinx and DOF devices

Share this post


Link to post
Share on other sites

Update: DOFLinX working with full game feedback in FX2 :wub:

Change settings in DOFLinX.ini : PROCESS_TO_ACTIVE_TIME=30000  

This will give you full force feedback with slingshots, shaker and more...

It seems that DOFLinX needs more time to initialize the full force ;)

But how to drive the Teensy Leds with DofLinX ??  

 

Here is some relaxing pinball video after all this hustle  :lol:  

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now