Jump to content
delt31

How to set virtualDMD screen (external DMD option) for every game

Recommended Posts

Not sure right section (maybe Pin2DMD) but I have installed the freezy dmddevice.dll and can use the external DMD.  Problem is it's in the wrong section of the screen (need it on display 3).  How do I move that auto for each game instead of just 1 (by writing it in the dmddevice.ini).  Looking for the quickest way.

Also - any idea why vpx might crash upon initial startup when playing games config to show external?  They work fine if vpx loads a game and then quit and then load external DMD game.  

Share this post


Link to post
Share on other sites

OK will do - still looking into setting this external in the same spot for each game automatically as opposed to writing config for each one in ini.  

Share this post


Link to post
Share on other sites

Sorry to reply to late. I've added support for reading the DMD position from VPM's registry, so if you have positioned the DMD in VPM, dmdext's DLL will be able to reuse those values. Will be in the next release coming up the next few days.

Share this post


Link to post
Share on other sites

did this get released yet?

 

EDIT _ looks like there is an update on the website to include:

 

  • useregistry - If true, read the virtual DMD position from VPM's registry.

But I don't see it in the actual download package (that line is not there).

Share this post


Link to post
Share on other sites
On 6/20/2017 at 7:59 AM, delt31 said:

Also - any idea why vpx might crash upon initial startup when playing games config to show external?  They work fine if vpx loads a game and then quit and then load external DMD game.  

Having same problem with VPX:

ver 10.4.0 rev 3235, DMD ext 1.6 or 1.52

Steps to reproduce:

Set "twenty4_150" Rom to use DMD/Display window

Launch VPX

Open 24 table and play.

Esc-Quit Table

close table

Set "twenty4_150" Rom to use external DMD

Open 24 table and play.

Exit out of VPX

Run VPX

Open 24 Table

witness VirtualDMD lock up during rom initialization

Share this post


Link to post
Share on other sites

I Figured out some settings that eliminated my audio:

-Disable Brute-Force 4x SXSSA if you have it enabled

-Be sure both windows and external dmd are enabled in rom options.  then set backglass dmd to hidden.

This fixed all the double/stuttering audio issues for me.

Share this post


Link to post
Share on other sites

That makes sense in a way. Brute-Force 4x SXSSA will use more juice - mostly from your GPU though. But, anything that reduces the load should help out.

Happy to hear that you resolved it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×