Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
blur

Fplaunch 1.295 Wip 10

Recommended Posts

Here is FPLaunch 1.295 WIP 10.

This is full version with all images, ahk files, exe files, wav files, even pinemhi 1.1 and sample of jukebox.bat are there.

Extract this to your hyperpin folder - images should go to media folder automatically.

 

New features are:

 

1.295 wip 10
+ highscores added tnx to dna disturber, bleasby and horseyhorsey
+ custom fp and vp exe (vp/fpexetables.txt in settings dir)
+ custom b2s settings from koadic added (CustomB2STables.txt)
+ toggleLedwizKey button added to menus - tnx to deegor
+ toLog added to every function
+ external ahk script focus.exe executed on exit to focus hp
+ exitemulatorkey changed to exitkey
+ pausekey changed to exitkey1
+ exitemulatorKey2 and 3 changed to enterkey and enterkey1
+ upkey1 and downkey1 added - so now all menu keys are doubled
  (to enable keyboard and joystick keys)
+ usepausekey true/false removed (it is always used same as exit key)
+ #winactivateforce added again
+ memory leak found in hp on win7 if used in comp. mode - USE NATIVE MODE
+ taskbar problems - auto hide taskbar HAS TO BE OFF in windows
+ some images updated
+ instruction card menu item changed to instructions
+ improved error handling (winwait removed, mouse moved out of the loop)
+ jukebox support added
+ instructions moved a bit down so more of a playfield is visible
+ swf instructions will be on same position as jpg or png
+ antar bug - word (Play) makes problems - solved in vp 445
+ comments in settings are allowed
+ double focus - in script and in focus.exe
+ useFocus internal/external/both/none added to settings
+ hiscores for EM games copied from VP\user\hiscore.txt
+ options added to ledcleat.bat
+ sound is played after pf or bg images is saved
 
here is new pinmehi.ini with fixed names of "The" tables

FPLaunch1.295wip10.zip

pinemhi.ini.txt

  • Upvote 2

Share this post


Link to post
Share on other sites

+ custom b2s settings from koadic added (CustomB2STables.txt)

 

The Custom B2S is no longer needed.  Herweh built into the server where users just need to create a custom screenres.res file. They simply create a file named the same as their tablename, (IE tablename.res) and include the custom b2s options in that file. 

Share this post


Link to post
Share on other sites

You are correct dazz but there are a handful of tables that are b2s versions that don't have direct b2s versions yet. So until they come out, I for one need this feature.

Share this post


Link to post
Share on other sites

I'm having an issue with accessing instructions from within a game via the exit menu. I can access instructions and flyers no problem on the wheel screen but when I'm in a game I get the following error message:

 

2013-02-27%2019.47.32.jpg

 

I don't get this message in FP but I don't get instructions either. In FP I only get a black screen. This was from VP

Share this post


Link to post
Share on other sites

I thought I would test this as well and do not get the error but also do not get the instruction card or flyer from the Exit/Pause menu from within the game just the exiting of the menu.  But hitting "i" and "f"  from within the game works.

 

FYI Note: before adding the ledcontrol.nofeedback.ini to my VP tables dir I got an error "You are missing a ledcontrol file. Refer to the documentation to fix this."

 

Update: My above problem is only when using "1" It works fine when using "Enter" when selecting.

Share this post


Link to post
Share on other sites
FYI Note: before adding the ledcontrol.nofeedback.ini to my VP tables dir I got an error "You are missing a ledcontrol file. Refer to the documentation to fix this."

 

Oh, I saw that error too, good catch. I have that file generated even, just no plans to use it so I didn't think about it.

 

Is there something we need to set up or configure to get the new high scores box working? I'm just seeing an error about a missing file. I'll have to look up the exact wording, something about nvram maybe?

Share this post


Link to post
Share on other sites
I thought I would test this as well and do not get the error but also do not get the instruction card or flyer from the Exit/Pause menu from within the game just the exiting of the menu.  But hitting "i" and "f"  from within the game works.

FYI Note: before adding the ledcontrol.nofeedback.ini to my VP tables dir I got an error "You are missing a ledcontrol file. Refer to the documentation to fix this."

Update: My above problem is only when using "1" It works fine when using "Enter" when selecting.

 

Well if your 1 key is also a togle feedback key then of course it won't show instructions but close menus and switch ledcontrol files.

Maybe default for feedback toggle  should be key 5 instead of 1.

Share this post


Link to post
Share on other sites

My instructions key is "i" and flyer is "f".

My above error message must mean something, after I get it everything in the exit menu doesn't work and I have to hit e again to get out.

Share this post


Link to post
Share on other sites

How do you get to the menu to enable/disable night mode? I'm assuming that it's defaulted to off, but I can't figure out how to turn it on or even how to access the hi-scores.

Share this post


Link to post
Share on other sites
How do you get to the menu to enable/disable night mode? I'm assuming that it's defaulted to off, but I can't figure out how to turn it on or even how to access the hi-scores.

 

You need to hit the pause or escape button. You should see the highscores display on the pause menu.

. Also make sure you have the pinhi.ini file edited to your nvram paths like so:

 

// PINemHi ini-file created by Dna Disturber

// use this section to set the paths to FP fpram's and VP nvram's

[paths]

VP=D:\Dean\Games\Emulatori\Visual Pinball\NVRAM\

FP=D:\Dean\Games\Emulatori\Future Pinball\fpRAM\

 

Mine are different than this.

VP=C:\vpinmame\nvram\

FP=C:\Games\Future Pinball\fpRAM\

 

Next. for Forcefeedback night mode on/off:

 

. MAke sure you generate the latest config from FPwiz site. You should have 2 files. put them both in the vp/tables directory. Once this is done. Run hyperpin. hit pause or esc after you are in a game.

 

next press the "1" key. Mine is mapped to start button. Unpause into the table. Forcefeedback will still be enabled. You need to exit out of the table and the relaunch table and now only flashers will work.

 

I really hope Blur adds a menu or status to the pausemenu to tell you the nightmode is enabled as its confusing for people.

 

I will probably make a tutorial as people are still having confusion around this.

Share this post


Link to post
Share on other sites

Hey everyone,

I tried out the "new" - which is really new for me - WIP10 FP Launch and got everything installed nicely - changed the Pause routine in FP, the ESC to e thingy and everything works quite nicely. The only problem I am still having, and this was the reason for me to set up the whole thing, is the launching of various FP exe(s). I understood that I have to create the txt file fpexetables.txt in the hyperspin\folder; which I did. In there, for test reasons, I wrote in the first line "Aliens_Legacy_Pincab 1.07" , which is the FP table I would like to run with my Future Pinball 2.exe. Below that I simply added "future pinball 2.exe". However, in Hyperpin, when I launch the Aliens Legacy Table, it is started with the standard "Future Pinball.exe" file, not the alternative FP2.exe. What am I doing wrong? Do I have to change the settings.ini for Hyperpin to some extent. Is the txt file edited wrong? I would love to get some help on this one. Since I really like the FPWIP10 Version, with all its benefits and would love to get also this ultimate tweak going.

If there is a really detailed help thread (for total noobs like me) I would also love to get a hint where to find the link. This question must have been asked multiple times but I am just to stupid to find it here... Sorry

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

 

You should make sure all this handy work you're doing gets archived properly in the tutorials section:

 

http://vpuniverse.com/forums/index.php?/tutorials/

Share this post


Link to post
Share on other sites
Hey everyone,

I tried out the "new" - which is really new for me - WIP10 FP Launch and got everything installed nicely - changed the Pause routine in FP, the ESC to e thingy and everything works quite nicely. The only problem I am still having, and this was the reason for me to set up the whole thing, is the launching of various FP exe(s). I understood that I have to create the txt file fpexetables.txt in the hyperspin\folder; which I did. In there, for test reasons, I wrote in the first line "Aliens_Legacy_Pincab 1.07" , which is the FP table I would like to run with my Future Pinball 2.exe. Below that I simply added "future pinball 2.exe". However, in Hyperpin, when I launch the Aliens Legacy Table, it is started with the standard "Future Pinball.exe" file, not the alternative FP2.exe. What am I doing wrong? Do I have to change the settings.ini for Hyperpin to some extent. Is the txt file edited wrong? I would love to get some help on this one. Since I really like the FPWIP10 Version, with all its benefits and would love to get also this ultimate tweak going.

If there is a really detailed help thread (for total noobs like me) I would also love to get a hint where to find the link. This question must have been asked multiple times but I am just to stupid to find it here... Sorry

fp exe tables file goes to settings folder not hyperspin folder.

Share this post


Link to post
Share on other sites

Hey there bent98,

thank you so much for your tutorial. For noobs like me it's sometimes the simplest things that get us stumble :) Your tutorial made everything very transparant and - lo' and behold - I got everything working just fine. Thank you so much.

The only thing I am struggling with now is that the best highscore (grandchampion score) from my future pinball games/tables is not visible above the wheel image. If I understand WIP10 correctly, this feature should work, shouldn't it? But, I have to be honest, I wouldn't even know how to describe where I might have made a mistake. I just copied all the respective files as suggested and didn't change anything else (I just reprogrammed my IPAC2 because of the ESC button issue and replaced everything with "e", which works like a charm; and I also did the "right mouse button" thingy to have "pause mode" activated). Everything else, I think, works just fine.

I there anything in the hyperspin settings.ini or in the FPLaunch.ahk that I have to change from "false" to "true" to have the highscore feature or did I miss something else?

Thank you so much for helping me! The tutorial was real great!

Cheers,

Jogzter

Share this post


Link to post
Share on other sites

Ah, I just noticed post #14 and will try the above mentioned procedure. Maybe it will help also in regards of my setup. Must have skipped that info earlier. Sorry.

Share this post


Link to post
Share on other sites

I'm getting some strange behavior using the latest WIP when viewing instruction cards and flyers ingame.

When viewing flyers, the right flipper button does nothing (normally, scroll forward) and I have to double press the left flipper button each time I want to scroll through the pages.

 

When viewing Instruction cards, the card comes up as normal. But when I press a flipper button to scroll through the pages I get an error message.

 

Behavior in Hyperpin is normal...

 

 

15809876.jpg
 
Uploaded with ImageShack.us

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...