Jump to content
Hanibal2001

[New VP10 Alert] Star Trek LE Hanibals 4k Asteroid Mod 1.7

Recommended Posts

Star Trek LE Hanibals 4k Asteroid Mod 1.7


This table is base on the nice Star Trek LE table of freneticamnesic, a very nice work.
 
I have add 2 new asteroid, my first try to create 3D objects for an table.
On the original pinball game they are 2 to cover the spots and I missed them.
 
Additionally I update some lights, physics, and add the ball reflection for the game, because it looks like fantasic on this table.
 
Now it looks like very nice on my 4k virtual pinball and I hope you enjoy it  :dblthumb:

 

Share this post


Link to post
Share on other sites

Thanks guys ;)

I've just played Hanibal's mod and went through very important slowdown in Klingon Multiball mode with the red lights moving on the playfield.

I'm running on a Core i7-4470 / Geforce 1060 6 Gb / SSD 240 Gb / 16 Gb DDR3 / Win 10 x64 / VPX 10.2.1 / SAMbuild v2.9, all softwares up to date.

Can the moving red lights be disabled in the script ?

Anyway thanks for this nice little piece of VPX art ^_^

 

Edit : nevermind, I switched PewPew option from 1 to 0 to disable lasers and no more lights but smoothness is back ;)

++

Share this post


Link to post
Share on other sites

    I keep getting rom errors on this table. I have both 160 and 161h roms. . Tried them both and no deal. I have the Physmod5 version and it uses the 160 rom and plays fine--although I could never get it to run with a backglass. Love this table and would love to get it working in VP10. Any ideas? Thanks

Share this post


Link to post
Share on other sites
1 hour ago, BobAlbright said:

    I keep getting rom errors on this table. I have both 160 and 161h roms. . Tried them both and no deal. I have the Physmod5 version and it uses the 160 rom and plays fine--although I could never get it to run with a backglass. Love this table and would love to get it working in VP10. Any ideas? Thanks

Can you run the rom in the vpinmame test? I just tried the table and it works fine with 160h rom. This is the LE don't forget, so you need the LE rom.

Share this post


Link to post
Share on other sites

   The physmod5 version was also LE. And it works. I tried using the 160 rom that Frens pm5 version used and it would not run with the new vpx version. Doesn't make a lot of sense. I'm going to dl the table again...but I doubt that that will help

Share this post


Link to post
Share on other sites
1 hour ago, BobAlbright said:

   The physmod5 version was also LE. And it works. I tried using the 160 rom that Frens pm5 version used and it would not run with the new vpx version. Doesn't make a lot of sense. I'm going to dl the table again...but I doubt that that will help

I dont think the physmod5 version was LE...  Pretty sure it's just the Pro version.

Share this post


Link to post
Share on other sites

As shadowshd noted, you can disable the lasers by changing PewPew to 0 in the script, This causes crazy slowdown on my system, so I expect a lot of people will have the issue. I was going to come up with a better looking lower quality version but never got around to it, I think it just turns a red light on near the flipper if you turn it off, instead of something like 120 lights moving around the table. It runs fine on my GTX 750 but not great on my GTX 650 so there's your threshold.

Share this post


Link to post
Share on other sites
23 hours ago, freneticamnesic said:

As shadowshd noted, you can disable the lasers by changing PewPew to 0 in the script, This causes crazy slowdown on my system, so I expect a lot of people will have the issue. I was going to come up with a better looking lower quality version but never got around to it, I think it just turns a red light on near the flipper if you turn it off, instead of something like 120 lights moving around the table. It runs fine on my GTX 750 but not great on my GTX 650 so there's your threshold.

My 750 ain't happy when it sees those dots of yours Fren. But, what a light show it is. Makes me want to upgrade.

Share this post


Link to post
Share on other sites
7 hours ago, Thalamus said:

My 750 ain't happy when it sees those dots of yours Fren. But, what a light show it is. Makes me want to upgrade.

If you want the light show you can turn off 4xaa for this table and you should be able to handle it.   That's what I do for my 960.

Fortunately this table doesn't have a lot of wire ramps, so the quality doesn't suffer too much from disabling 4xaa.

 

Share this post


Link to post
Share on other sites

Great mod to an already fantastic table. Not sure what exactly you changed but it plays completely differently on my cab.

One question that I have though is on my cab it seems that when I hold down the left flipper button and launch the ball it is supposed to go around the playfield and come down to the left flipper and when launching without the left flipper button depressed it is supposed to stop at the top of the playfield and fall into the pop bumpers? On this mod for me at least it is the opposite. I loaded up Fren's original and it works as expected. Is this something I can change in the script?

Great mod, plays fantastic on my cab.

Share this post


Link to post
Share on other sites

@agwood : I was cominig back here to ask the exact same question :-)

I haven't played the original table, so, I have no idea if the loop ramp is supposed to be hard like Fren's or more like it is now. I also have noticed that on the left ramp that goes back to the left flipper there seems to be a small issue. Sometime a fast ball suddenly stops and get returned while a slower ball would get through.

I'm sure I'll figure it out.

Thank you for sharing !!

Share this post


Link to post
Share on other sites

I like this LE version alot, however if I keep the controller for VPINMAME (cController= 1),  the external flashers on my game won't work.,

If I set the game to directb2s mode (cController = 3), the external flashers work but the controlled playfield lamps stop working. Very strange.

Share this post


Link to post
Share on other sites
On 2/14/2017 at 11:20 AM, freneticamnesic said:

As shadowshd noted, you can disable the lasers by changing PewPew to 0 in the script, This causes crazy slowdown on my system, so I expect a lot of people will have the issue. I was going to come up with a better looking lower quality version but never got around to it, I think it just turns a red light on near the flipper if you turn it off, instead of something like 120 lights moving around the table. It runs fine on my GTX 750 but not great on my GTX 650 so there's your threshold.

I don't know if that's a good threshold. I don't make tables or claim to be able to make something better than what you've already made, but I have a Gtx980 and Klingon multiball wrecks it. The effect was cool and surprising as hell when i saw it. Surely there is a better way to do it? 

Awesome work on your tables btw. I'm very appreciative of all the work that you do! So thank you :)

After reading some previous posts, I do have 4x AA enabled. Perhaps that's where a lot of the slowdown comes from. Normally runs around 130fps with 4xaa. I didn't check what it was during Klingon multiball, but it had to be around 20fps

Share this post


Link to post
Share on other sites
13 hours ago, gtxjoe said:

I think you need the directb2s update or beta

Are you referring to an update to the directoutputconfig.ini? I don't use the directb2s backglass for this game just to ensure thats not a problem. I have no other games with this weird issue.

Share this post


Link to post
Share on other sites

Left Galactic Ramp is a mess, please fix it.... a shot from the right flipper hits some invisible wall that makes the ball go right back down the ramp...if you remove this wall, the ball flies out the back of the table...I have tried moving this thing around and nothing works.  Why upload the table in this state?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×