Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
CarnyPriest

SAMBuild2.9 beta thread

Recommended Posts

@lucky1 Damn, why didn't I think about that. Yepp. Your correct - this issue is related to Freezy' dmddevice and the latest change to GTS3. Would you mind reporting this to him ?

Developer to developer is better in this case I guess ;)

Share this post


Link to post
Share on other sites
35 minutes ago, Thalamus said:

@lucky1 Damn, why didn't I think about that. Yepp. Your correct - this issue is related to Freezy' dmddevice and the latest change to GTS3. Would you mind reporting this to him ?

Developer to developer is better in this case I guess ;)

He currently is busy with some other things but I´m sure he will contact me when he updates the colorization code needed for TSSP. I will tell him then.

Share this post


Link to post
Share on other sites

Dumb question but do you recommend using the 64 bit version? I'm running Windows 10 and always have used the 32 bit version but going to apply tour latest 2.9 and was going to try out the 64bit.

Sent from my SAMSUNG-SM-G935A using Tapatalk

Share this post


Link to post
Share on other sites

The 64bit VPM would be for the 64bit VPX. I haven't seen a build for 64bit VPX in many months. As I understand it, no performance benefit was observed with 64bit as things stand. I'd recommend sticking with x86 build until some new development news comes out about it.



Sent from my iPhone using Tapatalk

  • Upvote 1

Share this post


Link to post
Share on other sites
The 64bit VPM would be for the 64bit VPX. I haven't seen a build for 64bit VPX in many months. As I understand it, no performance benefit was observed with 64bit as things stand. I'd recommend sticking with x86 build until some new development news comes out about it.



Sent from my iPhone using Tapatalk


Thank You!

Sent from my SAMSUNG-SM-G935A using Tapatalk

Share this post


Link to post
Share on other sites

Thank You!

Sent from my SAMSUNG-SM-G935A using Tapatalk



That said, these 64bit builds might be used by developers for non-VP projects, such as the defunct Unity or Unreal based editors or dumping frames or sound from rom sets. I will get a 64bit build out one of these days just in case.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Just tested newest build and all tables working great I'm using the built in dmd not an external

Sent from my SAMSUNG-SM-G935A using Tapatalk

Share this post


Link to post
Share on other sites

@randr shared his vpinmame dir with me and it fixed my crashing. Must have had an extra dll or something, unsure, but works great now. with latest vpm beta

Share this post


Link to post
Share on other sites

Yeah was strange! I think between myself and fren we are above average intelligence :) and honestly was a very tough thing to get working correctly for both of us. But is working perfectly now for me too

Share this post


Link to post
Share on other sites

Thanks for the reports.

The vpinmame.dll and pinmame.exe in this package are identical to r4284. If you just use these two files and you have already installed r4284 then there is no reason to download this package.

This includes the latest dmddevice.dll for Pin2DMD and the 64bit build. The 64bit build is purely experimental. I'm not even sure it works. No way for me to test it.

 

official rev 4285
 

 

 

SAMBuild_r4285.zip

  • Upvote 2

Share this post


Link to post
Share on other sites
19 hours ago, CarnyPriest said:

The 64bit VPM would be for the 64bit VPX. I haven't seen a build for 64bit VPX in many months. As I understand it, no performance benefit was observed with 64bit as things stand. I'd recommend sticking with x86 build until some new development news comes out about it.



Sent from my iPhone using Tapatalk

Exactly. As we could not see any performance benefit, and in addition some functionality has to be disabled in 64bit mode for VPM anyway at the moment (all directx code and the AT91 JIT speedup), we did not bother too much about 64bit releases in general so far.

Share this post


Link to post
Share on other sites
On 25.5.2017 at 1:20 PM, lucky1 said:

Sounds like a issue with Freezys DLL. I also had stuttering problems lately with this dll testing a little tool that plays back dmddumps. The stuttering was gone when I used my own dll. I just played a game Rescue911 and had no issue although the display seemed a tiny bit slower compared to this video on youtube https://www.youtube.com/watch?v=Ey9fv2Yqdtw  @toxie Do you know where to tweak this ?

@Thalamus Could you please test with the pinmame internal onscreen dmd window instead of Freezys dll?

 

There is still a note in the VPM bugs.txt: Data East/Sega/Stern/Gottlieb DMD timing is not 100% accurate (although i think thats only true for GTS3 nowadays, but not really 100% sure).

Apart from that you could try experimenting with 'MDRV_CPU_ADD(M65C02, 3579000/2)' in gts3.c (and/or also the 'MDRV_CPU_ADD(M65C02, 2000000)'), maybe the clock is still off (although it should be correct from the sources i know)??

  • Upvote 1

Share this post


Link to post
Share on other sites

My Walking dead LE VPX is still having problems.  Played a game stand alone and it seemed to work fine.  Within Pinball X (even with updated dmddevice in all folders) it seems to start slowing down on the DMD.  I have disabled things in the script to make it run better to no avail.  My CPU is running at 70% absolute maximum and the RAM is running at a very low % in task manager.

It is not loading up my RAM so I wont be throwing more money into the cab. 

Strange thing was it was working perfectly in Pinball X until a month ago.

Share this post


Link to post
Share on other sites
1 hour ago, jukedock said:

My Walking dead LE VPX is still having problems.  Played a game stand alone and it seemed to work fine.  Within Pinball X (even with updated dmddevice in all folders) it seems to start slowing down on the DMD.  I have disabled things in the script to make it run better to no avail.  My CPU is running at 70% absolute maximum and the RAM is running at a very low % in task manager.

It is not loading up my RAM so I wont be throwing more money into the cab. 

Strange thing was it was working perfectly in Pinball X until a month ago.

Well, the fact that it seems to work outside of PinballX is good news. I have not had any reports of problems with LE and PinballX. 

One big change with PinballX within the past month is the addition of support for Topper videos/images. If you updated and are using this feature then that would be another tap on system resources. 

You will need to do the usual checks: Using current version of PinballX? All pinball related exe and dll unblocked and running as admin? Updated to current LAV filters? Tried configuring PinballX as windowed-full screen instead of exclusive full-screen. 

If you can live without PinballX launching the table then you can always just set up a shortcut to launch just TWD LE. If you know AutoHotkey or batch language you can also script something that PinballX launches, shuts itself down, and then when you exit the table, relaunches PinballX. PITA for one table, but seems like that would be a workaround for your situation.

Share this post


Link to post
Share on other sites

Just to chime in i have no issues with walking dead le running with latest 2.9 and pinballx.

Sent from my SAMSUNG-SM-G935A using Tapatalk

Share this post


Link to post
Share on other sites

Hi, I am having some random crashes during game play, VP just crashes and I am spat back to PinballX. I am still trying to work out exactly what is causing the issue, The crash.txt files don't seem to be giving me any useful information. I suspect it is related to versions of vpinmame as it has been the only thing I have updated recently.

I have updated my nvidia drivers and tried disabling\enabling at91jit without success.

So far I have had crashes in "Metallica Premium Monsters", "Attack From Mars", "AC\DC" and "Austin Powers". Metallica seems to be the one I can get to crash regularly, it will crash most games, the others seem very random.

What I was hoping to do is run a script that will control vpinmame.dll files, run a stable version for most of my tables, and then copy the beta in place for the newer tables that need it.

So question is, will copying the vpinmame.dll be enough, I know the recommended step when in stalling a new version is to run the setup and click install, does this do something more in the registry or somewhere else?

And before I try and re-invent the wheel, does anyone already have a script doing this, or something similar?

Thanks,

Wob

Share this post


Link to post
Share on other sites

Hi,

OK, I did some more testing tonight, I stuck to using the Metallica Premium Table for testing as it seems to be the one that crashes most often, usually within a game or two (and I am not very good, so maybe 10min max). The crash is very random, it can be at any point in the game, or even as it was doing the match number.

I am using a pin2dmd and have lucky1's latest dmddevice.dll (I updated tonight to the one from 4 days ago, but had the same issue with the release just prior to that). I am also using the colourised version of the rom (mtl_170hc). But as previously mention this is not limited to fully colourised roms, although I do use at least a basic colour patch on most tables. For reference I am also launching from pinballx using the version of XDMD that calls dmddevice.dll.

To test I have just been copying various versions of the vpinmame.dll file, I have taken no other action apart from changing this file. 

So far it does seems linked to the vpinmame.dll, if I use either 4277 or 4285 (yes I know they are technically the same) I get the crashes as above, if I use 4253 I no longer see a crash, although as expected the hammer will not work. I played half a dozen games without a crash.

I have run out of time tonight, but I will test some more tables using 4253 to see if any crash, but I was running that version since its release without any crashes. I will also do some testing outside of pinballx to eliminate that as a cause. Is there any other diagnostics I can do to test for possible conflicts?

Thanks,

Wob

  • Upvote 1

Share this post


Link to post
Share on other sites
Hi,

OK, I did some more testing tonight, I stuck to using the Metallica Premium Table for testing as it seems to be the one that crashes most often, usually within a game or two (and I am not very good, so maybe 10min max). The crash is very random, it can be at any point in the game, or even as it was doing the match number.

I am using a pin2dmd and have lucky1's latest dmddevice.dll (I updated tonight to the one from 4 days ago, but had the same issue with the release just prior to that). I am also using the colourised version of the rom (mtl_170hc). But as previously mention this is not limited to fully colourised roms, although I do use at least a basic colour patch on most tables. For reference I am also launching from pinballx using the version of XDMD that calls dmddevice.dll.

To test I have just been copying various versions of the vpinmame.dll file, I have taken no other action apart from changing this file. 

So far it does seems linked to the vpinmame.dll, if I use either 4277 or 4285 (yes I know they are technically the same) I get the crashes as above, if I use 4253 I no longer see a crash, although as expected the hammer will not work. I played half a dozen games without a crash.

I have run out of time tonight, but I will test some more tables using 4253 to see if any crash, but I was running that version since its release without any crashes. I will also do some testing outside of pinballx to eliminate that as a cause. Is there any other diagnostics I can do to test for possible conflicts?

Thanks,

Wob


You might check your windows events error log right after a crash on Metallica. I was getting this also and found it was actually a .net error. Nothing to do with SAM.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
59 minutes ago, scottywic said:


You might check your windows events error log right after a crash on Metallica. I was getting this also and found it was actually a .net error. Nothing to do with SAM.


Sent from my iPhone using Tapatalk

 

Were you able to find a fix for that?  I'm also getting a .net error after a crash as you describe, but I can't re-install Net 4.0+ as Windows says it's already on the system,etc....  I'm using Win 10 Pro

 

I also get the slow down effect of the DMD in Walking Dead LE sometimes.

 

Using PinMAME r4285, VPX 10.21, dmdext 1.5.2

Share this post


Link to post
Share on other sites

I read dmdext has issues which could be why you have slowed down dmd. Try running with internal dmd

Sent from my SAMSUNG-SM-G935A using Tapatalk

Share this post


Link to post
Share on other sites
4 hours ago, scottywic said:


You might check your windows events error log right after a crash on Metallica. I was getting this also and found it was actually a .net error. Nothing to do with SAM.


Sent from my iPhone using Tapatalk

Thanks for the hint, and you are spot on, I am getting a .NET Runtime error.

Application: VPinballX.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: exception code c0000005, exception address 01080348
Stack:

It is odd that it is only an issue with the latest vpinmame.dll files.

How did you manage to fix this?

Thanks,

Wob

Edit: I should say I am running Windows 10 Pro, with the latest "Creative Update"

Share this post


Link to post
Share on other sites

I was getting very regular crashing with Metallica LE and occasionally on TWD LE. This was using:

Using PinMAME r4285, VPX 10.21, dmdext 1.5.2 (with or without Pinball X gave same result, using coloured roms)

 

I have since tried "only" updating to the latest VPX 10.3 beta  (3089), and "so far" I haven't had any crashes with Metallica LE, or TWD LE, and the hammer, all lighting for Star Trek LE and other tables,ACDC diverter, etc....seems to be working. No crashes yet.

 

While I do have more testing to do.... it's so far so good.

Share this post


Link to post
Share on other sites

Yeah, well, there were some code that DJRobX found when he debugged Metallica crashes. That change was pushed to upstream awaiting 10.3 release. Maybe related to what you now are experiencing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...