Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
CarnyPriest

SAMBuild2.9 beta thread

Recommended Posts

2 hours ago, Ginsonic said:

According to his profile he visited this forum yesterday ! Maybe real life things, but fortunately he is still among us...

Yes, I figure if he had the time he'd respond. In this community, I don't press anyone to do anything. 

  • Upvote 2

Share this post


Link to post
Share on other sites

@CarnyPriest
What size display did you have? Not sure how close to FL you are but have a 240hz 42" Vizio lying around. There's a large speaker across the bottom but could be cut off. With all the hard work you do I could part with it but don't have money to ship it. Send DM if any interest.


Sent from my iPhone using Tapatalk

  • Upvote 2

Share this post


Link to post
Share on other sites

I'm in TX. I appreciate the offer, but I'll be OK.


Sent from my iPad using Tapatalk

  • Upvote 1

Share this post


Link to post
Share on other sites
21 hours ago, CarnyPriest said:


LE, right? No patched color code?

Have the inserts worked before? Which beta version? Did they work with the stable version, 2.8b2?

Does it work with the latest stable VPX, 10.2? Aside from FSS POV tables, I'm not aware of anything that requires 10.3. No guarantee with a beta that it will be backwards compatible.

 

I am using 10.3 because 10.2 was crashing for me randomly, 10.3 is fine.  I am using LE ROM normal, no color changing/extra stuff

just this new version r4277 is causing lights issues

Share this post


Link to post
Share on other sites
just this new version r4277 is causing lights issues



Not sure if it's r4277 or dmddevicedll. I have no issues until I use the color rom. That said the regular rom makes use of external dmd with out an issue so....? Also that said I can't code software but I can play it. Keep it up guys!


Sent from my iPhone using Tapatalk
  • Upvote 1

Share this post


Link to post
Share on other sites
Quote

I want to confirm that on a fresh start of VPX that TWD LE works properly on 2.8b, r4196, and r4253. Correct?

Correct !

Quote

And otherwise AC/DC and Metallica are working as expected with r4277? How about Spider-Man VE, Star Trek LE, and Mustang LE?

Each of them seems to work correctly under 4277 when starting them in one fresh VPX session, BUT:

When starting them sequentially within the same VPX session, AC/DC LE has problems with some tables:

  • When starting MustangLE or StartrekLE before, AC/DC misses lights and does no longer work correctly (not accepting coins and start).
  • When starting SpidermanVE or MetallicaLE before, AC/DC works like a charm

TWD currently is the only one, which does not work with 4277 when started freshly in VPX !

It seems, that they more or less influence each other, maybe actually memory issues ?

Mysterious, isn't it ? :wacko:

 

 

  • Upvote 2

Share this post


Link to post
Share on other sites

ruebsy, it is normal you don't see the bug for twd if you use the color rom because as said before it is based on the PRO rom, not the LE rom, the issue is on the LE roms that uses the extra lights bank, so i repeat it is ACDC LE, Tron LE, Star Trek LE,, TWD LE ROMS, it has nothing to do with table x or y from author z with vp10.xx.

Also, i don't recommend to use the PRO roms for LE tables, some functionalities will not work or you will see abnormal behaviour because some solenoids or switches have been added or have changed of id (the crossbow of twd le doesn't exist for the pro rom for example), for the same reason there are specific dof configs for the pro and the le roms of each table

  • Upvote 1

Share this post


Link to post
Share on other sites
6 hours ago, Ginsonic said:

Correct !

Each of them seems to work correctly under 4277 when starting them in one fresh VPX session, BUT:

When starting them sequentially within the same VPX session, AC/DC LE has problems with some tables:

  • When starting MustangLE or StartrekLE before, AC/DC misses lights and does no longer work correctly (not accepting coins and start).
  • When starting SpidermanVE or MetallicaLE before, AC/DC works like a charm

TWD currently is the only one, which does not work with 4277 when started freshly in VPX !

It seems, that they more or less influence each other, maybe actually memory issues ?

Mysterious, isn't it ? :wacko:

 

 

Memory issue, I think. Maybe requires an explicit shutdown instruction for B2S Server or VPM controller at the end of the table script? In any case, if you exit and restart VPX in between switching among these LE tables then there are no (or fewer) issues. That said, I don't know how the authors were handling this. Sounds like a PITA.

Share this post


Link to post
Share on other sites

No, the sequential starting issues are not a problem at all, since I terminate each table through PinballX anyway after playing.  It is only TWD, which annoys a bit using r4277, so I modified my AHK starting script to replace r4277 by r4253 temporarily only for TWD, until the issue with 4277 will be found. Thanks a lot for your efforts Carny !

Share this post


Link to post
Share on other sites

VPMmodSol break Fish Tales, I think there might be some custom code for the handling the wheel mech 'kickout' that isn't working

Edit: Scripted around it. I'm guessing this isn't the only ancient mech hack buried in pinmame...

Edited by GtG

Share this post


Link to post
Share on other sites

Yes, that's true, when I tried the modulated solenoids on this table, the wheel mech wasn't working.

Share this post


Link to post
Share on other sites

Confirming some of the same with TWD those flasher lights just don't work at all with 4277.  4253 is fine.  All I do is swap the vpinmame.dll to get the lights to work.  This is reproduced with 10.2.1  or 10.3,  no different.
 
just dl a brand new ROM from stern and no change.   Run the colorized DMD or not, no change. 

simply swapping out the dll fixes these lights under any of the above variable conditions.

rename vpinmame.dll vpinmame29-4277.dll
rename vpinmame29-4253.dll vpinmame.dll
 
rename vpinmame.dll vpinmame29-4253.dll
rename vpinmame29-4277.dll vpinmame.dll

 

Share this post


Link to post
Share on other sites

I do crash VPM 2.9 beta when loading color roms, if I load a non-color rom first, then the color rom, it works fine. Makes it impossible to play through the front end though. I apologize if I am missing the solution somewhere in this thread, I've got so much catching up to do.

Edited by freneticamnesic
derp

Share this post


Link to post
Share on other sites

Crash is probably related to not using latest available dmddevice.dll. I'm still not sure as to if pin2dmd users can/should use Freezy' or Lucky' version.

Sorry, wife is calling me - so, don't have time right now to find the references you probably are looking for/need.

Share this post


Link to post
Share on other sites

I've tried them all, 2.8, 2.8b, 2.9 beta r4277, and lucky's

Freezy has one? Haven't tried that one yet I suppose

Share this post


Link to post
Share on other sites

https://github.com/freezy/dmd-extensions/releases

But, I begin to think it must be something else entirely. Don't know what though :( Can't. recall seeing anyone reporting the same problem you're describing. Ah - well, I had something like what you describe myself - once, the cab needed a reboot in order to get it resolved. Still don't know why.

Share this post


Link to post
Share on other sites
12 hours ago, freneticamnesic said:

I do crash VPM 2.9 beta when loading color roms, if I load a non-color rom first, then the color rom, it works fine. Makes it impossible to play through the front end though. I apologize if I am missing the solution somewhere in this thread, I've got so much catching up to do.

Try this thread:

SAM Build with modular DMD drivers for pindmd1,2,3 and PIN2DMD

End of page 19 start of page 20.  Djrobx went into why this was happening, basically said Windows 10 fixes your issue.  Going to 10 worked for me, I know sliderpoint and dozer were having same issues. Not sure if they were able to figure anything out, seemed to be random people had issues

  • Upvote 1

Share this post


Link to post
Share on other sites
13 hours ago, freneticamnesic said:

I've tried them all, 2.8, 2.8b, 2.9 beta r4277, and lucky's

Freezy has one? Haven't tried that one yet I suppose

Yes, Freezy wrote a .NET based dmddevice.dll which has a very nice looking onscreen display and also supports all real dmds available for vpins. He started to write this driver because he bought a pindmd3 and found out that the colored roms are not working with it. Then he contacted me about the colorization code, which made me think why should I. But the next thought was it could be good for the colorization if more could join us and who cares aboutNoah anyways. Current drawback is that it is not supporting latest pin2dmd editor colorizations like TSPP but I already sent him infos about that.  It also stutters on my cab using pin2dmd while my driver runs smooth. May be caused by .NET and multithreading Freezy uses. I would recommend Freezy´s driver for LCD and pindmd3 users but mine for pin2dmd.

  • Upvote 2

Share this post


Link to post
Share on other sites

@CarnyPriest Quick test of ACDC, Metallica and TWD. All seems to be ok now on my cab with r4284. Tried two Gottieb System 3 emualations. Teed off and Rescue911. Both still have the very lagged DMD problem. @toxie mentioned a fix ? Maybe it didn't get merged ?

http://vpuniverse.com/forums/topic/2933-sambuild29-beta-thread/?do=findComment&comment=35037

 

Share this post


Link to post
Share on other sites

Weird. @lucky1 needs to comment on that one, he changed some things with regard to GTS3 DMD emulation that may cause this.

  • Upvote 1

Share this post


Link to post
Share on other sites

Yeah - you mentioned that maybe this maybe would affect freezy' dmddevice code. I'm sure lucky1 and freezy will figure it out. Thank you.

Share this post


Link to post
Share on other sites

Sounds like a issue with Freezys DLL. I also had stuttering problems lately with this dll testing a little tool that plays back dmddumps. The stuttering was gone when I used my own dll. I just played a game Rescue911 and had no issue although the display seemed a tiny bit slower compared to this video on youtube https://www.youtube.com/watch?v=Ey9fv2Yqdtw  @toxie Do you know where to tweak this ?

@Thalamus Could you please test with the pinmame internal onscreen dmd window instead of Freezys dll?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...