CarnyPriest

SAMBuild2.9 beta thread

273 posts in this topic

official rev 4253
Fix AC/DC LE solenoid 47 [DJRobX]
Fix SHA1 checksums for fg_700af and bdk_240 
 

The playfield screen on my cab crapped out, so I can't test anything at the moment. If there are still issues with the hammer for MTL LE then leave a report.

SAMBuild_r4253.zip

Share this post


Link to post
Share on other sites

Does this also fix the problem reported with the hammer in Metallica LE, that was caused by the version provided with AC/DC LE?

Share this post


Link to post
Share on other sites

 

Hello i just tested the 2.9 and it does not fix the hammer in metallica LE:unsure:

Share this post


Link to post
Share on other sites

Checked it also: the hammer is not working right with this build but:

it might not be the hammer which is causing the problem: after hitting the captive ball 5(?) times the machine says Lock is ready.

Normally when the ball is near the magnet underneath the hammer it will be enegized so it captures the ball and the hammer will slam.

But this capturing doesn't happen.   And may-be because this doesn't happen the hammer won't slam. So...it might be a coil problem..

Checked it again: first time needs 5 capt. ball hits and no: ball doesn't get captured by magnet.

Nut then you need to make 10 hits. All of a sudden when 3 hits remained for that second lock the hammer slamed and I saw the magnet move under the playfield while the ball was still somewhere else....

So, not sure what the problem is but it isn't solved with this issue... Thanks anyway for your help!

Share this post


Link to post
Share on other sites
17 hours ago, Joppnl said:

Checked it also: the hammer is not working right with this build but:

it might not be the hammer which is causing the problem: after hitting the captive ball 5(?) times the machine says Lock is ready.

Normally when the ball is near the magnet underneath the hammer it will be enegized so it captures the ball and the hammer will slam.

But this capturing doesn't happen.   And may-be because this doesn't happen the hammer won't slam. So...it might be a coil problem..

Checked it again: first time needs 5 capt. ball hits and no: ball doesn't get captured by magnet.

Nut then you need to make 10 hits. All of a sudden when 3 hits remained for that second lock the hammer slamed and I saw the magnet move under the playfield while the ball was still somewhere else....

So, not sure what the problem is but it isn't solved with this issue... Thanks anyway for your help!

To add to this.

 

In r4253 the is no slowdown in the dmd animations, but the magnet does not turn on.

 

Hope this helps..

Edited by DeWim
Ignore the parts about r4245

Share this post


Link to post
Share on other sites
On 4/16/2017 at 9:28 PM, Wob said:

Hi,

I have updated my vpinmame.dll to 13/03/17 Version and also my dmddevice.dll's to the latest (07/04/17) and now I can't get Family Guy to load at all (it just crashes if I have Colorize Rom ticket). AC/DC will also crash if I use B2S, but it will work if I use vpinmame rather than b2s at the controller.

Both tables are running from PM5, all my other colour roms are running fine.

Any ideas?

Thanks,

Wob

Hi,

I updated to 4253 but these 2 colorized roms are still giving me problem.

I have tested just inside the setup for vpinmame, if I run the Test I get the following results

1) Family Guy (fg1200af) - Will crash every time, if I untick colorize rom it will load and play fine.

2) AC/DC Pro (acd_168c) - Will crash every 2nd or 3rd time it is started, same result with colorize rom checked or unchecked.

I was using the dmddevice.dll files from frenzy's dmdext repository, but it made the colors wrong for a number of the tables (POTC, Shrek, etc) but it did work with these roms. I have switched to lucky1's pin2dmd files, all other tables I have are working fine, but no these two.

Not sure if this belongs here on in the pin2dmd thread, lucky1 seems active is this threa, but please redirect me if you would rather it moved.

Thanks,

Wob

Share this post


Link to post
Share on other sites

hammer issue also thanks for all hard work you guys do to try to fix issues 

Share this post


Link to post
Share on other sites

I have a problem with seemingly all Stern ROMS with this version as all of the ones I can actually get to load flicker badly. I can't get this to load AC/DC at all though so I could have something wrong.

 

 

 

Share this post


Link to post
Share on other sites
On 18.4.2017 at 5:19 AM, Wob said:

Hi,

I updated to 4253 but these 2 colorized roms are still giving me problem.

I have tested just inside the setup for vpinmame, if I run the Test I get the following results

1) Family Guy (fg1200af) - Will crash every time, if I untick colorize rom it will load and play fine.

2) AC/DC Pro (acd_168c) - Will crash every 2nd or 3rd time it is started, same result with colorize rom checked or unchecked.

I was using the dmddevice.dll files from frenzy's dmdext repository, but it made the colors wrong for a number of the tables (POTC, Shrek, etc) but it did work with these roms. I have switched to lucky1's pin2dmd files, all other tables I have are working fine, but no these two.

Not sure if this belongs here on in the pin2dmd thread, lucky1 seems active is this threa, but please redirect me if you would rather it moved.

Thanks,

Wob

PotC  and Shrek cant´work with the dmddevice.dll from freezy,  because the inframe colorization mechanism used by these tables is not public.
No idea why tables don´t crash with freezys dll and crash with mine.on your machine. The tables work fine on my cab.
The difference between patched and non patched ROMs is the self modifying code patch of sidechannel. This caused problems
with the jit compiler in the past. So maybe setting at91_jit  to zero helps. Use the search function to find more details about this option.

Share this post


Link to post
Share on other sites
On 18.4.2017 at 0:37 PM, AnotherRat said:

I have a problem with seemingly all Stern ROMS with this version as all of the ones I can actually get to load flicker badly. I can't get this to load AC/DC at all though so I could have something wrong.

 

 

 

Update your dmddevice.dll to the latest version

Share this post


Link to post
Share on other sites

I just downloaded the latest dmddevice.dll and the flickering is still there... it is more flashing then flickering now though.

 

Share this post


Link to post
Share on other sites
On ‎20‎/‎04‎/‎2017 at 5:06 PM, lucky1 said:

PotC  and Shrek cant´work with the dmddevice.dll from freezy,  because the inframe colorization mechanism used by these tables is not public.
No idea why tables don´t crash with freezys dll and crash with mine.on your machine. The tables work fine on my cab.
The difference between patched and non patched ROMs is the self modifying code patch of sidechannel. This caused problems
with the jit compiler in the past. So maybe setting at91_jit  to zero helps. Use the search function to find more details about this option.

 

Just got around to testing this, changing at91jit had no effect on either of these roms for me. All other colour roms are working fine.

Share this post


Link to post
Share on other sites
On ‎4‎/‎16‎/‎2017 at 10:31 PM, CarnyPriest said:

official rev 4253
Fix AC/DC LE solenoid 47 [DJRobX]
Fix SHA1 checksums for fg_700af and bdk_240 
 

The playfield screen on my cab crapped out, so I can't test anything at the moment. If there are still issues with the hammer for MTL LE then leave a report.

SAMBuild_r4253.zip

This build helped me get Star Trek LE vpx running with pf lighting, however now my older iron man and avengers loads a script error. Forgive my noobness but is this post the latest or is there something else I should be doing? With my previous build all worked but had no pf lights on ST LE..

 

 

Share this post


Link to post
Share on other sites

Scripts problems are almost always because you have two different versions laying around in your cab. I always advice people - move all your *.vbs files that you have in tables folder into scripts folder. Then run the update again - overwriting the scripts you already have. That way, you overwrite the curlprit and for the future. Don't put scripts in two separate folders. Keep them in scripts folder.

Its a reason that folder is called scripts - don't you think ? :)

Share this post


Link to post
Share on other sites

@Thalamus - not sure what you are referencing. If it is @Ruesby then this has nothing to do with vbs scripts.

Just need to rename rom files as mentioned in the latest stable release:

Also, don't refer people to the beta releases unless they are prepared to be beta testers. Most people should just use the stable releases posted in the main Downloads section (as linked above). Thanks.

Share this post


Link to post
Share on other sites

@CarnyPriest Well, there are a few tables and fixes that requires the beta. But, ok - I see you point. I will not be as quick to point people at this thread for the future. I completely forgot about the rom-name changes. Should have picked that up.

Share this post


Link to post
Share on other sites

any news about the metallica le hammer fix? somebody is looking at it?

Share this post


Link to post
Share on other sites

Thanks to you both. The naming part Thalamus speaks to, might be an issue as there's too many Star Trek tables in general. Was only having an issue with the lighting on the LE vpx version.

I do have all my scripts in the scripts file with the exception of a copy of S7 as it's needed in the tables folder for Laser Cue..Although as I'm typing this I'm thinking I might find a newer version of it or edit the table script to allow the position to be in the proper folder. It's an older one, and I'm certain I have 1 more but can't think of it as of now.

Love what you guys are doing keep up the great work, and thanks for taking the time!


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

@Ruebsy No, the issue Carny is referring to is from release 2.8 - there where changes in the code that required you to rename you rom files for avengers, x-men and iron-man. That is the reason your tables will barf when you try to load them. It is described in the release notes.

I should have picked up that this was the problem since you mentioned 2 out of 3 potential problem tables.

Share this post


Link to post
Share on other sites

What's the word on sam GI support? I'm only getting GI updates when the game tilts, no other time.

Share this post


Link to post
Share on other sites

C.S.I crashes for me if setting to use external dmd.

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

@connorsdad Tried reboot ? I've had some cases where fiddling with the settings it has worked only after a reboot. Doesn't happen often though I must admit.

Share this post


Link to post
Share on other sites

@Thalamus
I tried rebooting but it didn't help, quite a few issues with other stern tables too :/

Spiderman ve crashes vpx unless I load another table first. Big buck hunter loads in physmod 5 but if I try it inside of PinballX it crashes, change back to NONE external dmd setting and it's fine :/

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

Your real dmd, is it a Pin2dmd or ... ? Unfortunately I need to hit the sack ... work tomorrow. You have the latest sam release installed ?

Not, that I believe it is directly related, but, it is always a good idea to be running the latest stable. Makes it easier for me as well, then I know your version :)

http://vpuniverse.com/forums/files/file/4236-sambuild/

 

Share this post


Link to post
Share on other sites
Your real dmd, is it a Pin2dmd or ... ? Unfortunately I need to hit the sack ... work tomorrow. You have the latest sam release installed ?

Not, that I believe it is directly related, but, it is always a good idea to be running the latest stable. Makes it easier for me as well, then I know your version

http://vpuniverse.com/forums/files/file/4236-sambuild/

 



It's an LCD using the pin2dmd running sam from the first post in this thread.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now