85vett

Metallica Pro Fs Pm5

77 posts in this topic

In service menu goto "ADJ", then GAME feature adjustments, set Feature adjustment #125 "Music Attentuation" to -60.

That helped for me to get it louder (but really loud is something else ...)

Share this post


Link to post
Share on other sites

Thanks for this reproduction ! One of the best Stern ;)

 

I think the physics can be tweaked a little bit but, hey, you won't never replace the real thing right ? :D

 

Very nice stuff !

Share this post


Link to post
Share on other sites

Just a question since I play with desktop view I've modified the options of the backdrop. Do I have to adjust gravity constant & playfield friction too ? Does the modification of the render view have an impact on physics ?

 

Thanks in advance for your help !

Share this post


Link to post
Share on other sites

First, let me say that this table is fantastic.  85vett, you did a fabulous job on this and it is appreciated.  I particularly like the action on Sparky.

 

I am having trouble with my toys working with this table.  All other tables in my cab are working properly.  I am running Windows 7.  I have checked all the settings in the script comparing to other tables.  I have verified I have the latest version of DOF running.  I verified the Metallica table is in the config file.  I even have an older Metallica table working properly with all the toys.  I have verified I am using the proper B2S for Metallica pro.  I have tried a couple of different versions of a direct B2S backglass (LE, pro, etc.) with no luck.  This table works except for the toys using this table.  I must be missing something, but have not been able to locate it.  Any help on this issue would be greatly appreciated.  

Share this post


Link to post
Share on other sites

First, let me say that this table is fantastic.  85vett, you did a fabulous job on this and it is appreciated.  I particularly like the action on Sparky.

 

I am having trouble with my toys working with this table.  All other tables in my cab are working properly.  I am running Windows 7.  I have checked all the settings in the script comparing to other tables.  I have verified I have the latest version of DOF running.  I verified the Metallica table is in the config file.  I even have an older Metallica table working properly with all the toys.  I have verified I am using the proper B2S for Metallica pro.  I have tried a couple of different versions of a direct B2S backglass (LE, pro, etc.) with no luck.  This table works except for the toys using this table.  I must be missing something, but have not been able to locate it.  Any help on this issue would be greatly appreciated.  

 

You are not missing anything.  Table hasn't been updated for DOF yet.

Share this post


Link to post
Share on other sites

First, let me say that this table is fantastic.  85vett, you did a fabulous job on this and it is appreciated.  I particularly like the action on Sparky.

 

I am having trouble with my toys working with this table.  All other tables in my cab are working properly.  I am running Windows 7.  I have checked all the settings in the script comparing to other tables.  I have verified I have the latest version of DOF running.  I verified the Metallica table is in the config file.  I even have an older Metallica table working properly with all the toys.  I have verified I am using the proper B2S for Metallica pro.  I have tried a couple of different versions of a direct B2S backglass (LE, pro, etc.) with no luck.  This table works except for the toys using this table.  I must be missing something, but have not been able to locate it.  Any help on this issue would be greatly appreciated.  

 

You are not missing anything.  Table hasn't been updated for DOF yet.

 

 

Sorry Dazz I have to disagree with you on this one bro.  I have it working perfectly on my cab with DOF and all of the toys. It all works, all of the contactors, shaker motor, knocker, and RGB leds. No problems here.  I'm using the mtl_164 rom and the latest DOF config.ini.

 

Once again Vett, thank you very much.  This table is awesome.  I'm an old metal head and this is just fan fu**ing tastic!

 

Junky

Share this post


Link to post
Share on other sites

Perhaps you need to update your config files from the config webpage? If its rom based - which is its - it should work as long as its defined in the xml file. (afaik)

Share this post


Link to post
Share on other sites

Yes you need to hit the config site and generate a new config, the metallica config has been created and is available for everyone 

Share this post


Link to post
Share on other sites

Yes you need to hit the config site and generate a new config, the metallica config has been created and is available for everyone 

Sorry a newbie here. I dont really understand what u mean by this?

 

Im too having problems with getting the dof to work with the b2s. I can also only get mtl_163 to work but with no dof. I have downloaded the mtl_164 file and changed the name in the script like below but only get error "Game name not found". Tried changing the bin file name to mtl_164 but no luck :(

 

Const cGameName = "mtl_164" 
     Const UseSolenoids = 1
     Const UseLamps = 0
     Const UseSync = 1
     Const HandleMech = 0 
     Const SSolenoidOn = "Solenoid"
     Const SSolenoidOff = ""
     Const SCoin = "CoinIn"
 
'***********************************************
'***********************************************
' Table init.
'***********************************************
'***********************************************
 
    Dim xx
    Dim Bump1, Bump2, Bump3, Mech3bank,bsTrough,bsLHole, bsRHole,dtl,cbRight,turntable
Dim PlungerIM,LMag,RMag
 
  Sub Table1_Init
 
UpPost.Isdropped=true
With Controller
.GameName = cGameName
If Err Then MsgBox "Can't start Game " & cGameName & vbNewLine & Err.Description:Exit Sub
.SplashInfoLine = "Metallica (Stern 2013)"
.HandleKeyboard = 0
.ShowTitle = 0

Share this post


Link to post
Share on other sites

Dof config, from the configtool website where you configure dof, you need to generate a new config as metallica is a recent addition

 

if mtl_163 works and mtl_164 doesn't, are you sure you have the latest vpinmame.dll? 

Share this post


Link to post
Share on other sites

Download the bin file for metallica pro from stern. Name it mtl_164. Compress it in a zip file with the same name. Put it in your roms folder. As long as your table script says mtl_164 you should be good to go.

Go the the dof configuration website and download the latest config after you've created a login and set up the outputs to your cabinet/ledwiz/etc. Put the downloaded ini's and the xml in your vp tables folder.

Junky

Share this post


Link to post
Share on other sites

Guys any help if you can im getting the game not found error. I changed the script to mtl_164 then when I start the table it points to this line in the script

.GameName = cGameName 

 

What did I mess up... Thanks :)

Share this post


Link to post
Share on other sites

Thanks for your replies.  :)  :)

 

 

 

Download the bin file for metallica pro from stern. Name it mtl_164. Compress it in a zip file with the same name. Put it in your roms folder. As long as your table script says mtl_164 you should be good to go.
Go the the dof configuration website and download the latest config after you've created a login and set up the outputs to your cabinet/ledwiz/etc. Put the downloaded ini's and the xml in your vp tables folder.

Junky

 

I created an xml file in the table config section from choosing metallica from the dropdown list. Generated the file. Do I just put this file called "tablemappings.xml" as it is in VP tables folder for metallica to work with dof? 

I have Dof working on all my other tables. So I guess I have a working Ini file to my Ledwiz and don't need to update this, or am I wrong? 

I have not build the system and setup vp with LEDwiz. I bought it from the maker so thats why im very newbie to this. But Im eager to learn.  :)

Thanks in advance.

Share this post


Link to post
Share on other sites

Fail at line 49 with controller.

 

I'm trying to just test this on desktop and not a full table setup. How do I get around this error. 

 

(Update - Answer) Found this fix and it worked.. sorry still learning.

 

"Start with controller, if you're not using "B2S.Server" (the active backglass) then most tables you will need to change to "VPinMAME.Controller" (Search for B2S.Server in script)

Share this post


Link to post
Share on other sites

you need to change the controller to vpinmame.controller, it's default to b2s.server

 

 

Fail at line 49 with controller.

 

I'm trying to just test this on desktop and not a full table setup. How do I get around this error. 

 

(Update - Answer) Found this fix and it worked.. sorry still learning.

 

"Start with controller, if you're not using "B2S.Server" (the active backglass) then most tables you will need to change to "VPinMAME.Controller" (Search for B2S.Server in script)

Share this post


Link to post
Share on other sites

Hmm I got it all working but now im having issues getting any of my lights or flashers to work. I logged into DOFConfig, went to the Metallica table, I have to make a custom 3 flasher setup so I just cut and paste the 5 to a 3, I then generated a config file, dropped it into my folder like always but im not getting anything. I browsed the config file line by line but im not seeing Metallica in there. Is it abbreviated?

Share this post


Link to post
Share on other sites

Guys any help if you can im getting the game not found error. I changed the script to mtl_164 then when I start the table it points to this line in the script

.GameName = cGameName 

 

What did I mess up... Thanks :)

 

I was having the same problem getting this game and Mustang To run. I deleted my ROM from stern and downloaded the Roms from this site and worked like a charm. Hope this helps

Share this post


Link to post
Share on other sites

Awesome release.

Quick question, how do I turn off the solenoid sounds for the flippers and pop bumpers? I have contractors so don't really need these sounds.

Thanks!

Share this post


Link to post
Share on other sites

The BEST table EVER!    I have noticed a slight issue that I haven't seen mentioned.   For some reason I do not get my bonus on ball 2 every time?   As soon as it drains it immediately puts ball 3 in trough.   I have not seen it do that except for ball 2.   Anyone else notice that?   I am using ROM 164.   I also updated to the most recent vpinmame SAM version.

Share this post


Link to post
Share on other sites

Awesome release.

Quick question, how do I turn off the solenoid sounds for the flippers and pop bumpers? I have contractors so don't really need these sounds.

Thanks!

 

Go into the script and look for the - play sound line in the script for each flipper and each pop.  Put a ' in front of that line and that will prevent the sound from playing.

Share this post


Link to post
Share on other sites

The BEST table EVER!    I have noticed a slight issue that I haven't seen mentioned.   For some reason I do not get my bonus on ball 2 every time?   As soon as it drains it immediately puts ball 3 in trough.   I have not seen it do that except for ball 2.   Anyone else notice that?   I am using ROM 164.   I also updated to the most recent vpinmame SAM version.

 

Never had that issue nor one of my testers.  Sounds like an emulation issue for you though as when the ball drains it should be the same for all 3 balls.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now