Dazz

Cactus Canyon Continued - Proc In Vp?

457 posts in this topic

I have friends that are building real CCC machines and I'd like to have it in VP.  

 

Has anyone gotten PROC and VP to live together nicely?  If so do we have a Cactus Canyon Continued build?

 

Share this post


Link to post
Share on other sites

It should work. I never was able to get the CCC files to test it myself. There was discussion on VPF about getting it working and the changes needed for the table (really minimal, I believe it was just changing the controller in the script) - the hard part is obviously obtaining the CCC files.

Share this post


Link to post
Share on other sites

The files for CCC are available, if you know where to look. They are on the CCC site and available this whole time. ;)  I'm in the office so can't download them right now. Either way CCC files are easy to get.  I'm not sure about Judge Dredd files, but I'll check.

 

Not sure if this helps or not... http://www.pinballcontrollers.com/forum/index.php?topic=370.0

Share this post


Link to post
Share on other sites

I agree it would be fantastic to have this on the cab. I have the files but I can't get the vproc controller to work. I gave up and not without trying. Hope there is a simpler way since that is one cool project.

 

Here are some newer directions. I am told this can work with Vp 9.91 too

 

https://github.com/mjocean/proc-visual-pinball

Share this post


Link to post
Share on other sites

I don't believe the CCC files available on the site are complete, Williams sent a c&d I thought for hosting the sounds and animations, or something similar (I could be full of shit) but all the files I ever downloaded from official avenues were incomplete.

 

edit: looks like things have changed since I last tried (last winter) so this looks promising. I really wanted to finally play my cab tonight but....

Share this post


Link to post
Share on other sites

Chepas has the P-Roc controller install process down to minimal steps. Not saying that it will be easy for people who have trouble just with VP. But I'm not a developer myself, and I managed to follow directions and get it installed enough to launch the Evil Dead WIP

Share this post


Link to post
Share on other sites

The one click install in his post fails for me every time. It starts looking to use files in the P-ROC folder that it hasn't installed and it fails, I don't understand

Share this post


Link to post
Share on other sites

Fren,

I was never able to get chepas install to work either. It wouldn't help anyway its for VP10. The latest CC is a vp 9 table so you don't want the Vp10.

Take a step back and try this install:

 

https://github.com/mjocean/proc-visual-pinball

 

But instead of installing vp9.14 of course install vp 9.91 or point to your vp 9.91 folder. You should get the pyprocgame working, the problem has always been the vproc controller getting it to recognize the reset of the VP files. If you need the missing CCC files pm me.

 

The one click install in his post fails for me every time. It starts looking to use files in the P-ROC folder that it hasn't installed and it fails, I don't understand

Share this post


Link to post
Share on other sites

It wouldn't be so hard to convert it to VP10... I don't see myself touching VP9 if I don't have to!

I tried to do the manual install previously but don't recall where I stalled out... I'll try again tonight I guess :(

actually, that guide won't work either. It says to use a one-click installer and the link to that one is broken (http://proctools.catster.net/)

Share this post


Link to post
Share on other sites

That worked for me, but I could never get the table to launch when I changed the controller. The p-roc environment and python was working fine. However you get it to work, please update us! I'd like to play this on my cab too!!

Share this post


Link to post
Share on other sites

holy shit i got p-roc working

 

FOLLOW THIS GUIDE TO A T

 

http://www.pinballcontrollers.com/forum/index.php?topic=1340.msg14243#msg14243

 

then with chepas' guide from here: http://www.vpforums.org/index.php?showtopic=32197

 

do this... all credit to chepas, I've modified this to coincide with the completion of MOcean's guide

 

Check the previous install is correct by doing the following anywhere in a cmd prompt.

 

Type Python and enter to run the python environment.

import pinproc
import procgame
import pygame
print pinproc.EventTypeBurstSwitchOpen

You should see a 6 in return

 

Install the PyProcGameHD SDL2 dependencies.

 

  Download PySDL2 = https://bitbucket.or...ySDL2-0.9.3.zip

  Extract & install with cmd prompt.. (I extracted this to the P-ROC folder)

OPEN A COMMAND WINDOW IN THIS FOLDER (open the PySDL2 folder, hold down shift, and Open Command Window Here) and type

python setup.py install

Download following files & extract to C:\P-ROC\DLLS :

Copy the contents of the two zip files to this folder first, then copy the third link, the dll, to the folder and overwrite the existing dll

https://www.libsdl.o...3-win32-x86.zip

https://www.libsdl.o...2-win32-x86.zip

Updated sdl font : https://www.dropbox....L2_ttf.dll?dl=0

 

Install this:

PIL Libary http://effbot.org/do...win32-py2.6.exe

 

PyOSC module

Extract this folder to the P-ROC folder

https://pypi.python.org/pypi/pyOSC

OPEN A COMMAND WINDOW IN THIS FOLDER (open the pyOSC-0.3.5b-5294 folder, hold down shift, and Open Command Window Here) and type

python setup.py install

Download the ZIP of Moceans GitHub project here

https://github.com/m...hive/master.zip

 

Extract it to the P-ROC folder

 

OPEN A COMMAND WINDOW IN THIS FOLDER (open the PyProcGameHD-SkeletonGame-master folder, hold down shift, and Open Command Window Here) and type

python setup.py develop

Setting up the VP_Com Bridge for VP

 

You will need to install Python extensions for Windows. Pywin32 2.6. If this install fails at any point try an older version. But HAS to be 2.6 & 32bit.

http://sourceforge.n....6.exe/download

 

https://github.com/m...-visual-pinball

Download the following files from moceans git and extract into C:\P-ROC\tools

Easy download https://github.com/m...hive/master.zip

 

Move the vp_game_map.yaml into C:\P-ROC\Shared\Config

 

Navigate to C:\P-ROC\tools.  Open a command prompt in this window the same you have been doing and type

python register_vpcom.py --register

Ignore other errors here if you have any, but important to look for :

Registered: VPROC.Controller

 

===========================================================================

End Pyprocgame setup.

===========================================================================

 

 

VP Setup:

1. Create a new VP10 installation  in  C:\P-ROC\Visual Pinball (this is only needed because of the inclusion of other VBS, however I believe this can be worked around by renaming the VBS that you need and having a separate set for P-ROC... as I can launch games just fine from my default VP install directory)

Any games you create or download can go in a tables directory here. You need older versions of the VB scripts, so don't extract the vbs.zip shipped with VP10.

P-roc vbs Scripts (into C:\P-ROC\Visual Pinball\Tables)

https://www.dropbox....cripts.zip?dl=0

(if you only want to run CCC then grab that VBS folder and copy the wpc.vbs file, rename it something like ccc-wpc.vbs and save it in your default scripts folder)

 

2.

Create a directory in C:\P-ROC\Games\ called SkeletonVP10

 

Download these files and put the files from the included SkeletonProcVisualPinball10-master folder into this new directory (SkeletonVP10) you've created. 

https://github.com/h...VisualPinball10

Easy Download: https://github.com/h...hive/master.zip

 

Copy the config.yaml from this game folder into C:\Users\Admin\.pyprocgame (or other directory name...you can find it easy)

 

For the bridge to recognize this game folder you need to add this Template game into the vp_game_map.yaml see the following:

SkeletonProc:
path: /../games/SkeletonVP10
kls: Game.Game
yaml: /../games/SkeletonVP10/config/GameConfig.yaml

Move the table that should be here C:\P-ROC\Games\SkeletonVP10\VisualPinball\SkeletonProc.vpx into C:\P-ROC\Visual Pinball\Tables (or your default directory if you're going that route...I am personally)

 

Load the table from the new VP10 installation folder and if all is ok you should get an R6034 error which you can just dismiss by clicking or pushing enter.

 

You can automate this with the autohotkey script that was in the download.

https://github.com/h...rocLaunchVP.ahk

 

=========================================================

End VP setup

========================================================

Share this post


Link to post
Share on other sites

Well I can't get CCC or JD working, I believe I have all the files. I can only get the skeleton game from chepas to work.

Share this post


Link to post
Share on other sites

My god Fren, that sure is some extensive guide!! :)

Really hope you get though with CCC and/or JD, thanks for the update

Cheers

Share this post


Link to post
Share on other sites

I was able to get the Skeleton table to run.  But not JD, I think I'm missing something there.

 

But...  I see that the CCC game code is available, but the DMD and audio are not, but says they are required for it to run.  Anybody have those?  

 

-Mike

Share this post


Link to post
Share on other sites

post the error you are getting with CCC. I have the DMD display working with CCC in p-roc mode, but I don't have the VP/p-roc working.

Share this post


Link to post
Share on other sites

maybe an incorrect path in your vp_game_map.yaml

What version of CC are you trying? One you converted to VP10 or one of the several VP9 versions? Check paths, file names, etc.

Share this post


Link to post
Share on other sites

just a vp9 version, the high noon mod

also tried vp10 version of judge dredd

i've tinkered with that damn yaml file left and right, tried new game names, tried the default one, the one part that confuses me though is kls:

the default yaml has "game.CCGame" for CCC, and "jd.Game" for dredd but I don't know what these relate to. The skeleton game is just "Game.Game" and it works, I don't know if this is a file or what, I can't find it lol

then the cc.yaml, it says "seems to be ignored anyway" and I don't see it anywhere anyways... there's an actual config for the skeleton game though, and the only yaml files I have for ccc are cc_machine.yaml, game_data_template.yaml, and settings_Template.yaml - I copied over the GameConfig.yaml from the skeleton game hoping that would solve something but no dice

 

with judge dredd at least I get the runtime error that i get with the skeleton game before it works, but then it goes into the python errors

Share this post


Link to post
Share on other sites

I think the problem is in C:\Users\Sprinter\.pyprocgame with the config.yaml - it's set up for the skeleton game. Do you have one that will work with ccc/jd?

Share this post


Link to post
Share on other sites

So here is how it works.

The cc machine yaml is for the real game to identify the switches, lamps and solenoids.

The config.yaml identifies the p-roc settings for its environment for temp files, fonts, and some other things.

 

Like I said, the problem is where does the vp bridge look for files. I am unable to determine if its in the p-roc folder, the users folder, etc. Very confusing.

I also looks in c:\p-roc\shared

 

No I don't have a config file that works with the bridge, but this one definately works if you run the game without VP.

 
config.yaml ( I have this setup to test switches and gameplay from p-roc (nothing to do with vp) using my keyboard). I can see all of the animations and test the game in fake p-roc mode but outside of VP.
 
font_path:
    - .
    - ~/P-ROC/shared/dmd
 
# Uncomment the following line to use a virtual P-ROC instead of running on real hardware.
pinproc_class: procgame.fakepinproc.FakePinPROC
 
config_path:
    - ~/P-ROC/shared/config
 
keyboard_switch_map:
    # Enter, Up, Down, Exit
    7: enter
    8: down
    9: up
    0: exit
    # Start:
    q: leftOutlane
    w: rightReturnLane
    e: rightOutlane
    r: bottomRightStandUp
    t: beerMug
    y: topRightStandUp
    u: rightSlingshot
    i: leftJetBumper
    o: rightJetBumper
    c: rightLoopTop
    a: rightBonusLane
    s: startButton #SD15
    d: rightRampMake
    f: rightRampEnter
    g: saloonBart
    h: leftLoopTop
    j: leftRampEnter
    k: minePopper
    l: centerRampMake
    z: shooterLane
    x: mineEntrance
    c: troughEject
    v: skillBowl
    b: saloonGate
    n: centerRampMake
    m: badGuySW2
    \: SD1
 
use_desktop: True
color_desktop: True
desktop_dmd_scale: 1
 
# Where you want your log file to go. Use "stdout" for then screen.
log_destination: ./log.text
vp_game_map_file: /P-ROC/pyprocgame-master/vp_game_map.yaml # Change this to where you create your map file
 

I think the problem is in C:\Users\Sprinter\.pyprocgame with the config.yaml - it's set up for the skeleton game. Do you have one that will work with ccc/jd?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now