Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
lucky1

Pin2Dmd Real Pinball Support

Recommended Posts

My next trick is it is in Virtual Pinball mode and I don't know how to change it to DATAEAST mode.

Share this post


Link to post
Share on other sites

So I've got everything updated and functioning, but after adding the color files for WWF Royal Rumble, I'm not getting full color, just default palette. As of right now the sd card contains in its root: pin2dmd.fsq, pin2dmd.pal, pin2dmd.key, and pin2dmd.dat. Did I forget to add something or check a setting or something?

Share this post


Link to post
Share on other sites
On 4/13/2019 at 11:09 PM, lucky1 said:

The 74LS123 is the signal enhancer for real pinball machines.

 

Hi

I followed your advice and bought a chip HD74LS123P

when I install it I change the place jumper and when I start it does not detect my micro SD card and it changes the color of the display

when I remove it and put it back as before it works

Thanks

20190418_174539.jpg

Share this post


Link to post
Share on other sites

You also need to let the software know that it is installed by setting the enhancer in the onscreen menu to on !!

Share this post


Link to post
Share on other sites

 

Thank you

I test today I just put the chip, I do not change the jumper, and i put enhancer ON

 

 

I install the chip, change the jumper and restart, with the world enhancer in ON it does not detect my SD card and the display has more standard colors I do not understand

Share this post


Link to post
Share on other sites

Hi All

I am pretty new to all of this so I would be grateful for any help. I have a pin2dmd evo board based on Lucky's posted designs and in conjunction have purchased a 128x16 controller board for a Data East system from german gaming supplies (since i have a Checkpoint pin that i want to get working with pin2dmd). I have tried to follow all of the instructions as posted on the pin2dmd site and everything seems to have worked fine but I seem to be getting stuck at the boot screen when connected to the pin. I have tried all of the obvious things like changing connectors/checking ribbon connections etc. Can anyone suggest any troubleshooting that I can try? Since the screen powers on and I can change palettes/brightness and everything else on the on-screen menus as well as via the micro-usb and laptop I am assuming the issue might be with the 128x16 controller board? Any ideas how I could confirm this?

I would appreciate any help.

Share this post


Link to post
Share on other sites
7 hours ago, Rdcheckpoint said:

Hi All

I am pretty new to all of this so I would be grateful for any help. I have a pin2dmd evo board based on Lucky's posted designs and in conjunction have purchased a 128x16 controller board for a Data East system from german gaming supplies (since i have a Checkpoint pin that i want to get working with pin2dmd). I have tried to follow all of the instructions as posted on the pin2dmd site and everything seems to have worked fine but I seem to be getting stuck at the boot screen when connected to the pin. I have tried all of the obvious things like changing connectors/checking ribbon connections etc. Can anyone suggest any troubleshooting that I can try? Since the screen powers on and I can change palettes/brightness and everything else on the on-screen menus as well as via the micro-usb and laptop I am assuming the issue might be with the 128x16 controller board? Any ideas how I could confirm this?

I would appreciate any help.

For checkpoint you need to set enhancer to off in the onscreen settings.

Share this post


Link to post
Share on other sites

First off thanks to everybody who helped me get this far and all the hard work for the community.  Here is my issue.

I have a  Pin2DMD EVO board loaded with firmware 3.05 and activated.  Pics are on this post. https://pinside.com/pinball/market/classifieds/archive/90587

For the first time my Pin2Dmd shows signs of life.  However,  using the  colorization files from CB3, the hulkster on my DE Royal Rumble looks like he has a rash or took to many chair shots to the head  as you can see in the image below.  The ribbon cable's red line is on 1 on the DMD driver board and my regular DMD works fine. I've also  cycled though all the RGB options as well and on each one the skin tones are just not there.  Hopefully this is an easy fix and any help would be much appreciated.  

 

DE_RR_Pin2DMD.jpg

Share this post


Link to post
Share on other sites

Are you sure you have the files for Real Pinball installed ? Those for VPIN are different from the real pinball files.

You need to PM CB3 to get the real pinball files

Share this post


Link to post
Share on other sites

Works great now. I needed to change the files names CB3 hooked me up with to pin2dmd.pal and pin2dmd.fsq 

Share this post


Link to post
Share on other sites

Hi, I have some real pins with pin2dmd. Now, We stay at home and it's time for me to continue my Attack form mars colorisation. I'm french and I decided to make my own colorisation. There is a lot of work and I have a big problem since 2.57 to 3.xx and new version of editor. I don't know if the problem is pin2dmd version or editor. Before update, no problem with freeze at all. So hardware is not the problem. Dump is made by me.

When a screen appear like "presente" or another screen with score and freeplay. The pin2dmd freeze. If I reset with button, pin2dmd restart normaly since one of these screen appear. I change STM32 with another one but same problem. I change microSD but same problem. I think, there is a bug with my colorisation file. I don't know where I can begin to search. I can send file if need.

Share this post


Link to post
Share on other sites
2 hours ago, Tiberium said:

Hi, I have some real pins with pin2dmd. Now, We stay at home and it's time for me to continue my Attack form mars colorisation. I'm french and I decided to make my own colorisation. There is a lot of work and I have a big problem since 2.57 to 3.xx and new version of editor. I don't know if the problem is pin2dmd version or editor. Before update, no problem with freeze at all. So hardware is not the problem. Dump is made by me.

When a screen appear like "presente" or another screen with score and freeplay. The pin2dmd freeze. If I reset with button, pin2dmd restart normaly since one of these screen appear. I change STM32 with another one but same problem. I change microSD but same problem. I think, there is a bug with my colorisation file. I don't know where I can begin to search. I can send file if need.

Upload your project somewhere and send me the link

Share this post


Link to post
Share on other sites

hello 

 

i have a question !

 

setup

pinball : kiss ( spike 1) , shield v3.1 , stm362 discovery , colorprism  3.11

editor : 2.5.0.6 at 07/04/2020

 

my probleme :

When i push the left button for go back.
the palette does not return by default.
What is my mistake?
Only the high score should be changed , the other slide are by default

 

 

 
 
 
 

image.thumb.png.84d02d8acacfbb1dada36a14bbc3ee34.png

 

 

 

Share this post


Link to post
Share on other sites

I guess you used a single frame colormask which is only stopped to be applied when the delay time is over or a new keyframe triggers.
Try to set a keyframe for every frame before and after with a switch to the default  palette and it should work.

Share this post


Link to post
Share on other sites

thank for your reply

 

 

 

what i can change the delay ?

 

example ; on t2 dump , this frame have delay=16

image.png.7aae94c5c61b200e4a6048b05bd389cd.png

 

 

on the kiss dump : the delay of this frame  is 1981 !

 

i think , it is this delay witch is too long , and i can not change this value 

image.png.3bf2582e15f59d58cd7de7bbaab6d712.png

 

Share this post


Link to post
Share on other sites

You only can change the delay in the scene. You did not select the scene but the keyframe !

Share this post


Link to post
Share on other sites

ok i understand !

only the "enter" key works.
the enter key on the numeric keypad does not validate the value

can you check this ?

Share this post


Link to post
Share on other sites

I am trying to update the firmware on my pin2dmd display. I have download the dfu file / program as instructed and the program loads as it should. When I connect the display  to my PC it does seem the recognise the display, I can see the display is connected as it shows as pin2dmd in device manager.  I have moved the boot dip switch and still no joy. I am not sure how I can get the program to recognise the display, any suggestions welcome

Share this post


Link to post
Share on other sites
57 minutes ago, Banzaipinball said:

I am trying to update the firmware on my pin2dmd display. I have download the dfu file / program as instructed and the program loads as it should. When I connect the display  to my PC it does seem the recognise the display, I can see the display is connected as it shows as pin2dmd in device manager.  I have moved the boot dip switch and still no joy. I am not sure how I can get the program to recognise the display, any suggestions welcome

Can you make a picture of your hardware, that we know what you are talking about ? My pin2dmd designs never got dip switches, so I suppose it is some kind of custom hardware.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...