Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
lucky1

Pin2Dmd Editor

Recommended Posts

Had another write error while opening a recently saved file today like I mentioned on the pinside WCS94 colorization thread, kept the corrupt files this time.  Saved to a USB key, only added two scenes and keyframes and two palate switches.  Did a sort on both the keyframes and scenes right before saving the project as a new version.  Looks like it wrote a bunch of NULs at the end of the script this time.  Running the 64 bit version on a windows 8 computer, editor version is from April 20th this year.  All the animations are up on my google drive:  https://drive.google.com/open?id=15F5QfX8MM-i6xUO8srj1fVqNOkUsuU_k

Screenshot (16).png

WCS94 KO 22.ani WCS94 KO 22.xml

Share this post


Link to post
Share on other sites

Do you have the logfile from the crash ?  It should be in C:\Users\Username\AppData\Local\Temp. 
Here is the fixed version of your project

WCS94 KO 22.xml

Share this post


Link to post
Share on other sites

Unfortunately the logging did not show anything helpful.

Share this post


Link to post
Share on other sites

That's too bad, must be something with my computer or the way I'm saving it.  I do have quite a few large animations in the file.  I've noticed it takes longer than it used to for loading and saving.  I'll post again with the logs if it happens again.  Thanks for fixing that file for me and looking into it.

Share this post


Link to post
Share on other sites
5 hours ago, KOAmps said:

That's too bad, must be something with my computer or the way I'm saving it.  I do have quite a few large animations in the file.  I've noticed it takes longer than it used to for loading and saving.  I'll post again with the logs if it happens again.  Thanks for fixing that file for me and looking into it.

It crashed when saving the detection masks, so it has nothing to do with the number or the size of animations.

Share this post


Link to post
Share on other sites

Just starting on my first colourisation and was thinking if there was a way of copying and pasting a section of the frame rather than the whole frame.

The game I am doing is Tales from the Crypt and several scenes have one object moving but the Keeper's face remains the same throughout.

This would save a lot of manual colouring

Share this post


Link to post
Share on other sites

Sure, you can copy a part of a frame by selecting the rectangular icon, drawing a frame and then cops&paste it

72d46b833c2d61e47533fe7f27086a86.jpg

Share this post


Link to post
Share on other sites

I tried that but it pasted the whole frame

What I did was

Select the require area with the rectangle tool

Control-C

select next frame

Control-V

I also tried using the buttons on the top right  under the palette selection but they didn't seem to do anything

Share this post


Link to post
Share on other sites
29 minutes ago, SpaceGambler said:

I tried that but it pasted the whole frame

What I did was

Select the require area with the rectangle tool

Control-C

select next frame

Control-V

I also tried using the buttons on the top right  under the palette selection but they didn't seem to do anything

Try shift-ctrl-V and click into the drawing window

The buttons on the top right are described  here https://pin2dmd.com/chapter-2-coloring-non-dynamic-content-scenes-in-replace-mode/

Share this post


Link to post
Share on other sites

OK thanks,  got it working

I selected the required area then

ctrl-C

move to next frame

ctrl-shift-V

I then click in the bottom corner of the frame and drag the copied area to it's correct place.

Where you release the left mouse button is where it is placed, to correct an incorrect placement ctrl-V before leaving the frame

Share this post


Link to post
Share on other sites

I uploaded a new version to google drive.

https://drive.google.com/drive/folders/18wNl_JbPW4XbvLkJQbT_s_DhHZqwq9CI

I have added a Add2Scene button for easier creation of frame collections needed for e.g. Colormask Layered mode.

Description is integrated here https://pin2dmd.com/chapter-8-advanced-coloring-using-colormask-layered-mode/

 

  • Like 1

Share this post


Link to post
Share on other sites

i am using the newest version but often my palettes dont get saved to the right scene. maybe a error in my xml or something. can you help me? tried to contact you via FB

Share this post


Link to post
Share on other sites
9 hours ago, nbcrew said:

i am using the newest version but often my palettes dont get saved to the right scene. maybe a error in my xml or something. can you help me? tried to contact you via FB

Upload the project somewhere and send me the link

Share this post


Link to post
Share on other sites

I was trying to create a 4 color palette using the editor and what i think was the color prism. I now have an issue, display just shows pin2dmd logo and states stern spike, will not fully boot. It states it is not activated, albeit the key file is still on SD card. I did select reset from menu. any ideas to fix?

Share this post


Link to post
Share on other sites
1 hour ago, Banzaipinball said:

I was trying to create a 4 color palette using the editor and what i think was the color prism. I now have an issue, display just shows pin2dmd logo and states stern spike, will not fully boot. It states it is not activated, albeit the key file is still on SD card. I did select reset from menu. any ideas to fix?

That sounds like multiple problems and not enough information.

4 colors palette and Spike pinball ? Spike needs 16 colors ! Is it a Spike pinball machine ?
Key on the SD and not activated = wrong key or keyfile not named correctly. ONLY keys starting with # must be renamed to pin2dmd.key

Share this post


Link to post
Share on other sites

@lucky1

 

can you disable the "pallet already exists"  error ?

I enabled the "Create palette after cutting"  in the Settings menu

simply because I did not want to go trough each individual scene and

then create and then assign a pallet.

 

but when I saved, closed and re opened the project  I got the "pallet already exists"  error for each scene I cut

and each scene I cut and had its  own individual pallet assigned  was reassigned the  pal0  witch is the only pallet I started with.

 

 

Share this post


Link to post
Share on other sites
9 hours ago, Pinballuser said:

@lucky1

 

can you disable the "pallet already exists"  error ?

I enabled the "Create palette after cutting"  in the Settings menu

simply because I did not want to go trough each individual scene and

then create and then assign a pallet.

 

but when I saved, closed and re opened the project  I got the "pallet already exists"  error for each scene I cut

and each scene I cut and had its  own individual pallet assigned  was reassigned the  pal0  witch is the only pallet I started with.

 

 

To generate a palette for every scene does not make any sense. To save memory you should learn to reuse palettes as often as possible.

Just disable "Create palette after cutting" as it is the wrong approach to start a new project anyway.

Share this post


Link to post
Share on other sites

its also a wrong approach to cut a scene and  color it before making sure that the  keyframe for that scene works.

I found that  scenes are shown with pal0  when the key frame does not work.

My approach is to  cut a few 100 scenes assign a  pallet other then pal0 -->  test all the scenes I cut.

Once I confirmed that the keyframes work,  I can worry about coloring or merging pallets.

 

The reason I enabled "Create palette after cutting" is so that I don't have to assign a pallet to every single scene I cut.

if we had a feature that automatically assigns pal1 or any pallet of my choosing to every single scene I cut.

or

a keyboard shortcut to  assign a pallet to the scene for a more streamline approach

like pressing the pallet button and a pop up appears where I can enter a pallet number rather then scrolling down the pallet  menu and then pressing the pallet button

or

a feature that lets us assign a pallet number to the scene when we cut it  (as shown in the pic)

the problem would go away

 

 

Capture.PNG

Share this post


Link to post
Share on other sites
5 hours ago, Pinballuser said:

I found that  scenes are shown with pal0  when the key frame does not work.

Scenes that don´t work use the palette which is set as Default. If you change the default palette after you have cut all your scenes should give you what you want.

Share this post


Link to post
Share on other sites

Hi all,

My first time trying to run pin2dmd-editor.  The window pops up to tell me it is loading, but then it disappears and nothing else happens.  I have read that this is possibly a java error.

I am running Windows 10 Home 64-bit.  I have pin2dmd-editor64.exe downloaded

My java is...

F:\java -version
java version “1.8.0_261”
Java SE Runtime Environment (build 1.8.0_261-b12)
Java HotSpot 64-Bit Server VM (build 25.261-b12, mixed mode)

 

Do I try the 32 bit version?  I see there is a link on page one in a post of this thread referencing another java link.

BTW, I turned off all anti-virus software and even disabled my firewalls on a whim.

Share this post


Link to post
Share on other sites
3 hours ago, Fifty said:

Hi all,

My first time trying to run pin2dmd-editor.  The window pops up to tell me it is loading, but then it disappears and nothing else happens.  I have read that this is possibly a java error.

I am running Windows 10 Home 64-bit.  I have pin2dmd-editor64.exe downloaded

My java is...

F:\java -version
java version “1.8.0_261”
Java SE Runtime Environment (build 1.8.0_261-b12)
Java HotSpot 64-Bit Server VM (build 25.261-b12, mixed mode)

 

Do I try the 32 bit version?  I see there is a link on page one in a post of this thread referencing another java link.

BTW, I turned off all anti-virus software and even disabled my firewalls on a whim.

That is exactly the version I´m running. Should work. Did you try to start as admin ?

Share this post


Link to post
Share on other sites
10 hours ago, lucky1 said:

That is exactly the version I´m running. Should work. Did you try to start as admin ?

I did not.  I was able to get it to load once.  Long enough to register using the key I was provided.  It crashed after that.

I gave up on it and moved over to my work laptop.  My work laptop uses Windows 10 Pro.  Once Java upgraded I was able to launch the editor without any issues.  It launches without any problems every time now.  I am not sure what the problem was with my home PC.

I registered the key on my work laptop.  Do I need to deregister on my home PC?  When I try to load the .raw dump file from my CFTBL (attraction screens) the program goes into (Not Responding) mode and I get this error.

error.JPG

 

[EDIT] I got it loaded.  I was compressing the .raw file to a .gz  I did not know it was the .txt that need to be compressed and loaded.  What is the .raw file used for?

Edited by Fifty
Got it loaded and working.

Share this post


Link to post
Share on other sites

Both RAW and TXT files should be gzipped. Maybe your RAW file is corrupted ?

Share this post


Link to post
Share on other sites
36 minutes ago, lucky1 said:

Both RAW and TXT files should be gzipped. Maybe your RAW file is corrupted ?

I gzipped the RAW file and tried again.  Same error as before.  When colourizing, you use the gzipped RAW file correct?  Not the TXT.

Why would the TXT work and not the RAW if they are from the same dump?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...