Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Romuluz

Sam Stutter

Recommended Posts

Hello,

 

I have a Tablet PC which i use for playing Pinball while at Train or such. First i had a Dell Venue 8 Pro (2 Core, 1,33GHZ, 2GB Ram), now i have an Akoya (Medion/Aldi) which has much better processing power (4 Core, 1,83 GHZ, 4GB). As was the case with the Dell, all Tables i throw on it run well, except the SAM Ones. They run too, but they have an awful Audio Stutter. I had hoped that the better Machine would get rid of that performance Problem, but unfortunately it doesn't.

 

Since i can't do anything about it, i would like to ask if it is possible to modify something on VPinmame itself, possibly a feature for something like "Frameskipping" or something similar (i would have asked Arngrim via PN, but his Box seems to be full)

 

If that is not the Case, then would there be a possible Solution with Samples? I've noticed that in LOTR that had been done.

 

Or... has someone another solution (opposite from getting a better Device) for this Problem?

 

Kind Regards

Romuluz

Share this post


Link to post
Share on other sites

grab the latest dll, that's all i can say, i am not a vpm dev, just put pieces together :)

Share this post


Link to post
Share on other sites

Hey Arngrim,

 

i do have the latest DLL :( My Comment wasn't meant as criticism. If you can't do anything about, then so it is! Keep up your good work :)

Share this post


Link to post
Share on other sites

i am not offended, no worries, just tell the reality, i am already glad i could make it work :)

Share this post


Link to post
Share on other sites

You can enable frameskipping for vpinmame, click on the dmd and press f9 or f10 try some of them can't remember exactly which. But it doesn't help at all, I think that is because the display part is the least demanding part of the emulation.

Share this post


Link to post
Share on other sites

I had the same sound problems on my I7, all  sam tables with echo/double-sound. It seems to be a problem on some multi-core CPUs.

My Hardware:      I7-4790K @ 4 GHz/ GTX970 / 16GB ram.

My 2nd  System:  I5 @ 3,2 GHz / GT620 / 8GB ram.

OS on both:  Windows 10 / 64-Bit.

 

I had no sound problems on my I5, only on my I7.

My solution:

While playing a sam table pause the game and  start TaskManager. All CPU cores were checked. After uncheck all except CPU 0 the problem was gone.

 

Find it out:

 

1. Start VP - open table - play

2. Pause the game and open TaskManager (ctrl-shift-esc)

3. Right-Click on the VP app (eg. VPinball991) - Go to details -

4. Under details again right-click on the app and choose set affinity

5. In the Processor Affinity window uncheck all CPU cores but leave the ones for CPU 0 (hex=1)

6. Click ok to save the settings

7. Close the TaskManager Box and  resume game

8. The effect is immediate - echo / double sound is gone

 

 

Close / Open VP or restarting the computer will revert the changes.
To assign specific processor cores for the VP app in Windows 10 create a shortcut to run VP app with a set CPU affinity in Windows:

 

- right click on an empty area of your desktop, and click on New and Shortcut.

- Type the command below into the location area:

  cmd.exe
/c start "VP sam tables" /affinity 1 "Full path of application file"  (your path in quotes)

 

- click next and OK to save the shortcut, in the properties of the shortcut  the command should be:

 

 C:\Windows\System32\cmd.exe /c start " VP sam tables " /affinity 1 "D:\Pinball\Visual Pinball\VPinball991.exe"

 

Double-click on Shortcut, open and play all sam tables without sound problems.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...